Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250620 - app-crypt/calcchecksum fails to build with gcc 4.3
Summary: app-crypt/calcchecksum fails to build with gcc 4.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
: 227041 (view as bug list)
Depends on:
Blocks: gcc-4.3
  Show dependency tree
 
Reported: 2008-12-11 14:51 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-13 23:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (calcchecksum-1.6_pre1:20081211-144752.log,99.66 KB, text/plain)
2008-12-11 14:51 UTC, Diego Elio Pettenò (RETIRED)
Details
Patch to fix missing includes (calcchecksum-gcc-4.3.patch,539 bytes, patch)
2008-12-11 15:22 UTC, Martin Väth
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-11 14:51:30 UTC
Check attached build log.
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-11 14:51:53 UTC
Created attachment 174960 [details]
Build log
Comment 2 Martin Väth 2008-12-11 15:22:47 UTC
Created attachment 174970 [details, diff]
Patch to fix missing includes

That's a no-brainer: The usual missing #include's.
Comment 3 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-12-14 00:13:44 UTC
Thanks for the patch, applied now. I would ask if you sent this upstream but given that upstream seems dead I'm not sure if there was much point. Still would be nice if you could attach it on a tracker upstream if one exists.
Comment 4 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-06-13 23:21:03 UTC
*** Bug 227041 has been marked as a duplicate of this bug. ***