Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250615 - gnome-base/gvfs-1.0.3 with bluez-4 support
Summary: gnome-base/gvfs-1.0.3 with bluez-4 support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
: 261964 263447 267575 (view as bug list)
Depends on:
Blocks: 250909
  Show dependency tree
 
Reported: 2008-12-11 13:29 UTC by Norman Jonas
Modified: 2009-04-26 19:48 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gvfs-1.0.3.ebuild (gvfs-1.0.3.ebuild,2.16 KB, text/plain)
2008-12-11 13:30 UTC, Norman Jonas
Details
gvfs-obexftp-updated-apis-2.patch (gvfs-obexftp-updated-apis-2.patch,10.53 KB, text/plain)
2008-12-11 13:30 UTC, Norman Jonas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Norman Jonas 2008-12-11 13:29:50 UTC
This ebuild is intended for use by those who installed net-wireless/bluez-4*. It adjusts dependancies and adds an backport patch of Fedora 10 to readd browsing bluetooth devices capability. Tested with my K800i.

Reproducible: Always
Comment 1 Norman Jonas 2008-12-11 13:30:33 UTC
Created attachment 174954 [details]
gvfs-1.0.3.ebuild
Comment 2 Norman Jonas 2008-12-11 13:30:58 UTC
Created attachment 174955 [details]
gvfs-obexftp-updated-apis-2.patch
Comment 3 Norman Jonas 2008-12-11 13:36:49 UTC
This ebuild only supports net-wireless/bluez - the in tree ebuild would need a more elaborate work to support bluez-3 as well.
Comment 4 Gilles Dartiguelongue gentoo-dev 2008-12-11 19:46:08 UTC
link to an upstream bug ? This won't be included if it doesn't provide backwards compatibility with at least bluez-libs-3.
Comment 5 Mart Raudsepp gentoo-dev 2008-12-12 02:57:15 UTC
At worst we need to just conditional patch if preserved-libs or revdep-rebuild is going to help users out once they migrate to bluez-4. We need to move to bluez-4 ASAP imho (I admit that I had personal pain with bluez-3 and getting a bluetooth mouse to work). A patch that would be compatible with either without conditional epatching would be nicer of course
Comment 6 Mart Raudsepp gentoo-dev 2008-12-12 03:01:20 UTC
(In reply to comment #4)
> link to an upstream bug ? This won't be included if it doesn't provide
> backwards compatibility with at least bluez-libs-3.

Try 552356. There is no backwards compatibility there either. I don't think we should wait for supporting bluez-4 until GNOME-2.26, even if we would have to conditional patch.
Another option is to have two revisions, one going for bluez-3, another for bluez-4. Latter patches, former not. Then there's the additional work of keeping those in sync with bluez(-libs) package visibility
Comment 7 Mart Raudsepp gentoo-dev 2008-12-12 03:05:36 UTC
To not give any implicit impressions -- I have not compared the attached patch with what ended up in upstream SVN, nor tested it, nor vetted this. These would have to still be verified from our side (dev-zero has done some testing too). I personally currently don't have any easy access to any bluetooth devices that would have file storage (obex-ftp) - just a mouse and a headset.
Comment 8 Norman Jonas 2008-12-12 03:18:33 UTC
The source of the patch is http://cvs.fedoraproject.org/viewvc/devel/gvfs/gvfs-obexftp-updated-apis-2.patch?view=markup.
Comment 9 Mike Auty gentoo-dev 2008-12-14 16:28:43 UTC
Well, as to the testing part, the fedora patch (identical to this bug's attached one) seems to work fine.

Unfortunately, bluez seem to have decided to release obexd, which uses the same D-Bus service name as this (and obexd takes precedence if they're installed side by side), so I can see there being chaos up ahead, but for now (since obexd isn't in the tree), bluetooth-applet and all the gvfs-obexftp goodness seems to work fine.

Things to note include:

* Still no write support via GFS.
* obex:/// doesn't list nearby bluetooth devices (not sure it ever did for gvfs), you'll have to use bluetooth-applet to do that
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-01-26 22:54:02 UTC
added to the tree. Thanks for reporting and the patches.
Comment 11 Gilles Dartiguelongue gentoo-dev 2009-03-10 12:53:06 UTC
*** Bug 261964 has been marked as a duplicate of this bug. ***
Comment 12 Gilles Dartiguelongue gentoo-dev 2009-03-23 21:03:05 UTC
*** Bug 263447 has been marked as a duplicate of this bug. ***
Comment 13 Gilles Dartiguelongue gentoo-dev 2009-04-26 19:48:49 UTC
*** Bug 267575 has been marked as a duplicate of this bug. ***