Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 250176 - app-misc/mc-4.6.2_pre1 crashes under root
Summary: app-misc/mc-4.6.2_pre1 crashes under root
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Desktop Misc. Team
URL: http://savannah.gnu.org/bugs/index.ph...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-12-07 14:58 UTC by Tomas Caithaml
Modified: 2009-08-05 11:37 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fix uninitialized variable error (mc-4.6.2_pre1-unused-fix.patch,320 bytes, patch)
2008-12-07 15:02 UTC, Tomas Caithaml
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Caithaml 2008-12-07 14:58:19 UTC
Hi,
If I run mc under root, it gets SIGSEGV on startup.

I tried to investigate this bug and ran into this http://savannah.gnu.org/bugs/index.php?24986. I applied that patch and it seems to solve the problem.

Is it possible to include that patch into portage? It is already in upstream CVS but it could take long time before new version comes out...
Comment 1 Tomas Caithaml 2008-12-07 15:02:21 UTC
Created attachment 174564 [details, diff]
Fix uninitialized variable error
Comment 2 Samuli Suominen gentoo-dev 2009-07-21 10:05:13 UTC
+  21 Jul 2009; Samuli Suominen <ssuominen@gentoo.org> mc-4.6.2_pre1.ebuild,
+  +files/mc-4.6.2_pre1-null.patch:
+  Don't crash when used as root wrt #250176.

Added without revbump; I'll revbump a bit later on when I get enough fixes in..
Comment 3 Samuli Suominen gentoo-dev 2009-08-05 11:37:38 UTC
4.7.0_pre1 in tree...