dev-perl/Crypt-SSLeay-0.49 should depend on dev-perl/ExtUtils-MakeMaker.
Steps to Reproduce:
1.Obviously remove dev-perl/ExtUtils-MakeMaker
Compilation exited in error.
make sure you have latest version of perl
Well, anyway if you need perl-5.8 then the dependancy should say:
>=dev-lang/perl-5.8 (or whenever the MakeMaker became stable)
not as it says now:
perl-5.8 is the default perl for all platforms, all profiles. There is no need to be that precise. If you have chosen to stay with the older perl, then install the standalone ebuild for the makemaker patch (please read the page at the url I posted). Unfortunately, we cannot continue to support older perl installs.
Bah, that all came out wrong. The point is if you have perl 5.6.1, then you should have the makemaker ebuild installed to patch it, if you have 5.8.0 you are fine, but either way you should already have MakeMaker there. If you don't, then that means you were caught in a depclean in between our cleanups and makemaker was unmerged by accident.
Well, I'm going with perl-5.8.0.
The reason I reported the bug in the first place was because I had to do a lot of manual manhandling with the portage tree. It seems like a plausible cause that I've been caught in between depcleans. Anyway, you do as you best see fit. I'm done with this bug.
"fixed" isn't the best class for resolution but comes closest for this bug
Well, I'll mark it as verified.