Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 25010 - vanilla-sources-2.4.21 hangs during boot, something to do with disks
Summary: vanilla-sources-2.4.21 hangs during boot, something to do with disks
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: (DEPRECATED)
Depends on:
Reported: 2003-07-21 16:26 UTC by Matthew Walker
Modified: 2003-09-25 15:24 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

My .config (myconfig,17.72 KB, text/plain)
2003-07-21 19:04 UTC, Matthew Walker

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Walker 2003-07-21 16:26:57 UTC
On the two systems I've tried to set up with vanilla-sources 2.4.21, the kernel
hangs just after listing the IDE Drives and/or SCSI cards. I'm afraid I don't
have any good diagnostic messages since it just hangs.

One of the systems is running a P4, and the other one is an Athlon XP, so it's
not (obviously) processor related.

If you need any other information, I'll see what I can do to get it for you.

Reproducible: Always
Steps to Reproduce:
1. Compile vanilla-sources 2.4.21.
2. Reboot.
3. Hang.

Actual Results:  
Machine hangs during boot.

Expected Results:  
Continued to boot.

hydrogen root # emerge info
Portage 2.0.48-r1 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4)
System uname: 2.4.20 i686 Intel(R) Pentium(R) 4 CPU 2.00GHz
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config
/usr/kde/2/share/config /usr/kde/3/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 3dnow apm crypt gif imlib jpeg libg++ mad mmx ncurses nls pdflib png
spell truetype xml2 zlib gdbm berkdb slang readline mysql tcpd pam libwww ssl
perl python cdr apache2 curl gd innodb ipv6 maildir xml -oss -arts -avi -cups
-encode -gpm -gtk -java -kde -gnome -mikmod -motif -mpeg -oggvorbis -opengl -qt
-quicktime -sdl -svga -X -xmms -xv -snmp"
CFLAGS="-march=pentium3 -O3 -pipe"
CXXFLAGS="-march=pentium3 -O3 -pipe"
FEATURES="sandbox ccache"
Comment 1 SpanKY gentoo-dev 2003-07-21 18:44:38 UTC
please post your .config as an attachment 
Comment 2 Matthew Walker 2003-07-21 19:04:55 UTC
Created attachment 14850 [details]
My .config
Comment 3 Bob Johnson (RETIRED) gentoo-dev 2003-07-21 19:22:02 UTC
Be glad to look at your .config, 
but vanilla-sources is unpatched by the gentoo kernel
team. That means, even if we have a known fix, it will
not be applied. You may try one of the gentoo kernels.
At least if we find a problem, we can do something about

I consider 2.4.21 unstable, but upstream
considers it stable, so thats how it will be marked in portage.
Comment 4 Matthew Walker 2003-07-21 19:24:33 UTC
Thanks anyway... I'll try and find some time to test a Gentoo kernel on one of the servers. I'd prefer to run a vanilla kernel purely from a philisophical point of view, since this is supposed to be a backup production server, and I'd like as few patches as possible in the kernel.

I agree that 2.4.21 seems unstable... I don't have any machines running it successfully.
Comment 5 Guy 2003-07-21 20:13:59 UTC
Disclaimer: I am not a Gentoo Developer. 
Try configuring your kernel without ACPI support. There's been a lot of activity in this 
area on 2.5/6, some of which has been back ported. 
If this solves your problem, you might want to post your mobo model, chipset and 
bios rev. 
I'm assuming that you don't have this problem under 2.4.20 
Comment 6 Patrick Kursawe (RETIRED) gentoo-dev 2003-07-22 01:36:54 UTC
I have vanilla 2.4.21 happily running on one Pentium, one Pentium IV, one Athlon and one Athlon XP without any troubles.
Comment 7 Don Seiler (RETIRED) gentoo-dev 2003-07-22 09:04:59 UTC
I have vanilla-2.4.21 running perfectly on a Pentium 4, Athlon, and two Pentium (classic) machines.  I would have to bet my sweet bippy that it's a config problem.
Comment 8 Matthew Walker 2003-07-22 09:06:36 UTC
/me grimaces. I'm started to conclude that too... If anyone has the time, could you look over my config and see if there's any obvious problems?
Comment 9 Guy 2003-07-22 16:59:44 UTC
FWIW, I have three machines that hang on disks during booting of the 2.5.75 kernel 
if I also have ACPI support compiled into the kernel. THey are one each of a Duron, 
Athlon XP and P4. 
My best _guess_ that the problem is related to ATA 133 capable IDE chipsets. But 
this is only a guess and I have nothing to back it with. 
Have you tried a kernel compiled without ACPI support? 
Also, what is the longest you've let your system hang before re-booting it? On two 
of my machines, they'll eventually responsd with bad interrupt messages. This is 
after waiting about 20 minutes. 
Comment 10 Tim Yamin (RETIRED) gentoo-dev 2003-09-25 15:24:24 UTC
Ignore me <<< We are having Bugzilla database issues.