Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 249985 - dev-lang/mono-2.0.1 does not parallel build - libtool error (`mach_dep.lo' is not a valid libtool object)
Summary: dev-lang/mono-2.0.1 does not parallel build - libtool error (`mach_dep.lo' is...
Status: RESOLVED LATER
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
: 353002 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-12-05 21:38 UTC by Simon Zilliken
Modified: 2011-01-28 11:09 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Disables parallel build. (mono-2.0.1.ebuild,2.68 KB, text/plain)
2008-12-05 21:40 UTC, Simon Zilliken
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Zilliken 2008-12-05 21:38:43 UTC
Emerging mono-2.0.1 fails with the error described in
https://bugs.gentoo.org/show_bug.cgi?id=178870. I noticed that the mono-1.9.1 ebuild (which worked) disables the parallel build, but the mono-2.0.1 ebuild doesn't. After adding MAKEOPTS="${MAKEOPTS} -j1" the build succeeds.

Reproducible: Always




Portage 2.2_rc17 (default/linux/amd64/2008.0/no-multilib, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27.7 x86_64)
=================================================================
System uname: Linux-2.6.27.7-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-glibc2.2.5
Timestamp of tree: Fri, 05 Dec 2008 13:57:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/microcode.dat /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/src/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ "
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/src/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/layman/science /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage "
USE="X acl acpi alsa amd64 branding bzip2 cdr cracklib crypt cups dri dvd dvdr dvdread fortran gdbm hal iconv ieee1394 ipv6 kde midi mmx mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl python qt3 qt4 readline reflection session smp spell spl sse sse2 ssl ssse3 sysfs tcpd threads truetype type1 unicode xinerama xorg zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Simon Zilliken 2008-12-05 21:40:10 UTC
Created attachment 174360 [details]
Disables parallel build.
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-25 23:06:24 UTC
Fixed in 2.0.1-r1
Comment 3 Mart Raudsepp gentoo-dev 2008-12-25 23:58:04 UTC
Disabling parallel build is not a proper fix but a workaround that makes it not blow up on users faces. Reopening until it is fixed properly in the build system and parallel make is allowed again.
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-12-26 00:10:23 UTC
We don't want to track this bug actively then, changing resolution to later. Parallel make for mono is a long way off.
Comment 5 Pacho Ramos gentoo-dev 2011-01-28 11:09:02 UTC
*** Bug 353002 has been marked as a duplicate of this bug. ***