Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 249663 - sys-apps/util-linux: tweak dependency on e2fsprogs
Summary: sys-apps/util-linux: tweak dependency on e2fsprogs
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest major (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Blocks: 234907
  Show dependency tree
Reported: 2008-12-02 22:42 UTC by Björn
Modified: 2008-12-31 23:02 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Björn 2008-12-02 22:42:48 UTC
util-linux falsely depends on sys-libs/e2fsprogs and should instead (or at least additionally) depend on sys-libs/e2fsprogs-libs for libblkid.
Comment 1 Wormo (RETIRED) gentoo-dev 2008-12-03 07:37:37 UTC
Actually it could be an alternative, because libblkid moved out of e2fsprogs starting in 1.41
|| ( <=sys-fs/e2fsprogs-1.40  
     sys-libs/e2fsprogs-libs )
Comment 3 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-30 12:44:46 UTC
Mike, your change, is in conflict with bug 234907. Before some weeks zmedico removed e2fsprogs from system set to fix bug 234907. I copy paste the line from the changelog of profiles/base/packages

Remove sys-fs/e2fsprogs from the system set in order to allow
automatic blocker resolution for bug #234907. This change shouldn't
hurt since the sys-fs/e2fsprogs package is pulled in as a dependency
of sys-apps/util-linux, which is a member of the system set for
relevant profiles.

I see that one way or another, e2fsprogs pull in e2fsprogs-libs, so why we did that change anyway? I cc dev-portage@ and I hope there isn't a false alarm of my side. 
Comment 4 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-30 13:26:52 UTC
I increase severity, cause the change pulls out e2fsprogs from every box, if someone does today a depclean.
Comment 5 Panagiotis Christopoulos (RETIRED) gentoo-dev 2008-12-30 20:58:48 UTC
bah, don't change anything, we probably have solved bug 234907 another way(writing a revbumped ebuild of e2fsprogs-libs in EAPI=2 where with 2.1.6 portage, blockers get solved automatically). I'll leave the open for a while, and resolve it as fixed again, in some hours.
Comment 6 David Smith 2008-12-31 22:33:05 UTC
I am the unlucky sap that happened to do emerge --depclean today and not notice that e2fsprogs was in the list (probably because I didn't know what it was).
I lost fsck and system refused to boot after that. Spent several hours tracking down what was missing and manually installing e2fsprogs from livecd...

This definitely ought to be fixed.