Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 249363 - sys-libs/ncurses-5.7: cross-compile hangs when host is older ncurses as `tic` goes into infinite loop
Summary: sys-libs/ncurses-5.7: cross-compile hangs when host is older ncurses as `tic`...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High major with 2 votes (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 288881
  Show dependency tree
 
Reported: 2008-11-30 11:42 UTC by Chema
Modified: 2015-08-17 13:54 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chema 2008-11-30 11:42:22 UTC
When the compilation reachs this point:

make[1]: se sale del directorio `/home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/test'
cd misc && make DESTDIR="/home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/image/" install
make[1]: se ingresa al directorio `/home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/misc'
/bin/sh /home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/work/ncurses-5.7/mkdirs.sh /home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/image//usr/share/tabset
/usr/bin/install -c ncurses-config /home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/image//usr/bin/ncurses5-config
mkdir /home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/image/usr/share/tabset
DESTDIR=/home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/image/ \
        prefix=/usr \
        exec_prefix=/usr \
        bindir=/usr/bin \
        top_srcdir=/home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/work/ncurses-5.7 \
        srcdir=/home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/work/ncurses-5.7/misc \
        datadir=/usr/share \
        ticdir=/usr/share/terminfo \
        source=terminfo.tmp \
        THIS_CC="gcc-4.3.1" \
        THAT_CC="x86_64-pc-linux-gnu-gcc" \
        /bin/sh ./run_tic.sh
** Building terminfo database, please wait...
Running tic to install /home/chema/.portage/tmp/portage/sys-libs/ncurses-5.7/image//usr/share/terminfo ...

        You may see messages regarding extended capabilities, e.g., AX.
        These are extended terminal capabilities which are compiled
        using
                tic -x
        If you have ncurses 4.2 applications, you should read the INSTALL
        document, and install the terminfo without the -x option.

It hangs, and can keep like that for hours if i don't kill the process

Reproducible: Always

Steps to Reproduce:
1. emerge --sync
2. emerge -1 =sys-libs/ncurses-5.7
3. wait till the error appears

Actual Results:  
The compilation hangs

Expected Results:  
Simply compile successfully

emerge --info:

Portage 2.1.6_rc2 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r3-x86_64-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-glibc2.2.5
Timestamp of tree: Sun, 30 Nov 2008 09:45:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=nocona -pipe -fomit-frame-pointer -frename-registers -msse -msse2 -msse3 -mmmx"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=nocona -pipe -fomit-frame-pointer -frename-registers -msse -msse2 -msse3 -mmmx"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.qubenet.net/mirror/gentoo/ ftp://mirror.qubenet.net/mirror/gentoo/ http://gentoo.virginmedia.com/ ftp://gentoo.virginmedia.com/sites/gentoo "
LANG="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/home/chema/.portage/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 arts berkdb branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups dbus djvu dri dts dvd dvdr dvdread emboss encode evo exif fam ffmpeg firefox flac foomaticdb fortran gdbm gif hal hddtemp iconv imagemagick ipv6 isdnlog java java6 jpeg kde ldap libnotify lm_sensors mad matroska midi mmx mmxext mp2 mp3 mpeg mplayer mudflap multilib musepack nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff truetype unicode usb vim-syntax vorbis x264 xcb xcomposite xine xml xorg xosd xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael Perlov 2008-11-30 23:03:01 UTC
Same here.

emerge --info
Portage 2.1.6_rc2 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26.2 i686)
=================================================================
System uname: Linux-2.6.26.2-i686-Intel-R-_Pentium-R-_4_CPU_1.80GHz-with-glibc2.0
Timestamp of tree: Sun, 30 Nov 2008 21:36:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.4.4-r9, 2.5.2-r8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.hamakor.org.il/pub/mirrors/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://mirror.gentoo.no/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/my"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl alsa apache2 berkdb bzip2 cli cracklib crypt dbus dri dvdr flac fortran gdbm gif gpm gtk2 hal iconv ipv6 isdnlog jpeg midi mmx mp3 mudflap ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openmp pam pcre perl png pppd python readline reflection session spl sse sse2 ssl svg sysfs tcpd unicode vorbis win32codecs x86 xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" LIRC_DEVICES="audio audio_alsa" USERLAND="GNU" VIDEO_CARDS="nvidia none"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 SpanKY gentoo-dev 2008-12-01 16:48:51 UTC
this occurs when the host is ncurses-5.6 and the script runs tic in /usr/bin instead of the local build dir ... but it should have been built locally and used locally ...
Comment 3 Chris Bruner 2008-12-02 18:35:31 UTC
Is there a work around? I've tried copying the tic and other executables to the /usr/bin but it had the same result.
Comment 4 SpanKY gentoo-dev 2008-12-02 20:06:23 UTC
try building with -j1.  if that doesnt work, copy the tic from the builddir to your /usr/bin/.
Comment 5 Chris Bruner 2008-12-03 02:06:33 UTC
the -j1 makes no difference, I've already tried coping from the build dir to /usr/bin

I think you might be barking up the wrong tree there.
Comment 6 Gary Stein 2008-12-03 21:22:42 UTC
(In reply to comment #2)
> this occurs when the host is ncurses-5.6 and the script runs tic in /usr/bin
> instead of the local build dir ... but it should have been built locally and
> used locally ...
> 

Basically right, but copying the program won't fix anything, because it is still linking off of the /lib/libncurses.so.5 and that is the old one.

I fixed my system by patching the path with
LD_LIBRARY_PATH=/var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/lib/
and using the new tic in ../progs/tic (relative to the narrowc/misc/ where the run_tic.sh is)

so the full command:
LD_LIBRARY_PATH=/var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/lib/ ../progs/tic -x -s -o /var/tmp/portage/sys-libs/ncurses-5.7/image//usr/share/terminfo terminfo.tmp

works for me, I'll see if I can make that an ebuild rather than a manual patch

gary
Comment 7 Gary Stein 2008-12-03 21:53:46 UTC
Ok, tracked it down some more.  There is actually already a setup to run local version instead of the installed version using SHLIB in the runtic.sh

Unfortunately the script is broken since it thinks it is cross compiling (which is isn't), it checks the CC vs HOSTCC using
if test "$THAT_CC" = "$THIS_CC"

but this is false because in the calling Makefile:
CC              = gcc
HOSTCC          = x86_64-pc-linux-gnu-gcc

so it thinks it is a cross compile, changing this to:
CC              = x86_64-pc-linux-gnu-gcc
HOSTCC          = x86_64-pc-linux-gnu-gcc

also fixes the problem, however obviously breaks real cross-compiles.  The major thing is to find the code in Makefile.in or configure that incorrectly make CC be gcc instead of the full name

gary
Comment 8 Gary Stein 2008-12-03 22:36:42 UTC
Final post, I swear.

commenting out
tc-export BUILD_CC

at the beginning of src_compile() in the ebuild fixes everything for me

BUILD_CC sets the HOSTCC while CC just defaults to gcc.  if you take that line out, HOSTCC defaults to gcc also.

this might break cross compile, not sure exactly what that is used for.

gary
Comment 9 flukebox 2008-12-24 21:59:47 UTC
(In reply to comment #8)
> Final post, I swear.
> 
> commenting out
> tc-export BUILD_CC
> 
> at the beginning of src_compile() in the ebuild fixes everything for me
> 
> BUILD_CC sets the HOSTCC while CC just defaults to gcc.  if you take that line
> out, HOSTCC defaults to gcc also.
> 
> this might break cross compile, not sure exactly what that is used for.
> 
> gary
> 

I can confirm that 

> commenting out
> tc-export BUILD_CC

works !!!
Comment 10 Chris Bruner 2009-01-29 23:31:01 UTC
I've just installed on a brand new computer and stumbled over this same bug again!
Can we just comment out the bloody

tc-export BUILD_CC

and call it a day?

Comment 11 Alon Bar-Lev 2009-02-25 23:19:35 UTC
Happened to me during cross compile.
The solution was to have the same version of ncurses in the host while compiling the other package.
Comment 12 Chema 2009-02-28 13:35:17 UTC
I've tried compiling it again today, and it works!!

The same version (5.7) and doing nothing to solve this, it must have been some other package updated...
Comment 13 Michael Haubenwallner gentoo-dev 2009-04-21 16:36:38 UTC
Which version of sys-devel/binutils do you have when it works?
Is it always sys-devel/binutils-2.19 when it does not work?

While 'tic' hangs, can you post the output of:
$ readelf -d /var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/progs/tic

We do have this same problem in Prefix, where I currently have binutils-2.19.51.0.3.20090310 (ld -v). This Prefix runs on top of Gentoo Linux (x86 stable), where I do _not_ have this problem - with binutils-2.18.

According to 'readelf -d', the just built 'narrowc/progs/tic' only has the 'RPATH' entry, but lacks the 'RUNPATH' entry, which causes LD_LIBRARY_PATH to be ignored on execution, and thus using the installed lib during execution.

Note: In Prefix, we pass the '-rpath' linker option via binutils-config wrapper.
As this isn't done in main, and thus no RPATH/RUNPATH are recorded, I'm not sure if this helps here at all.
Comment 14 Gary Stein 2009-04-26 03:22:24 UTC
This is a different computer but same problem (other machine I just commented out the tc-export)

readelf -d /var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/progs/tic

Dynamic section at offset 0x9ea8 contains 22 entries:
  Tag        Type                         Name/Value
 0x00000001 (NEEDED)                     Shared library: [libncurses.so.5]
 0x00000001 (NEEDED)                     Shared library: [libc.so.6]
 0x0000000c (INIT)                       0x8049440
 0x0000000d (FINI)                       0x804de44
 0x00000004 (HASH)                       0x8048188
 0x6ffffef5 (GNU_HASH)                   0x8048590
 0x00000005 (STRTAB)                     0x8048c10
 0x00000006 (SYMTAB)                     0x80485e0
 0x0000000a (STRSZ)                      1080 (bytes)
 0x0000000b (SYMENT)                     16 (bytes)
 0x00000015 (DEBUG)                      0x0
 0x00000003 (PLTGOT)                     0x8052ff4
 0x00000002 (PLTRELSZ)                   528 (bytes)
 0x00000014 (PLTREL)                     REL
 0x00000017 (JMPREL)                     0x8049230
 0x00000011 (REL)                        0x8049160
 0x00000012 (RELSZ)                      208 (bytes)
 0x00000013 (RELENT)                     8 (bytes)
 0x6ffffffe (VERNEED)                    0x8049110
 0x6fffffff (VERNEEDNUM)                 1
 0x6ffffff0 (VERSYM)                     0x8049048
 0x00000000 (NULL)                       0x0


ldd /var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/progs/tic
        linux-gate.so.1 =>  (0xffffe000)
        libncurses.so.5 => /lib/libncurses.so.5 (0xb7f91000)
        libc.so.6 => /lib/libc.so.6 (0xb7e57000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7e53000)
        /lib/ld-linux.so.2 (0xb7fe3000)

I am using a newish, binutils
ld -v
GNU ld (GNU Binutils) 2.19.1

see how it grabs the host /lib/ncurses instead of the local one (even though that is what we were upgrading), the LD_LIBRARY_PATH flags did fix that

gary

(In reply to comment #13)
> Which version of sys-devel/binutils do you have when it works?
> Is it always sys-devel/binutils-2.19 when it does not work?
> 
> While 'tic' hangs, can you post the output of:
> $ readelf -d /var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/progs/tic
> 
> We do have this same problem in Prefix, where I currently have
> binutils-2.19.51.0.3.20090310 (ld -v). This Prefix runs on top of Gentoo Linux
> (x86 stable), where I do _not_ have this problem - with binutils-2.18.
> 
> According to 'readelf -d', the just built 'narrowc/progs/tic' only has the
> 'RPATH' entry, but lacks the 'RUNPATH' entry, which causes LD_LIBRARY_PATH to
> be ignored on execution, and thus using the installed lib during execution.
> 
> Note: In Prefix, we pass the '-rpath' linker option via binutils-config
> wrapper.
> As this isn't done in main, and thus no RPATH/RUNPATH are recorded, I'm not
> sure if this helps here at all.
> 

Comment 15 SpanKY gentoo-dev 2009-04-27 06:16:09 UTC
if your ld only generates RPATH and not RUNPATH also, then it sounds like your binutils is broken and not applying 76_all_use-new-ld-dtags.patch
Comment 16 Michael Haubenwallner gentoo-dev 2009-04-27 07:14:51 UTC
(In reply to comment #14)
> readelf -d /var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/progs/tic
>  0x00000001 (NEEDED)                     Shared library: [libncurses.so.5]
>  0x00000001 (NEEDED)                     Shared library: [libc.so.6]
> ldd /var/tmp/portage/sys-libs/ncurses-5.7/work/narrowc/progs/tic
>         libncurses.so.5 => /lib/libncurses.so.5 (0xb7f91000)

> see how it grabs the host /lib/ncurses instead of the local one (even though
> that is what we were upgrading), the LD_LIBRARY_PATH flags did fix that

When there is no RPATH/RUNPATH at all, and LD_LIBRARY_PATH fixes it, then my problem (RPATH only) is different than yours...
Comment 17 Michael Haubenwallner gentoo-dev 2009-04-27 08:30:16 UTC
(In reply to comment #15)
> if your ld only generates RPATH and not RUNPATH also, then it sounds like your
> binutils is broken and not applying 76_all_use-new-ld-dtags.patch

Indeed - thank you! Bug#267629 (Prefix only).
So still no clue about this issue in non-Prefix.
Comment 18 Poor Yorick 2009-05-24 17:50:24 UTC
FWIW, temporarily hiding files from the previous version ncurses solves this problem

Comment 19 Poor Yorick 2009-05-24 22:39:59 UTC
In my case (a non-gentoo) build system, I had specified rpath-link values that
were causing the build not to find the new ncurses library.  The fix was to
make the the ncurses src/lib directory the first place the linker looked
(LDFLAGS):

    -Wl,-rpath-link,/path/to/ncurses_build_dir/lib 

It was also necessary to specify

    LDFLAGS="-L../lib $LDFLAGS"

Comment 20 Tomáš Chvátal (RETIRED) gentoo-dev 2009-05-30 14:54:01 UTC
Guys i am also hit with this problem.
I can hack around it but we need some system way in order to stable the ncurses, feel free to poke me if you want to test some in ebuild strategies for it (if you are not able to reproduce it).
Comment 21 Gary Stein 2009-05-30 16:14:31 UTC
(In reply to comment #20)
> Guys i am also hit with this problem.
> I can hack around it but we need some system way in order to stable the
> ncurses, feel free to poke me if you want to test some in ebuild strategies for
> it (if you are not able to reproduce it).
> 

Haven't posted in awhile but, my previous fix of commenting out:
tc-export BUILD_CC

still working, but breaks cross-compiling, but then I noticed Bug 214642
for cross compiling as a flag for that, so cam we just fix it that way?

tc-is-cross-compiler && tc-export BUILD_CC

check for cross, if it is do the export, else don't, then things should work all around, not fully tested yet

gary

Comment 22 Sergiy Borodych 2009-06-22 10:03:15 UTC
for me bug appear again in ncurses-5.7-r1
Comment 23 Christopher Friedt 2009-07-31 09:45:11 UTC
(In reply to comment #22)
> for me bug appear again in ncurses-5.7-r1
> 

I've also encountered this error while cross compiling i686-pc-linux-gnu -> armv5tel-softfloat-linux-gnueabi
Comment 24 Erik Boritsch 2009-08-21 14:49:32 UTC
confirm this bug. Happens while cross-compiling to powerpc-unknown-linux-gnu.
Comment 25 SpanKY gentoo-dev 2009-10-11 07:29:31 UTC
when cross-compiling, ncurses-5.7-r2 builds a local static `tic` and uses that when installing
Comment 26 Sergiy Borodych 2009-10-12 11:14:19 UTC
maybe my problem is another,
but I still have a hang

# emerge -v -1 sys-libs/ncurses

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild     U ] sys-libs/ncurses-5.7-r2 [5.6-r2] USE="cxx%* gpm unicode -ada% -debug -doc -minimal -profile -trace (-nocxx%)" 0 kB
...
** Building terminfo database, please wait...
Running tic to install /var/tmp/portage/sys-libs/ncurses-5.7-r2/image//usr/share/terminfo ...

	You may see messages regarding extended capabilities, e.g., AX.
	These are extended terminal capabilities which are compiled
	using
		tic -x
	If you have ncurses 4.2 applications, you should read the INSTALL
	document, and install the terminfo without the -x option.

here it hangs
I waited about hour,
it eats processor time and no output even in strace

# strace -p 24731
Process 24731 attached - interrupt to quit
^CProcess 24731 detached


# emerge --info
Portage 2.1.7 (default/linux/x86/10.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.31-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.31-gentoo-r2-i686-Intel-R-_Pentium-R-_M_processor_1.70GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 12 Oct 2009 05:30:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p33
dev-java/java-config: 2.1.9-r1
dev-lang/python:     2.6.3, 3.1.1-r1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r4
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests autoaddcvs autoconfig ccache collision-protect distlocks fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="uk_UA.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru uk"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/perl-experimental /usr/local/portage /usr/local/portage.old"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa apache2 berkdb branding bzip2 cairo caps cdr chroot cli cracklib crypt dbus device-mapper djvu dri dts dvdr emboss encode evo fam fat ffmpeg firefox flac freetype gd gdbm gif gnome gpm gstreamer gtk gtk2 hal iconv irda isdnlog ithreads jpeg lcms libnotify logrotate mad mmap mmx modules mozdevelop mozilla moznocompose moznoirc mp3 mp4 mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl pic png ppds pppd qt3support readline reflection reiser4 reiserfs sdl seamonkey session slang sox spl sqlite3 sse sse2 ssl startup-notification subversion svg symlink sysfs syslog tcpd threads thunar tiff truetype unicode usb utf8 vim-syntax vim-with-x vorbis win32codecs wma x264 x86 xml xml2 xorg xulrunner xv xvid zlib" ALSA_CARDS="intel8x0 intel8x0m" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="alias auth_basic authn_default authn_file authz_default authz_host autoindex dbd dir env expires ext_filter filter headers include log_config logio mime rewrite setenvif status vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru uk" USERLAND="GNU" VIDEO_CARDS="radeon vesa vga" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS


where my problem ?
Comment 27 SpanKY gentoo-dev 2009-10-12 13:26:17 UTC
clone this bug with your info (including *full* build log as an *attachment*).  there is too much extraneous noise here.