Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 249220 - app-shells/bash-3.2_p48 didn't install /bin/sh
Summary: app-shells/bash-3.2_p48 didn't install /bin/sh
Status: RESOLVED DUPLICATE of bug 222721
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-29 03:05 UTC by Mikael Magnusson
Modified: 2008-12-01 22:16 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Magnusson 2008-11-29 03:05:46 UTC
I'm using some unstable bits, so if you can't reproduce it, it's probably some weird interaction. When the previous version was cleaned, /bin/sh was unmerged which was not so nice :).
Comment 1 Jeroen Roovers gentoo-dev 2008-11-29 16:37:43 UTC
Please post your `emerge --info' too.
Comment 2 Mikael Magnusson 2008-11-29 16:40:42 UTC
Portage 2.2_rc16 (default/linux/x86/2008.0/desktop, gcc-4.2.4, glibc-2.7-r1, 2.6.19.2-ck2-2 i686)
=================================================================
System uname: Linux-2.6.19.2-ck2-2-i686-AMD_Athlon-TM-_XP_2600+-with-glibc2.0
Timestamp of tree: Sat, 29 Nov 2008 14:15:02 +0000
distcc 3.0 i686-pc-linux-gnu [disabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r4, 2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.19.2-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /usr/share/gconf"
CONFIG_PROTECT_MASK="/etc/asciidoc /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d /usr/share/texmf /var/lib/rpm"
CXXFLAGS="-march=athlon-xp -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical --nospinner"
FEATURES="digests distlocks metadata-transfer noinfo preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="sv en ja"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/exclude-from"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR="/usr/portage"
SYNC="rsync://rsync1.uk.gentoo.org/gentoo-portage"
USE="3dnow X aalib acpi alsa avi branding bzip2 cairo canna cdr cli cracklib crypt cups dri dvd dvdr dvdread emboss encode f77 fam firefox flac fortran gcj gdbm gif gpm gs gtk gtk2 gtkhtml iconv idn isdnlog jpeg jpeg2k kdeenablefinal libnotify mad midi mikmod mmx moznocompose moznoirc moznomail mozsvg mp3 mpeg mudflap ncurses nethack no-old-linux nodrm noutempter nptl nptlonly objc ogg opengl openmp oss pam pcre pdf perl pic png ppds pppd python qt3 qt3support qt4 readline reflection sdl session spl sse ssl startup-notification svg sysfs tetex tiff truetype unicode usb vorbis win32codecs wmf x86 xml xorg xprint xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="sv en ja" USERLAND="GNU" VIDEO_CARDS="nv"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

Comment 3 Mikael Magnusson 2008-11-29 17:19:14 UTC
This is just a guess, since the old ebuild in /var/db/pkg was unmerged already. But my previous bash version obviously had /bin/sh in CONTENTS since it was unmerged, and the current ebuilds provide it in postinst, i checked and even versions before my previous do that so i'm not sure if maybe that was changed retroactively? Then for some reason the postinst on p48 was run before my old version was unmerged, and since the postinst doesn't touch the symlink if it exists, its mtime was unchanged and it was removed since it wasn't in the new CONTENTS.
Comment 4 SpanKY gentoo-dev 2008-12-01 22:16:41 UTC

*** This bug has been marked as a duplicate of bug 222721 ***