Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 249156 - x11-drivers/xf86-video-ati-{6.8.0-r1,6.9.0} trigger signal 11 on Xorg startup when Xinerama is enabled
Summary: x11-drivers/xf86-video-ati-{6.8.0-r1,6.9.0} trigger signal 11 on Xorg startup...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 253879 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-28 11:08 UTC by Simon C. Ion
Modified: 2009-05-07 07:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xorg.conf which triggers the crash. (xorg.conf,1.67 KB, text/plain)
2008-11-28 11:11 UTC, Simon C. Ion
Details
xorg.log from the crashing session. (Xorg.0.log,79.29 KB, text/plain)
2008-11-28 11:12 UTC, Simon C. Ion
Details
xorg.conf which triggers the crash. (xorg.conf,1.70 KB, text/plain)
2008-11-28 11:13 UTC, Simon C. Ion
Details
stderr and stdout from crashing Xorg run (xorgRunWithStderr,9.63 KB, text/plain)
2008-12-03 10:33 UTC, Simon C. Ion
Details
gdb backtrace from running 'gdb Xorg' as root (gdbBacktrace,901 bytes, text/plain)
2008-12-03 10:36 UTC, Simon C. Ion
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Simon C. Ion 2008-11-28 11:08:56 UTC
Xorg crashes on startup when using xf86-video-ati-6.8.0-r1 (or xf86-video-ati-6.9.0) and the Xinerama extension is enabled in xorg.conf.

Reproducible: Always

Steps to Reproduce:
1. Enable the Xinerama server flag
2. run 'startx'
3. Watch the crash!

Actual Results:  
Monitor makes "resolution changing" noise, then I get dumped to console with information about crash.

Expected Results:  
X.org up and running.

I'm using an AGP Radeon X850. I've nothing in /etc/portage/package.keywords... everything on this system is from Gentoo's stable x86 branch. I've built xf86-video-ati with the "debug" USE flag.

uname -a:
Linux avatar 2.6.26-gentoo-r3 #1 Fri Nov 28 03:28:50 CST 2008 i686 AMD Athlon(tm) AuthenticAMD GNU/Linux

lspci:
00:00.0 Host bridge: nVidia Corporation nForce2 AGP (different version?) (rev c1)
00:00.1 RAM memory: nVidia Corporation nForce2 Memory Controller 1 (rev c1)
00:00.2 RAM memory: nVidia Corporation nForce2 Memory Controller 4 (rev c1)
00:00.3 RAM memory: nVidia Corporation nForce2 Memory Controller 3 (rev c1)
00:00.4 RAM memory: nVidia Corporation nForce2 Memory Controller 2 (rev c1)
00:00.5 RAM memory: nVidia Corporation nForce2 Memory Controller 5 (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio Processing Unit (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation nForce2 External PCI Bridge (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:04.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
01:07.0 Network controller: 3Com Corporation 3CRWE777 PCI(PLX) Wireless Adaptor [Airconnect] (rev 02)
01:08.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)
01:0a.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
01:0a.1 Input device controller: Creative Labs SB Audigy Game Port (rev 03)
01:0a.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port
01:0b.0 RAID bus controller: Silicon Image, Inc. SiI 3112 [SATALink/SATARaid] Serial ATA Controller (rev 02)
03:00.0 VGA compatible controller: ATI Technologies Inc R420 JK [Radeon X800]
03:00.1 Display controller: ATI Technologies Inc R420 [Radeon X800] (Secondary

emerge --info:
Portage 2.1.4.5 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r3simoncion.dyndns.org i686)
=================================================================
System uname: 2.6.26-gentoo-r3simoncion.dyndns.org i686 AMD Athlon(tm)
Timestamp of tree: Wed, 26 Nov 2008 06:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=athlon-xp -mtune=athlon-xp -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe -march=athlon-xp -mtune=athlon-xp -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://acm.cs.rpi.edu/gentoo-portage/"
USE="3dnow X acl acpi alsa apache2 avahi avi berkdb bluetooth branding bzip2 cairo caps cdr cjk cli cracklib crypt cups dbus dev-db/sqlite doc dri dvd dvdr dvdread eds emboss encode esd evo examples fam firefox flac foomaticdb fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jack jpeg kde kdexdeltas kerberos ldap libnotify mad midi mikmod mmx mp3 mpeg mudflap ncurses nls no-htdocs nptl nptlonly offensive ogg oggvorbis openal opengl openmp pam pcre pdf perl pic pie png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse ssl startup-notification svg sysfs tcl tcpd test theora threads tiff truetype unicode usb vorbis win32codecs x86 xinerama xml xorg xv xvid zeroconf zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="ati radeon vesa vmware tdfx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Simon C. Ion 2008-11-28 11:11:01 UTC
Created attachment 173639 [details]
xorg.conf which triggers the crash.

Removing 'Option "Xinerama" "true"' from the attached file stops the crashing.
Comment 2 Simon C. Ion 2008-11-28 11:12:21 UTC
Created attachment 173640 [details]
xorg.log from the crashing session.
Comment 3 Simon C. Ion 2008-11-28 11:13:58 UTC
Created attachment 173641 [details]
xorg.conf which triggers the crash.
Comment 4 Simon C. Ion 2008-12-03 10:33:31 UTC
Created attachment 174144 [details]
stderr and stdout from crashing Xorg run
Comment 5 Simon C. Ion 2008-12-03 10:36:58 UTC
Created attachment 174146 [details]
gdb backtrace from running 'gdb Xorg' as root

x11-base/xorg-server-1.3.0.0-r6 has now been compiled with the 'debug' USE flag.
Comment 6 Simon C. Ion 2008-12-03 11:21:33 UTC
It seems that a Debian user is having this issue with a development version of the driver and a newer version of xorg-server.

https://bugs.freedesktop.org/show_bug.cgi?id=15188
Comment 7 Dmitry Ivankov 2009-01-05 20:37:48 UTC
*** Bug 253879 has been marked as a duplicate of this bug. ***
Comment 8 Rémi Cardona gentoo-dev 2009-05-07 07:05:47 UTC
Hi Simon,

Can you still reproduce this bug with the latest stable versions of xorg-server and xf86-video-ati?

If you can, please don't hesitate to reopen this bug.

Thanks