Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 249049 - net-wireless/wpa_supplicant-{0.5.7,0.5.8} + gcc-4.3 - .ui/../userdatarequest.ui.h:22: error: ‘free’ was not declared in this scope
Summary: net-wireless/wpa_supplicant-{0.5.7,0.5.8} + gcc-4.3 - .ui/../userdatarequest....
Status: RESOLVED DUPLICATE of bug 245563
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Mobile Herd (OBSOLETE)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-11-27 00:55 UTC by Yaroslav Gorbunov
Modified: 2008-12-23 02:24 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
0.5.7.ebuild with gcc-4.3.patch included (wpa_supplicant-0.5.7.ebuild,6.22 KB, text/plain)
2008-11-27 00:57 UTC, Yaroslav Gorbunov
Details
0.5.8.ebuild with gcc-4.3.patch included (wpa_supplicant-0.5.8.ebuild,6.18 KB, text/plain)
2008-11-27 00:58 UTC, Yaroslav Gorbunov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav Gorbunov 2008-11-27 00:55:05 UTC
In file included from .ui/userdatarequest.cpp:25:
.ui/../userdatarequest.ui.h: In member function ‘int UserDataRequest::setParams(WpaGui*, const char*)’:
.ui/../userdatarequest.ui.h:22: error: ‘free’ was not declared in this scope
.ui/../userdatarequest.ui.h:29: error: ‘free’ was not declared in this scope
.ui/../userdatarequest.ui.h:34: error: ‘atoi’ was not declared in this scope
.ui/../userdatarequest.ui.h:49: error: ‘free’ was not declared in this scope

Existing wpa_supplicant-0.5.10-gcc-4.3.patch is not included in wpa_supplicant-0.5.7.ebuild and wpa_supplicant-0.5.8.ebuild. Both fails with gcc-4.3.2

Reproducible: Always




emerge --info
Portage 2.1.6_rc1 (default-linux/x86/2007.0, gcc-4.3.2, glibc-2.7-r2, 2.6.25-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r9-i686-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.0
Timestamp of tree: Wed, 26 Nov 2008 16:00:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS=""
LINGUAS="en ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/berkano /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/yarik-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb cli cracklib crypt css dri fortran fuse gdbm gpm hal iconv isdnlog kde lm_sensors midi mmx mudflap ncurses nls nptl nptlonly nvidia opengl openmp pam pcre perl pppd python qt3 readline reflection samba session spl sse sse2 sse3 ssl ssse3 tcpd unicode userlocales utf8 x86 xorg xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nvidia vesa i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Yaroslav Gorbunov 2008-11-27 00:57:44 UTC
Created attachment 173543 [details]
0.5.7.ebuild with gcc-4.3.patch included
Comment 2 Yaroslav Gorbunov 2008-11-27 00:58:20 UTC
Created attachment 173544 [details]
0.5.8.ebuild with gcc-4.3.patch included
Comment 3 Ryan Hill (RETIRED) gentoo-dev 2008-12-23 02:24:52 UTC

*** This bug has been marked as a duplicate of bug 245563 ***