Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248743 - x11-libs/{libxcb-1.1.92,xcb-util-0.3.1,xpyb-1.0} version bumps
Summary: x11-libs/{libxcb-1.1.92,xcb-util-0.3.1,xpyb-1.0} version bumps
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 266188 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-25 07:49 UTC by Geaaru
Modified: 2010-03-21 02:29 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libxcb-1.1.92 ebuild (libxcb-1.1.92.ebuild,1.17 KB, text/plain)
2008-11-25 07:51 UTC, Geaaru
Details
xcb-util 0.3.1 (xcb-util-0.3.1.ebuild,1020 bytes, text/plain)
2008-11-25 07:55 UTC, Geaaru
Details
version 1.1.99.2 of libX11 that doesn't use xcb-xlib.pc file (libX11-1.1.99.2.ebuild,1.17 KB, text/plain)
2008-11-26 08:58 UTC, Geaaru
Details
randrproto version 1.2.99.1 (randrproto-1.2.99.1.ebuild,481 bytes, text/plain)
2008-11-26 21:12 UTC, Geaaru
Details
xproto-7.0.14 (xproto-7.0.14.ebuild,549 bytes, text/plain)
2008-11-26 21:12 UTC, Geaaru
Details
libXi version 1.1.4 (libXi-1.1.4.ebuild,680 bytes, text/plain)
2008-11-26 21:21 UTC, Geaaru
Details
libXaw version 1.0.5 (libXaw-1.0.5.ebuild,822 bytes, text/plain)
2008-11-26 21:22 UTC, Geaaru
Details
Remove xprint use flags because xprint library is depracated and libXaw8 is not included with new version (libXaw-1.0.5.ebuild,788 bytes, text/plain)
2008-11-27 08:33 UTC, Geaaru
Details
xorg-server-1.5.99.2 (xorg-server-1.5.99.2.ebuild,13.60 KB, text/plain)
2008-12-03 14:51 UTC, Geaaru
Details
New version of libxcb-1.2 (libxcb-1.2.ebuild,1.17 KB, text/plain)
2009-02-27 06:44 UTC, Geaaru
Details
xcb-proto-1.4 (xcb-proto-1.4.ebuild,640 bytes, text/plain)
2009-02-27 06:45 UTC, Geaaru
Details
Released version 1.6.0 of the xorg server (xorg-server-1.6.0.ebuild,13.60 KB, text/plain)
2009-02-27 06:50 UTC, Geaaru
Details
Xorg-server-1.6.0 (xorg-server-1.6.0.ebuild,13.51 KB, text/plain)
2009-02-27 07:32 UTC, Geaaru
Details
libX11-1.2 (libX11-1.2.ebuild,768 bytes, text/plain)
2009-02-27 21:16 UTC, Geaaru
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geaaru 2008-11-25 07:49:47 UTC
Hi, there are available new version of libxcb, xcb-util and xpyb packages.

Reproducible: Always
Comment 1 Geaaru 2008-11-25 07:51:33 UTC
Created attachment 173301 [details]
libxcb-1.1.92 ebuild

Rename of ebuild libxcb-1.1.90.1 seems works fine.
Comment 2 Geaaru 2008-11-25 07:55:31 UTC
Created attachment 173302 [details]
xcb-util 0.3.1

Still in this case only rename of the xcb-util-0.3.0 works.

Bye

Ge@@ru
Comment 3 Geaaru 2008-11-26 08:57:53 UTC
It isn't so easy use new libxcb because:
 * new library doesn't create libxcb-xlib;
 * there isn't file xcb-xlib.pc used by all X library and X server.

To use these new libraries is needed update all X library to last version.
I will insert here all ebuild used by all libraries. I hope that will insert at least on layman x11.

Bye
Comment 4 Geaaru 2008-11-26 08:58:56 UTC
Created attachment 173415 [details]
version 1.1.99.2 of libX11 that doesn't use xcb-xlib.pc file
Comment 5 Geaaru 2008-11-26 21:12:06 UTC
Created attachment 173520 [details]
randrproto version 1.2.99.1
Comment 6 Geaaru 2008-11-26 21:12:50 UTC
Created attachment 173522 [details]
xproto-7.0.14
Comment 7 Geaaru 2008-11-26 21:21:47 UTC
Created attachment 173525 [details]
libXi version 1.1.4
Comment 8 Geaaru 2008-11-26 21:22:23 UTC
Created attachment 173526 [details]
libXaw version 1.0.5
Comment 9 Geaaru 2008-11-27 08:33:51 UTC
Created attachment 173571 [details]
Remove xprint use flags because xprint library is depracated and libXaw8 is not included with new version
Comment 10 Geaaru 2008-11-30 08:53:42 UTC
I have some problems with new libXcb ... i have this error when i try to start application that use glx:

glxinfo: _XReply: Assertion `!dpy->xcb->reply_data' failed

This error is relative to file xcb_io.c in libX11 library... seems that xorg-server doesn't return correct data. In this moment i use xorg-server 1.5.3 but i try to use repository version or an older version.

Anyone had already see this error?

Bye

Ge@@ru
Comment 11 Rémi Cardona gentoo-dev 2008-11-30 17:18:41 UTC
(In reply to comment #10)
> I have some problems with new libXcb ... i have this error when i try to start
> application that use glx:
> 
> glxinfo: _XReply: Assertion `!dpy->xcb->reply_data' failed
> 
> This error is relative to file xcb_io.c in libX11 library... seems that
> xorg-server doesn't return correct data. In this moment i use xorg-server 1.5.3
> but i try to use repository version or an older version.

Please file a bug in http://bugs.freedesktop.org/

Upstream needs to know ASAP about this sort of bugs. And if it's already fixed, we need to pull the patch :)

Thanks
Comment 12 Geaaru 2008-11-30 22:32:20 UTC
Bug opened on bugzilla... i'm waiting for a response.

Bye

Ge@@ru
Comment 13 Geaaru 2008-12-02 22:03:26 UTC
I see new ebuild about xorg-server-1.5.99.1 but doesn't compile...
I see that file hw/dmx/input/atKeynames.h isn't inside of the 1.5.99.1 package but it is included of files usb-keyboard.c and lnx-keyboard.c

Ge@@ru
Comment 14 Geaaru 2008-12-02 23:18:32 UTC
I speak of this problem about lost files on xorg-server chat channel and developers said me that will be soon released a patch to use with 1.5.99.x tree that resovle problem.

Byes
Comment 15 Geaaru 2008-12-03 14:51:40 UTC
Created attachment 174166 [details]
xorg-server-1.5.99.2

This version compile but i think that is correct wait a new version... only version from git remove problem about libX11 for

glxinfo: _XReply: Assertion `!dpy->xcb->reply_data' failed

error.

Bye

Ge@@ru
Comment 16 Geaaru 2008-12-03 14:54:10 UTC
Ah sorry, it works fine only with dmx disabled else there are compile error with Xcalloc macro.
Comment 17 Donnie Berkholz (RETIRED) gentoo-dev 2009-02-27 06:29:18 UTC
Since xcb isn't enabled by default, I'm kinda thinking we just go with the dumb solution -- bump, require USE=xcb people to do lots of revdep-rebuilding (ewarn). Maybe with a note (ewarn) that --as-needed folks can use sed on *la instead.

Additionally, I think we should go EAPI=1 on libX11 and set +xcb by default.

Remi, or anyone else, thoughts?
Comment 18 Geaaru 2009-02-27 06:44:44 UTC
Created attachment 183338 [details]
New version of libxcb-1.2

Works for me (on amd64).
Comment 19 Geaaru 2009-02-27 06:45:54 UTC
Created attachment 183340 [details]
xcb-proto-1.4

needed for libxcb-1.2
Comment 20 Geaaru 2009-02-27 06:50:22 UTC
Created attachment 183341 [details]
Released version 1.6.0 of the xorg server

On xorg-server-1.5.99.303 is been identified a regression that broken compiz for radeon driver with white screen. This bug is been fixed with 1.6.0.
And now works fine. Seems that there are less memory leak of previous beta versions.

I think that an ewarn about rebuild of all libraries that use libxcb is correct but i think that as on beta portage version (2.2*) a way to recompile all package used by compiz with emerge @compiz is another worderfull thing.

Bye
Ge@@ru
Comment 21 Geaaru 2009-02-27 07:32:15 UTC
Created attachment 183343 [details]
Xorg-server-1.6.0

Sorry, it is needed remove old patches.

Ge@@ru
Comment 22 Rémi Cardona gentoo-dev 2009-02-27 08:02:19 UTC
(In reply to comment #17)
> Remi, or anyone else, thoughts?

Yeah, I guess people who use USE=xcb had it coming anyway :) In any case, the sooner we get it done, the better.

+1 from me.

Thanks
Comment 23 aidar 2009-02-27 12:40:13 UTC
emerging xorg-server-1.6.0 says : 

...
 -I../composite -I../damageext -I../xfixes -I../Xi -I../mi -I../miext/shadow  -I../miext/damage -I../render -I../randr -I../fb -DVENDOR_NAME=\""The X.Org Foundation"\" -DVENDOR_RELEASE="(((1) * 10000000) + ((6) * 100000) + ((0) * 1000) + 0)" -O2 -pipe -mtune=core2 -march=core2 -fomit-frame-pointer -MT dispatch.lo -MD -MP -MF .deps/dispatch.Tpo -c -o dispatch.lo dispatch.c
In file included from dispatch.c:134:
../Xext/panoramiX.h:44:41: error: X11/extensions/panoramiXext.h: No such file or directory
make[2]: *** [dispatch.lo] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.6.0/work/xorg-server-1.6.0/dix'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/x11-base/xorg-server-1.6.0/work/xorg-server-1.6.0/dix'
make: *** [all-recursive] Error 1
 * 
 * ERROR: x11-base/xorg-server-1.6.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3170:  Called x-modular_src_compile
 *             environment, line 3965:  Called x-modular_src_make
 *             environment, line 4000:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.6.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.6.0/temp/environment'.
Comment 24 Rémi Cardona gentoo-dev 2009-02-27 12:45:48 UTC
(In reply to comment #23)
> emerging xorg-server-1.6.0 says : 

@Amir, please don't hijack this bug and open a new one.

@Geaaru, we already have ebuilds in the x11 overlay for all this stuff, please only post diffs if you have improvements for them.

Thanks
Comment 25 Geaaru 2009-02-27 21:16:05 UTC
Created attachment 183410 [details]
libX11-1.2

Now you can found yet new libX11-1.2 library.

About your error:
$# equery belongs panoramiXext.h
[ Searching for file(s) panoramiXext.h in *... ]
x11-proto/xineramaproto-1.1.2 (/usr/include/X11/extensions/panoramiXext.h

What version of the xineramaproto package you have installed?

For some packages i use x11 overlay ebuild directly from git repository. I will try to create ebuild for all libraries/proto used on my environment.

Good luck!

Bye
Comment 26 Ryan 2009-03-06 23:09:34 UTC
Found this bug from the blog post. 

I've ended up with a good mix of ~ and non-~ system. My portage is sys-apps/portage-2.2_rc23 , 

I think b/c of the preserved libs. It was keeping libxcb-xlib.so.0.0.0 , which was breaking any type of rebuild.

The rebuild script provided doesn't work. I am having to use revdep-rebuild. I'll keep this updated with what I find.
Comment 27 Alexander 'E-Razor' Krause 2009-03-10 16:00:32 UTC
Hi all.

I was just adding the X11 overlay and did a emerge -uD world .
Then i did a revdep-rebuild after upgrading to x11-libs/libxcb-1.2 .

Well, i got a huge list of broken packages and most i can't emerge most of them cos of 
libtool: link: `/usr/lib/libxcb-xlib.la' is not a valid libtool archive

Packages are for example cairo and pango.

Anyone got a hint for me?
Comment 28 Donnie Berkholz (RETIRED) gentoo-dev 2009-03-10 18:02:35 UTC
Did you run xcb-rebuilder.sh?
Comment 29 Alexander 'E-Razor' Krause 2009-03-10 18:41:08 UTC
(In reply to comment #28)
> Did you run xcb-rebuilder.sh?
Just did that, and sorry, the message was:
grep: /usr/lib/libxcb-xlib.la: No such file or directory                                       
/bin/sed: can't read /usr/lib/libxcb-xlib.la: No such file or directory                        
libtool: link: `/usr/lib/libxcb-xlib.la' is not a valid libtool archive

Comment 30 Ivor Prebeg 2009-03-28 22:46:04 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > Did you run xcb-rebuilder.sh?
> Just did that, and sorry, the message was:
> grep: /usr/lib/libxcb-xlib.la: No such file or directory                        
> /bin/sed: can't read /usr/lib/libxcb-xlib.la: No such file or directory         
> libtool: link: `/usr/lib/libxcb-xlib.la' is not a valid libtool archive
> 

Same here
Comment 31 István Pongrácz 2009-04-03 09:45:58 UTC
> 
> Same here
> 

Unfortunately the same here. Now I have a totally broken machine :)
Comment 33 tonich 2009-04-03 10:16:35 UTC
PS. find /usr/lib -name "*.la" | xargs egrep libxcb-xlib 2>/dev/null | awk -F':' '{print $1}' | while read i; do echo cat $i | sed 's/\/usr\/lib\/libxcb-xlib.la//g' > /tmp/qweqwe; mv /tmp/qweqwe $i ; done | sh

Comment 34 Andrew Muhametshin 2009-04-03 12:02:40 UTC
1.
I upgraded the libxcb-1.1.90.1 to the libxcb-1.2

2.
Running:
$ find /usr/lib -name "*.la"  -exec \
 sed -e "s:-lxcb-xlib:: ; s:/usr/lib/libxcb-xlib.la::" -i \{\} \;

$ find /usr/kde/3.5/lib -name "*.la" -exec \
 sed -e "s:-lxcb-xlib:: ; s:/usr/lib/libxcb-xlib.la::" -i \{\} \;

$ xcb-rebuilder.sh
...

3.
Some applications are not started now:
======================================
$ playonlinux
PlayOnLinux v3.3.1

Checking python :                               [ Ok ]
Traceback (most recent call last):
  File "/usr/share/games/playonlinux/python/mainwindow.py", line 23, in <module>
    import wx, wx.html
  File "/usr/lib/python2.5/site-packages/PIL/__init__.py", line 45, in <module>

  File "usr/lib/python2.5/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 4, in <module>
ImportError: /usr/lib/libxcb-xlib.so.0: undefined symbol: _xcb_lock_io

$ ccsm
Traceback (most recent call last):
  File "/usr/bin/ccsm", line 32, in <module>
    import gtk
  File "//usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 48, in <module>
    from gtk import _gtk
ImportError: /usr/lib/libxcb-xlib.so.0: undefined symbol: _xcb_lock_io
======================================
Comment 35 Rémi Cardona gentoo-dev 2009-04-03 12:13:03 UTC
(In reply to comment #29)
> grep: /usr/lib/libxcb-xlib.la: No such file or directory                        
> /bin/sed: can't read /usr/lib/libxcb-xlib.la: No such file or directory         
> libtool: link: `/usr/lib/libxcb-xlib.la' is not a valid libtool archive

Could you paste the full output when you run xcb-rebuilder.sh ?

(In reply to comment #34)
> 3.
> Some applications are not started now:

Try running revdep-rebuild.

Thanks
Comment 36 Andrew Muhametshin 2009-04-03 12:46:04 UTC
> (In reply to comment #34)
> > 3.
> > Some applications are not started now:
> 
> Try running revdep-rebuild.

some programs fails to compile:
==============================
/usr/lib/libxcb-xlib.so: undefined reference to `_xcb_lock_io'
/usr/lib/libxcb-xlib.so: undefined reference to `_xcb_unlock_io'
==============================
Comment 37 Rémi Cardona gentoo-dev 2009-04-03 13:45:53 UTC
(In reply to comment #36)
> > (In reply to comment #34)
> > > 3.
> > > Some applications are not started now:
> > 
> > Try running revdep-rebuild.
> 
> some programs fails to compile:
> ==============================
> /usr/lib/libxcb-xlib.so: undefined reference to `_xcb_lock_io'
> /usr/lib/libxcb-xlib.so: undefined reference to `_xcb_unlock_io'
> ==============================

Sigh, @preserved-rebuild is killing us here.

Please remove /usr/lib/libxcb-xlib.so first and then run revdep-rebuild. Beware that might have to run it multiple times and you might have to run some emerges by hand if you have circular deps on your system.

So far the safe way to bootstrap revdep-rebuild is to do those packages first (if you do have them) :
 - pango
 - cairo
 - gtk+
 - libgnomeui

I have no idea what order Qt/KDE libs should be rebuilt in.

Cheers
Comment 38 István Pongrácz 2009-04-03 14:40:46 UTC
(In reply to comment #37)
> 
>  - pango
>  - cairo

In my system Cairo (x11-libs/cairo-1.8.6-r1) tries to find libxcb-render-util (-lxcb-render-util).
........
/usr/lib/gcc/i686-pc-linux-gnu/4.3.3/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lxcb-render-util
........
When I removed manually these libs and build cairo without that, I was able to compile it, but after I got error with pango :) 
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_query_version'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_glyphs_8'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_find_standard_format'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_glyphs_32'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_query_formats'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_composite_text_free'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_composite_text'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_find_visual_format'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_find_format'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_composite_text_stream'
/usr/lib/libcairo.so: undefined reference to `xcb_render_util_glyphs_16'

Not so easy :)

István
Comment 39 Rémi Cardona gentoo-dev 2009-04-03 14:50:46 UTC
New list :

 - xcb-util
 - pango
 - cairo
 - gtk+
 - libgnomeui
Comment 40 István Pongrácz 2009-04-03 14:58:05 UTC
(In reply to comment #39)
> New list :
> 
>  - xcb-util
>  - pango
>  - cairo
>  - gtk+
>  - libgnomeui
> 

I really like you, thanks :) Just do it.
Comment 41 István Pongrácz 2009-04-03 15:06:19 UTC
(In reply to comment #40)
> (In reply to comment #39)
> > New list :
> > 
> >  - xcb-util

Now I remember. When I was in light-panic, I wiped out all libxcb*.la, and xcb-util was in the victims. After I forgot to recompile xcb-util.

So, this was my fault, sorry. The original list also good for others, who saved xcb-util libs.

(...compiling...)

Comment 42 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-15 16:06:00 UTC
*** Bug 266188 has been marked as a duplicate of this bug. ***
Comment 43 Rémi Cardona gentoo-dev 2009-08-18 09:16:19 UTC
All of those are now unmasked in the 10.0 profile.

I'll write up a proper announcement with a small howto based on the info we gathered here.

Thanks to all for your feedback, we greatly appreciate it :)
Comment 44 Pascal Vanier 2009-09-16 08:30:58 UTC
Thanks guys, this really helped me!
Comment 45 ~S 2009-09-17 08:29:52 UTC
@Rémi Cardona 
can you please direct me to the announcement?
I am totally confused here

~S
Comment 46 Tomáš Chvátal (RETIRED) gentoo-dev 2009-09-17 08:40:38 UTC
(In reply to comment #45)
> @Rémi Cardona 
> can you please direct me to the announcement?
> I am totally confused here
> 
> ~S
> 

http://archives.gentoo.org/gentoo-dev/msg_95329568add4ae50f128a0775a7007c1.xml

Comment 47 Rémi Cardona gentoo-dev 2009-09-17 10:24:20 UTC
That and the ebuild contains a big ewarn message with a link to the upgrade guide.

Thanks
Comment 48 ~S 2009-09-17 13:30:58 UTC
thanks a lot again
i did emerge -uavDN world after a long time and it updated loads of packages
I couldn't see each and every package's build warns
is there any way to tell portage to report all build.warns/messages at the end of emerge -uavDN world?
one simply can not keep looking at the scrolling text and read the warn messages when emerge is compiling packages one after other

again, thanks a lot !
used the upgrade guide to fix ~65 packages :)
i suppose revdep will fix the rest

~S
Comment 49 Peter Fern 2010-03-21 02:29:16 UTC
(In reply to comment #48)
> thanks a lot again
> i did emerge -uavDN world after a long time and it updated loads of packages
> I couldn't see each and every package's build warns
> is there any way to tell portage to report all build.warns/messages at the end
> of emerge -uavDN world?
> one simply can not keep looking at the scrolling text and read the warn
> messages when emerge is compiling packages one after 

Check the ELOG options in make.conf - this will save (or email) the messages for you.  If you choose to save them, elogv (console) or elogviewer (GUI) will allow you to review the messages.