Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 248125 - nautilus-2.22 does not build with eel-2.24
Summary: nautilus-2.22 does not build with eel-2.24
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 261028 (view as bug list)
Depends on:
Blocks: 260063
  Show dependency tree
 
Reported: 2008-11-22 08:52 UTC by Jeremy Huddleston Sequoia
Modified: 2009-06-17 22:40 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Huddleston Sequoia 2008-11-22 08:52:08 UTC
Keywords were dropped from nautilus-2.24, but they weren't dropped from eel-2.24.  nautilus-2.22 does not build against the new eel.

Also, I couldn't find a bug report about why keywords were dropped...
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-11-22 10:21:02 UTC
see bug #242812 for why some keywords were dropped.

*** This bug has been marked as a duplicate of bug 242842 ***
Comment 2 Mart Raudsepp gentoo-dev 2008-11-23 01:30:16 UTC
Reopening as the bug is valid - we need to drop keywords on eel-2.24 as well to match nautilus-2.24, but that also means gnome-desktop-2.24, and everything that needs that for GnomeBG changes, sigh.
Comment 3 Mart Raudsepp gentoo-dev 2008-11-23 01:31:00 UTC
So at that point it's better to handle it with an exempi package.use.mask instead of keyword dropping I guess.
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-02 00:09:54 UTC
This bug is blocking the stab bug, but I don't see anything here for arches to do. Is that correct? If arches need to do something, do you mind CC'ing arches with specific details?
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-03-02 00:17:44 UTC
there is indeed nothing to do here, it's in the dep list to remind that some stuff needs to be done in one block.
Comment 6 Rémi Cardona gentoo-dev 2009-03-03 10:17:54 UTC
*** Bug 261028 has been marked as a duplicate of this bug. ***
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-06-17 22:40:06 UTC
most arches finished gnome 2.24 stabilization. Closing.