Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 247825 - Please stabilize gnome-base/gnome-keyring-2.22.3-r1
Summary: Please stabilize gnome-base/gnome-keyring-2.22.3-r1
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: gnome2.22-tracker 260063
  Show dependency tree
 
Reported: 2008-11-20 21:02 UTC by Pacho Ramos
Modified: 2009-04-28 17:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2008-11-20 21:02:18 UTC
Works fine for me since it was released:

Portage 2.1.4.5 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.27-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3200+
Timestamp of tree: Thu, 20 Nov 2008 20:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -msse3"
DISTDIR="/usr/distfiles"
FEATURES="autoaddcvs ccache collision-protect cvs distlocks fixpackages metadata-transfer multilib-strict parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 amr asf audiofile avahi bash-completion beagle berkdb bzip2 bzlib cairo caps cdb cdda cddb cdinstall cdparanoia cdr cli consolekit cpdflib cpudetection cracklib cross crypt cups curl daap dbus dga dirac divx4linux djvu dlloader dri dts dv dvb dvd dvdr dvdread dvi eds emboss encode epiphany erandom escreen evo evolution exif fam fame fbcon ffmpeg flac foomaticdb fortran ftp fuse galago gb gcj gd ggi gif gimp gimpprint git glitz glut glx gnome gnome-keyring gnome-print gphoto2 gpm gsm gstreamer gtk gtk2 hal hddtemp iconv idn imagemagick imlib inotify isdnlog ithreads jabber java java6 jpeg kdeenablefinal kdehiddenvisibility kpathsea ladspa lame latex lcms libnotify lm_sensors logrotate lzma mad madwifi midi mikmod mime mjpeg mmx mmxext mng mono moonlight motif mp3 mpeg mpi mplayer mudflap multilib musepack musicbrainz nas nautilus ncurses nethack network nls nocardbus nptl nptlonly ntp nvidia ogg oggvorbis openal opengl openmp pam pango pch pcre pdf perl plotutils png posix postscript ppds pppd python qt3 qt3support qt4 quicktime readline reflection remote rtc scanner schroedinger sdl session slang slp sockets spell spl sse sse2 sse3 ssl ssse3 startup-notification subversion svg sysfs sysvipc t1lib tcpd theora threads thunderbird tiff timidity totem trayicon truetype unicode usb v4l2 vcd vhook videos vim vorbis wma wmf x264 xattr xcb xcomposite xft xine xml xml2 xorg xpm xulrunner xv xvid xvmc zlib" ALSA_CARDS="via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-11-21 22:10:29 UTC
Hi arches, please go ahead.

Target keywors are:
alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86
Comment 2 Markus Meier gentoo-dev 2008-11-22 14:22:23 UTC
I was having troubles upgrading this packages with USE="test" enabled. gnome-base/gnome-keyring-2.22.3 was installed, when upgrading to -r1 with USE="test" enabled it failed like that:

i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../.. -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1   -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include       -O2 -march=i686 -pipe -MT run_auto_test-unit-test-keyring-login.o -MD -MP -MF .deps/run_auto_test-unit-test-keyring-login.Tpo -c -o run_auto_test-unit-test-keyring-login.o `test -f 'unit-test-keyring-login.c' || echo './'`unit-test-keyring-login.c
unit-test-keyring-login.c: In function 'verify_no_ask':
unit-test-keyring-login.c:68: error: 'CuTest' undeclared (first use in this function)
unit-test-keyring-login.c:68: error: (Each undeclared identifier is reported only once
unit-test-keyring-login.c:68: error: for each function it appears in.)
unit-test-keyring-login.c:68: error: 'cu' undeclared (first use in this function)
unit-test-keyring-login.c:68: error: expected expression before ')' token
unit-test-keyring-login.c: At top level:
unit-test-keyring-login.c:72: error: expected ')' before '*' token
unit-test-keyring-login.c:102: error: expected ')' before '*' token
make[3]: *** [run_auto_test-unit-test-keyring-login.o] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-2.22.3-r1/work/gnome-keyring-2.22.3/keyrings/tests'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-2.22.3-r1/work/gnome-keyring-2.22.3/keyrings'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-keyring-2.22.3-r1/work/gnome-keyring-2.22.3'
make: *** [all] Error 2
 * 
 * ERROR: gnome-base/gnome-keyring-2.22.3-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2751:  Called gnome2_src_compile
 *             environment, line 2046:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure

emerging with USE="-test" (and FEATURES="-test") worked w/o problems. after -r1 is installed, remerging with USE="test" also works w/o problems.

what should we do about it?
Comment 3 Tobias Scherbaum (RETIRED) gentoo-dev 2008-11-22 15:56:36 UTC
works for me. ppc stable.
Comment 4 Mart Raudsepp gentoo-dev 2008-11-23 02:01:09 UTC
(In reply to comment #2)
> emerging with USE="-test" (and FEATURES="-test") worked w/o problems. after -r1
> is installed, remerging with USE="test" also works w/o problems.
> 
> what should we do about it?

Wonder if latest stable had similar issues? 
Smells like tests link against system libraries if it fails later, which is bad as it's in that case testing system gnome-keyring, not the one being emerged
Comment 5 Pacho Ramos gentoo-dev 2008-11-23 14:40:53 UTC
The problem is that, now, building with "test" also work when emerging:
# emerge -1 =gnome-base/gnome-keyring-2.22.2
# emerge -1 =gnome-base/gnome-keyring-2.22.3
# emerge -1 =gnome-base/gnome-keyring-2.22.3-r1

Anyway gnome-keyring seems to work ok, but I don't know where is the real problem with tests :-/
Comment 6 Brent Baude (RETIRED) gentoo-dev 2008-11-26 15:39:32 UTC
ppc64 done
Comment 7 Tobias Klausmann gentoo-dev 2008-12-15 20:20:24 UTC
Stable on alpha.
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2008-12-16 15:53:27 UTC
Stable for HPPA.
Comment 9 Friedrich Oslage (RETIRED) gentoo-dev 2008-12-28 14:35:22 UTC
sparc stable
Comment 10 Raúl Porcel (RETIRED) gentoo-dev 2009-01-07 18:55:40 UTC
ia64 stable
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-03-07 02:42:34 UTC
gnome team: Since tests are obviously wrong, do you think it would be a good idea to RESTRICT=test?
Comment 12 Matthias Langer 2009-03-15 00:48:16 UTC
(In reply to comment #11)
> gnome team: Since tests are obviously wrong, do you think it would be a good
> idea to RESTRICT=test?

Seems to be a good idea to me too, as I get very similar (not exactly the same) compile failures as mentioned in comment 2 on amd64 with 

gnome-base/gnome-keyring-2.22.3-r1 USE="hal pam test* -debug -doc":

"
>>> Emerging (1 of 1) gnome-base/gnome-keyring-2.22.3-r1
[...]
make[3]: Entering directory `/var/tmp/portage/gnome-base/gnome-keyring-2.22.3-r1/work/gnome-keyring-2.22.3/library/tests'
sh ../../tests/prep-tests.sh -b run-auto-test unit-test-memory.c unit-test-keyrings.c unit-test-other.c unit-test-daemon-setup.c 
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../.. -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1   -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include      -DEXTERNAL_TEST -march=nocona -O2 -pipe -MT run_auto_test-unit-test-memory.o -MD -MP -MF .deps/run_auto_test-unit-test-memory.Tpo -c -o run_auto_test-unit-test-memory.o `test -f 'unit-test-memory.c' || echo './'`unit-test-memory.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I../.. -I../.. -I../.. -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/pixman-1   -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include      -DEXTERNAL_TEST -march=nocona -O2 -pipe -MT run_auto_test-unit-test-keyrings.o -MD -MP -MF .deps/run_auto_test-unit-test-keyrings.Tpo -c -o run_auto_test-unit-test-keyrings.o `test -f 'unit-test-keyrings.c' || echo './'`unit-test-keyrings.c
unit-test-keyrings.c:53: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:62: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:77: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:94: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:110: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:121: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:201: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:255: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:269: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:287: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:295: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:307: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:328: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:394: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c: In function ‘done_find_password’:
unit-test-keyrings.c:437: error: ‘CuTest’ undeclared (first use in this function)
unit-test-keyrings.c:437: error: (Each undeclared identifier is reported only once
unit-test-keyrings.c:437: error: for each function it appears in.)
unit-test-keyrings.c:437: error: ‘cu’ undeclared (first use in this function)
unit-test-keyrings.c:437: error: expected expression before ‘)’ token
unit-test-keyrings.c: At top level:
unit-test-keyrings.c:445: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:487: error: expected ‘)’ before ‘*’ token
unit-test-keyrings.c:518: error: expected ‘)’ before ‘*’ token
[...]
 * ERROR: gnome-base/gnome-keyring-2.22.3-r1 failed.
"

Portage 2.1.6.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E6550_@_2.33GHz-with-glibc2.2.5
Timestamp of tree: Sat, 14 Mar 2009 21:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/var/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ http://mirror.uni-c.dk/pub/gentoo/ http://trumpetti.atm.tut.fi/gentoo/ "
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/var/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/portage/repos/gentoo"
PORTDIR_OVERLAY="/var/portage/repos/layman/java-overlay /var/portage/repos/private"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acpi alsa amd64 berkdb bluetooth branding bzip2 cairo caps cddb cdparanoia cdr cli cracklib crypt cups dbus djvu dri dvd dvdr dvdread eds emboss encode evo exif fam ffmpeg firefox flac fortran gd gdbm gif gimp gnome gnome-keyring gphoto2 gpm gstreamer gtk hal hddtemp iconv icu ipod ipv6 isdnlog java java6 jpeg jpeg2k lcms libnotify lm_sensors log4j mad matroska midi mikmod mmap mmx mmxext mono mp3 mpeg mudflap multilib musicbrainz ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl plotutils png ppds pppd pulseaudio python qt3support quicktime readline reflection ruby sdl session spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd tetex theora threads tiff truetype unicode usb vcd vim-syntax vorbis xattr xine xinerama xml xorg xulrunner xv xvid zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon konica ptp2 kodak" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Comment 13 Raúl Porcel (RETIRED) gentoo-dev 2009-03-20 15:38:20 UTC
I was told by the gnome team that tests are restricted in newer ebuilds, so ignore the test failures.
Comment 14 Markus Meier gentoo-dev 2009-03-22 15:16:43 UTC
  15 Mar 2009; Markus Meier <maekke@gentoo.org>
  gnome-keyring-2.22.3-r1.ebuild:
  x86 stable, bug #260063

  11 Mar 2009; Daniel Gryniewicz <dang@gentoo.org>
  gnome-keyring-2.22.3-r1.ebuild:
  Marked stable on amd64
Comment 15 Guy Fontaine 2009-04-23 11:04:42 UTC
I encountered some problems in ~x86 environment. Ebuild fails to install because libtasn1-config can't be found as a result of libtasn1 not installing the script in /usr/bin.

I masked dev-libs/libtasn1-2.1 and downgraded to previous version. That enabled me to install gnome-keyring and to complete installation of gnome-light 2.24.
Comment 16 Gilles Dartiguelongue gentoo-dev 2009-04-23 11:46:30 UTC
you are experimenting bug #266554
Comment 17 Raúl Porcel (RETIRED) gentoo-dev 2009-04-28 17:51:30 UTC
arm/sh stable, closing