Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 24761 - Russian fonts are not properly displayed in gtk2 apps, unless fontconfig is reinstalled.
Summary: Russian fonts are not properly displayed in gtk2 apps, unless fontconfig is r...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
Depends on:
Reported: 2003-07-18 12:32 UTC by Sergey Kuleshov (RETIRED)
Modified: 2003-10-01 00:28 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Kuleshov (RETIRED) gentoo-dev 2003-07-18 12:32:07 UTC
Ok, this is a really strange issue with fontconfig, which I came across a number
of times. It is not always reproducible, but whenever it happens the solution is
always the same - reinstall fontconfig.

All the following *seems* to happen if you are not running UTF locale. The
problem is the following, after emergeing certain applications, such as mazilla
(AFAIK with gtk2 support), or just gnome (on a newly installed system or the one
already running some non-gtk2 apps). All the russian characters a replced with
squares, containing utf codes in them. It does not matter which font you chhose
the situation is always the same.

The sollution, which always seems to work, is to reemrge fontconfig, though I do
not understand who it actually works.

Reproducible: Sometimes
Steps to Reproduce:
1. Set locale to ru_RU.KOI8-R
2. Emerge mozilla with GTK2 support.
3. Open a page with russian text (e.g.:

Actual Results:  
All russian text is replaced with rectangle with unicode codes in them.

Expected Results:  
See russian text.
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2003-07-19 08:25:03 UTC
do you have any fonts that provide russion cyrillic characters?
Comment 2 Sergey Kuleshov (RETIRED) gentoo-dev 2003-07-19 08:32:39 UTC
Yes I do have (e.g.: Verdana font). A small addition to the bug: In the same time all gtk1 apps work with no problems.
Comment 3 Alastair Tse (RETIRED) gentoo-dev 2003-07-21 02:29:04 UTC
did you have an older fontconfig before hand? 

as far as i know, verdana should work fine with russian fonts on mozilla or any other gtk app. (i know because evolution opens all my russian spam properly ;)

it is the first time i've heard of this, but i'm not too familiar with fontconfig, maybe foser might know a little more about it.
Comment 4 Sergey Kuleshov (RETIRED) gentoo-dev 2003-07-21 03:31:56 UTC
Nope, I did not have an older fontconfig before, as I had exactly the same trouble with a plain new installation. It seems to be that fontconfig does not see any oher glyphs except english one. Reemerge it and it sees them ;)
Comment 5 Sergey Kuleshov (RETIRED) gentoo-dev 2003-07-29 00:50:45 UTC
One more testing case showed that fc-cache -v does not solve the issue. Againg reemerging was the remedy.
Comment 6 foser (RETIRED) gentoo-dev 2003-07-29 14:25:36 UTC
hmm that shouldve been 'fc-cache -f', did i say -v ? -vf wouldve been ok
Comment 7 Maksim D. 2003-08-01 16:31:00 UTC
If I open xterm and switch GTK font antialiasing off (export GDK_USE_XFT=1), then start application from this xterm window (for example Mozilla) I don't have such a problem (but I don't have antialiased font support of course). Of course it disapears too after reemerging fontconfig.
Comment 8 foser (RETIRED) gentoo-dev 2003-09-21 08:26:21 UTC

still need you to try with '-f'
Comment 9 Sergey Kuleshov (RETIRED) gentoo-dev 2003-09-30 12:11:19 UTC
I recently made a fresh gentoo installation on a new box with gtk2 + gnome.
fc-cache -f did not help at all. It indeed regenerated the cache, but everything
stayed as it was. Again remerging solved the isue.
Comment 10 foser (RETIRED) gentoo-dev 2003-09-30 14:43:03 UTC
well either there's something happening to your binaries or it's a complete
mystery to me. The only thing the ebuild does is rebuild and run 'fc-cache
-f' (as root). 

It is possible that the fontconfig caches are locale dependant, but then
this should be solved if you redo this with under the right locale.
Comment 11 Sergey Kuleshov (RETIRED) gentoo-dev 2003-10-01 00:28:25 UTC
>It is possible that the fontconfig caches are locale dependant, but then
>this should be solved if you redo this with under the right locale.

This was the case, as I specify my LC_ALL settings in the 00basic (or /etc/profile)
file, which means that root has exactly the same locale.