Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 247287 - media-plugins/audacious-plugins-1.4.5 gcc-4.3.2 USE="modplug" - archive/arch_gzip.cxx:130: error: ‘strlen’ was not declared in this scope
Summary: media-plugins/audacious-plugins-1.4.5 gcc-4.3.2 USE="modplug" - archive/arch_...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on: 245835
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-11-17 23:52 UTC by Yaroslav Gorbunov
Modified: 2009-03-14 21:35 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
proposed parch (audacious-plugins-1.4.5-gcc-4.3.patch,1.41 KB, patch)
2008-11-18 00:05 UTC, Yaroslav Gorbunov
Details | Diff
audacious-plugins-1.4.5.ebuild.diff (audacious-plugins-1.4.5.ebuild.diff,335 bytes, patch)
2008-11-18 00:08 UTC, Yaroslav Gorbunov
Details | Diff
audacious-plugins-1.4.4.ebuild.diff (audacious-plugins-1.4.4.ebuild.diff,342 bytes, patch)
2008-11-18 00:21 UTC, Yaroslav Gorbunov
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav Gorbunov 2008-11-17 23:52:49 UTC
I tried to emerge media-plugins/audacious-plugins-1.4.5 with USE="alsa dbus flac modplug* mp3 nls sse2 vorbis wavpack wma -aac -adplug -arts -chardet -esd -gnome -jack -lirc -mtp -musepack -oss -pulseaudio -sdl -sid -sndfile -timidity -tta" with gcc-4.3.2

Emerge fails with this:

Successfully compiled archive/arch_zip.cxx.
archive/arch_gzip.cxx: In static member function ‘static bool arch_Gzip::ContainsMod(const std::string&)’:
archive/arch_gzip.cxx:130: error: ‘strlen’ was not declared in this scope
Failed to compile archive/arch_gzip.cxx!
make[5]: *** [archive/arch_gzip.o] Error 1
make[5]: *** Waiting for unfinished jobs....
archive/arch_rar.cxx: In constructor ‘arch_Rar::arch_Rar(const std::string&)’:
archive/arch_rar.cxx:61: error: ‘strlen’ was not declared in this scope
archive/arch_rar.cxx:64: error: ‘strlen’ was not declared in this scope
archive/arch_rar.cxx:87: error: ‘strtol’ was not declared in this scope
archive/arch_rar.cxx: In static member function ‘static bool arch_Rar::ContainsMod(const std::string&)’:
archive/arch_rar.cxx:171: error: ‘strlen’ was not declared in this scope
archive/arch_rar.cxx:174: error: ‘strlen’ was not declared in this scope
Failed to compile archive/arch_rar.cxx!
make[5]: *** [archive/arch_rar.o] Error 1
make[4]: *** [all] Error 1
make[3]: *** [subdirs] Error 1
make[2]: *** [all] Error 1
make[1]: *** [subdirs] Error 1
make: *** [all] Error 1
 *
 * ERROR: media-plugins/audacious-plugins-1.4.5 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2375:  Called die
 * The specific snippet of code:
 *       emake || die "make failed"
 *  The die message:
 *   make failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-plugins/audacious-plugins-1.4.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-plugins/audacious-plugins-1.4.5/temp/environment'.

Reproducible: Always

Steps to Reproduce:
1.USE="modplug" emerge =audacious-plugins-1.4.5
2.
3.




emerge --info
Portage 2.2_rc14 (default-linux/x86/2007.0, gcc-4.3.2, glibc-2.7-r2, 2.6.25-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r9-i686-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.0
Timestamp of tree: Sat, 15 Nov 2008 15:00:11 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS=""
LINGUAS="en ru"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/berkano /usr/local/portage/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb cli cracklib crypt css dri fortran fuse gdbm gpm hal iconv isdnlog kde lm_sensors midi mmx mudflap ncurses nls nptl nptlonly nvidia opengl openmp pam pcre perl pppd python qt3 readline reflection samba session spl sse sse2 sse3 ssl ssse3 tcpd unicode userlocales utf8 x86 xorg xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon ptp2" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nvidia vesa i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Yaroslav Gorbunov 2008-11-18 00:05:49 UTC
Created attachment 172145 [details, diff]
proposed parch

I think the reason is Header dependency streamlining in gcc-4.3 http://gcc.gnu.org/onlinedocs/libstdc++/manual/api.html#api.rel_430

On my system problem is solved with changing <string> to <cstring> in arch_gzip.h and arch_rar.h, and adding #include <cstdlib> in arch_rar.cxx

Please check this patch
Comment 2 Yaroslav Gorbunov 2008-11-18 00:08:05 UTC
Created attachment 172147 [details, diff]
audacious-plugins-1.4.5.ebuild.diff

Patch for audacious-plugins-1.4.5.ebuild
Comment 3 Yaroslav Gorbunov 2008-11-18 00:21:13 UTC
Created attachment 172148 [details, diff]
audacious-plugins-1.4.4.ebuild.diff

I have the same error for audacious-plugins-1.4.4, and audacious-plugins-1.4.5-gcc-4.3.patch solve this problem.

This is patch for audacious-plugins-1.4.4.ebuild
Comment 4 Tony Vroon gentoo-dev 2008-11-19 16:22:32 UTC
This is no way related to ALSA, reassigning bug to correct owner.
Could you please confirm that the 1.5.1 core & plugins of Audacious handle this correctly. If they do, we will push those packages for stable rather then patch an old version.
Comment 5 Yaroslav Gorbunov 2008-11-20 12:04:16 UTC
Yes, audacious-plugins-1.5.1 + audacious-1.5.1 and audacious-1.5.1-r1 + audacious-plugins-1.5.1-r2 handle this correctly.
Comment 6 Tony Vroon gentoo-dev 2008-11-24 17:33:16 UTC
Arch teams, please test and mark (early) stable:
dev-libs/libmowgli-0.7.0 
dev-libs/libmcs-0.7.1-r2 
media-sound/audacious-1.5.1-r1
media-plugins/audacious-plugins-1.5.1-r3

These packages are blocking the GCC 4.3 stabilisation effort. Some last minute (and minor) wrinkles have been ironed out.

Target keywords: alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd
(AMD64 just done by me)
Comment 7 Brent Baude (RETIRED) gentoo-dev 2008-11-26 16:30:16 UTC
ppc64'd
Comment 8 Jeroen Roovers gentoo-dev 2008-11-27 22:03:46 UTC
Stable for HPPA.
Comment 9 Raúl Porcel (RETIRED) gentoo-dev 2008-11-30 20:03:46 UTC
sparc/x86 stable
Comment 10 Tobias Klausmann gentoo-dev 2008-12-13 18:32:36 UTC
All stable on alpha.
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-27 23:03:54 UTC
@ppc: ping, gcc-4.3 needs you.
Comment 12 nixnut (RETIRED) gentoo-dev 2009-03-14 21:35:16 UTC
ppc stable. closing since we're last