Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246415 - dev-perl/XML-Twig-3.29 - Warning: prerequisite XML::Parser 2.23 not found.
Summary: dev-perl/XML-Twig-3.29 - Warning: prerequisite XML::Parser 2.23 not found.
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-11 16:42 UTC by Anton Baklanov
Modified: 2008-11-12 16:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Baklanov 2008-11-11 16:42:32 UTC
>>> Emerging (1 of 1) dev-perl/XML-Twig-3.29 to /
 * XML-Twig-3.29.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                   [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                  [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                 [ ok ]
 * checking XML-Twig-3.29.tar.gz ;-) ...                                                                                               [ ok ]
>>> Unpacking source...
>>> Unpacking XML-Twig-3.29.tar.gz to /var/tmp/portage/dev-perl/XML-Twig-3.29/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-perl/XML-Twig-3.29/work/XML-Twig-3.29 ...
 * Using ExtUtils::MakeMaker
Do you want to install 'xml_pp' (XML pretty printer)? [y] y
Do you want to install 'xml_grep' (XML grep - grep XML files using XML::Twig's subset of XPath)? [y] y
Do you want to install 'xml_split' (split big XML files)? [y] y
Do you want to install 'xml_merge' (merge back files created by xml_split)? [y] y
Do you want to install 'xml_spellcheck' (spellcheck XML files skipping tags)? [y] y
Checking if your kit is complete...
Looks good
Warning: prerequisite XML::Parser 2.23 not found.
Writing Makefile for XML::Twig
/usr/bin/perl5.8.8 speedup Twig_pm.slow > Twig.pm
Can't locate XML/Parser.pm in @INC (@INC contains: /etc/perl /usr/lib/perl5/vendor_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl/5.8.8/i686-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/5.8.8/i686-linux-thread-multi /usr/lib/perl5/5.8.8 /usr/local/lib/site_perl .) at speedup line 5.
BEGIN failed--compilation aborted at speedup line 5.
make: *** [Twig.pm] Помилка 2
 *
 * ERROR: dev-perl/XML-Twig-3.29 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2371:  Called perl-module_src_compile
 *             environment, line 2107:  Called die
 * The specific snippet of code:
 *           make ${mymake} || die "compilation failed";
 *  The die message:
 *   compilation failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-perl/XML-Twig-3.29/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-perl/XML-Twig-3.29/temp/environment'.
 *


Reproducible: Always

Steps to Reproduce:
1. # emerge dev-perl/XML-Twig




# emerge --info
Portage 2.1.4.5 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r8_XATA i686)
=================================================================
System uname: 2.6.25-gentoo-r8_XATA i686 AMD Athlon(tm) XP 2500+
Timestamp of tree: Tue, 11 Nov 2008 15:45:03 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="uk_UA.UTF-8"
LC_ALL="uk_UA.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru uk"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 7zip X aac acl acpi alsa amr bash-completion berkdb bzip2 cli cracklib crypt cups dbus dri fortran gdbm gif gpm hal iconv ipv6 isdnlog java jpeg kde midi mmx mp3 mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png pppd python qt3 readline reflection sdl session source spell spl sse ssl sysfs tcpd tetex theora threads tiff truetype type1 unicode v4l v4l2 vim-syntax vorbis win32codecs x264 x86 xml xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru uk" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Jeroen Roovers gentoo-dev 2008-11-11 22:24:23 UTC
Does `emerge -1 dev-perl/XML-Parser' solve the problem? If not, did you recently run perl-cleaner?
Comment 2 Anton Baklanov 2008-11-12 08:20:48 UTC
(In reply to comment #1)
> Does `emerge -1 dev-perl/XML-Parser' solve the problem? If not, did you
> recently run perl-cleaner?
> 

All works after `emerge -1 dev-perl/XML-Parser`. Thanks.

I was trying to emerge www-apps/bugzilla when this bug appeared. I did not touch any perl stuff at all.
Comment 3 Jeroen Roovers gentoo-dev 2008-11-12 16:52:14 UTC

*** This bug has been marked as a duplicate of bug 41124 ***