Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246398 - kde-base/superkaramba-4.1.3 failed - and the same error with 4.1.2
Summary: kde-base/superkaramba-4.1.3 failed - and the same error with 4.1.2
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-11 14:02 UTC by Osipov S. Stanislav
Modified: 2008-11-16 13:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Osipov S. Stanislav 2008-11-11 14:02:13 UTC
[ 54%] Building CXX object superkaramba/src/CMakeFiles/superkaramba.dir/python/imagelabel.o
[ 56%] Building CXX object superkaramba/src/CMakeFiles/superkaramba.dir/python/graph.o
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp: In static member function ‘static void KarambaPython::initPython()’:
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp:418: ошибка: нет декларации ‘PyEval_InitThreads’ в этой области видимости
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp:424: ошибка: нет декларации ‘PyEval_ReleaseLock’ в этой области видимости
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp: In static member function ‘static void KarambaPython::shutdownPython()’:
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp:434: ошибка: нет декларации ‘PyEval_AcquireLock’ в этой области видимости
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp: In member function ‘void KarambaPython::getLock(PyThreadState**)’:
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp:441: ошибка: нет декларации ‘PyEval_AcquireLock’ в этой области видимости
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp: In member function ‘void KarambaPython::releaseLock(PyThreadState*)’:
/var/tmp/portage/kde-base/superkaramba-4.1.3/work/superkaramba-4.1.3/superkaramba/src/python/karamba.cpp:457: ошибка: нет декларации ‘PyEval_ReleaseLock’ в этой области видимости
make[2]: *** [superkaramba/src/CMakeFiles/superkaramba.dir/python/karamba.o] Ошибка 1
make[2]: *** Ожидание завершения заданий...
make[1]: *** [superkaramba/src/CMakeFiles/superkaramba.dir/all] Ошибка 2
make: *** [all] Ошибка 2
 *
 * ERROR: kde-base/superkaramba-4.1.3 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 3342:  Called kde4-meta_src_compile
 * environment, line 2627:  Called kde4-meta_src_make
 * environment, line 2676:  Called kde4-base_src_make
 * environment, line 2381:  Called cmake-utils_src_make
 * environment, line  880:  Called die
 * The specific snippet of code:
 * emake "$@" || die "Make failed!";
 * The die message:
 * Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/superkaramba-4.1.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/superkaramba-4.1.3/temp/environment'.
 *

>>> Failed to emerge kde-base/superkaramba-4.1.3, Log file:

>>>  '/var/tmp/portage/kde-base/superkaramba-4.1.3/temp/build.log'

 * Messages for package kde-base/superkaramba-4.1.3:

 *
 * ERROR: kde-base/superkaramba-4.1.3 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 3342:  Called kde4-meta_src_compile
 * environment, line 2627:  Called kde4-meta_src_make
 * environment, line 2676:  Called kde4-base_src_make
 * environment, line 2381:  Called cmake-utils_src_make
 * environment, line  880:  Called die
 * The specific snippet of code:
 * emake "$@" || die "Make failed!";
 * The die message:
 * Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/superkaramba-4.1.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/superkaramba-4.1.3/temp/environment'.
 *

 * GNU info directory index is up-to-date.
gentoo ~ # emerge --info
Portage 2.2_rc13 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r2-i686-AMD_Athlon-tm-_processor-with-glibc2.0
Timestamp of tree: Mon, 10 Nov 2008 14:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon -m3dnow -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -m3dnow -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://mirror.yandex.ru/gentoo-portage"
USE="3dnow X Xaw3d aac accessibility acl acpi alsa amr amrr animgif anonres ao apache2 archive arts async bitmap-fonts bluetooth browserplugin bzip2 calendar canon cli cracklib crypt css cups curl dbus dhcp directfb djvu dri dvdr dvdread encode esd fasttrack fbcon ffmpeg firefox flac ftp gd gif gnokii gnutella gphoto2 gpm gtk gtk+ gtk2 hal htmlhandbook i18n iconv idea imap isdnlog java javascript jpeg jpeg2k kde kdehiddenvisibility kdeprefix lm_sensors logrotate loop-aes midi mikmod mime mozilla moznopango mp3 mpeg mudflap mysql ncurses nls nptl nptlonly odbc ogg opengl openmp pam pcre pdf perl php png posix povray pppd python qt3support qt4 rdesktop readline reflection samba sdl-mixer sensord session sharedmem slang sndfile spl ssl svg symlink sysfs tcpd tidy tiff timestats tls transcode truetype truetype-fonts twolame type1-fonts unicode usb userlocales vcd vorbis win32codecs wma x264 x86 xml2 xorg xprint xv xvid zero-penalty-hit zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="radeon ati mach64 vesa vga fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Reproducible: Always

Steps to Reproduce:
1. install gentoo with KDE 4.1.* with USE flag -kdeprefix
2. change USE flags to +kdeprefix
3. emerge -ND @world - here you are :-\

Actual Results:  
kde-base/superkaramba-4.1.3 failed
Comment 1 Osipov S. Stanislav 2008-11-12 10:17:31 UTC
have changed CFLAGS:
CFLAGS="-O2 -march=athlon -m3dnow -fomit-frame-pointer -pipe"
CXXFLAGS="${CFLAGS}"
and executed python-updater

The problem still exists.
Comment 2 Osipov S. Stanislav 2008-11-12 21:20:11 UTC
A workaround was found:
I've added the next string:
kde-base/superkaramba -python
to a file /etc/portage/package.use

Compiled successfully.

Developers/maintainers, the problem is still needing your attention with USE flag "python"

Best regards,
O.S.S. from Russia.
Comment 3 Osipov S. Stanislav 2008-11-13 11:21:24 UTC
Excuse me, gentlemens,

I have totally located source of problem. The bug was due to disabling of USE flag "threads" and enabling flag "sharedmem".

I have changed global USE flags to "-sharedmem threads", deleted my previous record about superkaramba in package.use file and executed
emerge -ND @world

All is fine!
Sorry for troubles!
Comment 4 Jan Kundrát (RETIRED) gentoo-dev 2008-11-13 22:12:48 UTC
Stanislav, please `export LANG=C` as most of us don't speak Russian and it's a bit difficult to read cyrilllic.

kde team, you might want to depend on python being built with USE=threads (or do these symbols come from another library?). Reopening for proper solution.
Comment 5 Osipov S. Stanislav 2008-11-13 22:22:59 UTC
Jan, i'm sorry.

I have no time to rollback for reproducing the bug in C locale, because this installation can not wait anymore, i've wasted a lot of time due to superkaramba's bug. Computer with that gentoo isn't mine. Really, very sorry!

But in fact, now you have the keys to reproduce bug on fast systems.

Best regards,
O.S.S. from Russia.
Comment 6 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-11-16 03:54:13 UTC
Unless someone else hits this bug and can provide more info, there's nothing we can do about it.
Comment 7 Osipov S. Stanislav 2008-11-16 13:45:43 UTC
Sorry for my stupid bugreport. Next time I'll set locale=C before making bugreport.