Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 246170 - After upgrade to gnome-base/gnome-panel-2.24.1 the Gnome menu options to log out or shut down don't work anymore
Summary: After upgrade to gnome-base/gnome-panel-2.24.1 the Gnome menu options to log ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-11-09 15:10 UTC by Jürgen Geuter
Modified: 2009-02-27 11:01 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-panel-2.24.1-logout.patch (gnome-panel-2.24.1-logout.patch,31.88 KB, patch)
2008-11-10 11:15 UTC, Gilles Dartiguelongue
Details | Diff
ebuild for debain's patch (gnome-session-2.22.3.ebuild,2.02 KB, text/plain)
2008-11-11 01:10 UTC, Andrew Kirilenko
Details
ebuild w/ logout support (gnome-panel-2.24.1.ebuild,2.11 KB, text/plain)
2008-11-11 01:27 UTC, Andrew Kirilenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Geuter 2008-11-09 15:10:05 UTC
After upgrade to gnome-base/gnome-panel-2.24.1 and  gnome-base/gnome-settings-daemon-2.24.0 today the Menu options to log the current user out and to shut the computer down do not work anymore.
I do hear the "clicking" sound that notifies me that I clicked a menu option but absolutely nothing happens. The keyboard shortcut to log out doesn't work either (I reset it to something else to check that it was not just a problem with one certain shortcut).
I get no error messages at all so there's not a lot I can add to this.

Reproducible: Always

Steps to Reproduce:
1.log into GNOME with gnome-base/gnome-panel-2.24.1 and  gnome-base/gnome-settings-daemon-2.24.0
2.click on logout or shutdown
3.

Actual Results:  
You get the audible notification that you clicked a button in the menu but nothing happens

Expected Results:  
I should have been able to log out or shut the computer down

tante@sanzen ~ $ emerge --info
WARNING: repository at /usr/local/portage/layman/cwiid is missing a repo_name entry
Portage 2.2_rc13 (default/linux/amd64/2008.0/desktop, gcc-4.2.4, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Sun, 09 Nov 2008 11:30:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r15, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://ftp.gentoo.mesh-solutions.com/gentoo/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/"
LANG="en_US"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/cwiid /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X X509 a52 aac aalib acl acpi administrator aim alsa amarok amazon amd64 ao apache2 applet async audiofile autoipd automount avahi bash-completion berkdb bluetooth bogofilter bonjour branding bzip2 cairo caps cdb cddb cdio cdparanoia cdr chroot cli colordiff cracklib crypt cscope css cups curl cvs daap dbus device-mapper disk-partition dri dts dvd dvdr dvdread eds emboss encode esd evo exif expat fam fat ffmpeg firefox flac fontconfig fortran fuse gconf gd gdbm gdm gedit geoip gif gimp glade glib gmail gnome gnome-keyring gnutls gpg gphoto2 gpm grub gstreamer gtk gtkhtml gzip hal hdaps hddtemp ibam icons iconv icq id3 id3tag imagemagick imap imlib imlib2 ipod ipv6 isdnlog jabber javascript john jpeg jpeg2k json kpathsea lame laptop latex libgda libnotify libsamplerate libwww lm_sensors loop-aes lvm mad maildir matroska mdnsresponder-compat midi mikmod mime mjpeg mmap mmx mng mono mozdevelop mp3 mp4 mpeg mpeg2 mplayer msn mudflap multilib music musicbrainz mysql mysqli nautilus ncurses network networkmanager nfs nls nptl nptlonly nsplugin ntfs ntp obex offensive ogg ogg123 openal opengl openid openmp oscar pam pango parted pcmcia pcre pdf pdo perl php pidgin pixmaps plugins png pop posix postgres postscript ppds pppd pulseaudio python pyzord qemu qt3 qt3support qt4 query-browser quicktime rar rdesktop readline reflection reiserfs rss samba sdl session sharedmem silc simplexml smp sndfile sockets spell spl sql sqlite sqlite3 sse sse2 ssl startup-notification stream subversion svg sysfs syslog t1lib taglib tagwriting talkfilters tcpd tetex theora threads tidy tiff totem tracker transcode truetype twolame type1 unicode unzip upnp usb v4l2 vcd vcdx vhosts vim-syntax vnc vorbis wav webdav webdav-neon wifi wmf wxwindows x264 xattr xcb xcf xcomposite xft xine xinerama xml xmlrpc xorg xosd xpm xrandr xscreensaver xulrunner xv xvid yahoo zeroconf zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="intel vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-11-09 18:37:02 UTC
That is expected, new gnome-panel uses new gnome-session 2.24 D-Bus API.
Comment 2 Andrew Kirilenko 2008-11-09 21:40:25 UTC
(In reply to comment #1)
> That is expected, new gnome-panel uses new gnome-session 2.24 D-Bus API.
> 

And where is new gnome-session 2.24? What's the reason to push one updated package and forget about another, which renders first one broken?
Comment 3 Mart Raudsepp gentoo-dev 2008-11-09 22:20:07 UTC
gnome-session-2.24 looses support for session saving completely.
Comment 4 Mart Raudsepp gentoo-dev 2008-11-09 23:58:39 UTC
What I mean is that gnome-session-2.24 not entering the portage tree is fully intentional, however gnome-settings-daemon-2.24 not working with gnome-session-2.22 is an unfortunate mistake not noted before that gets resolved in due course - help appreciated. This is ~arch you are using, you are our testing ground to flush out the last things before stabilizing, and we did take care of quite some things while things were in overlay, with this case unfortunately not noticed or remembered by any of us or the overlay users who hang out in IRC or file bugs to bugzilla against the overlay (which is quite fine if the summary starts with [gnome overlay]).
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-11-10 11:15:35 UTC
Created attachment 171291 [details, diff]
gnome-panel-2.24.1-logout.patch

please try this patch.
Comment 6 Wang, Baojun 2008-11-10 14:14:42 UTC
(In reply to comment #3)
> gnome-session-2.24 looses support for session saving completely.
> 

Do you mean the testing tree will use gnome-session 2.22(.3) for a long time (after session saving completed maybe)? this problem is quite irriating, though.
Comment 7 Mart Raudsepp gentoo-dev 2008-11-10 14:53:46 UTC
(In reply to comment #6)
> (In reply to comment #3)
> > gnome-session-2.24 looses support for session saving completely.
> > 
> 
> Do you mean the testing tree will use gnome-session 2.22(.3) for a long time
> (after session saving completed maybe)? this problem is quite irriating,
> though.

I mean that the testing and stable tree will use a gnome-session with session saving support there as long as we can (when we can't keep fixing it up ourselves for things that break without it, like that big patch in previous comment). If a gnome-session-2.24+ stable version comes out that supports session saving, it will enter ~arch, meanwhile the 2.24 versions that lose that support, will probably be introduced to portage tree at some point, but package.masked with an appropriate warning about the lost functionality (that is important to quite some people).
Comment 8 ro0 2008-11-10 16:19:30 UTC
Using >=sys-auth/consolekit-0.3.0 fixed the problem for me.

# emerge --info

Portage 2.2_rc13 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.27-gentoo x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Sun, 09 Nov 2008 12:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/my0wn /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/gnome /usr/local/portage/layman/x11"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 avi beagle berkdb bluetooth bzip2 cairo cdparanoia cdr cli cracklib crypt cups dbus divx divx4linux dri dv dvd dvdr dvdread encode exif ffmpeg firefox flac fortran fuse gdbm gif gnome gnutls gpm gstreamer gtk hal hald iconv irmc isdnlog jabber java jpeg jpeg2k lame laptop ldap libgda libnotify live lm_sensors mad midi mmx mp2 mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcmcia pcre perl pmu png pppd python quicktime raw readline reflection ruby samba session spl sqlite sse sse2 ssl svg sysfs t1lib tcpd truetype twolame unicode usb v4l v4l2 vcd vim-syntax vorbis widescreen wifi wmf xcb xcomposite xorg xprint xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 9 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-11-10 17:29:43 UTC
(In reply to comment #5)
> Created an attachment (id=171291) [edit]
> gnome-panel-2.24.1-logout.patch
> 
> please try this patch.
> 

Applying it works fine, but it breaks compilation. Bottom line, this is the error:

../gnome-panel/libpanel-util/.libs/libpanel-util.a(panel-session-manager.o): In function `panel_session_manager_request_shutdown':
panel-session-manager.c:(.text+0x21f): undefined reference to `panel_logout_new'
../gnome-panel/libpanel-util/.libs/libpanel-util.a(panel-session-manager.o): In function `panel_session_manager_request_logout':
panel-session-manager.c:(.text+0x388): undefined reference to `panel_logout_new'
collect2: ld returned 1 exit status

If you need a complete build log, emerge --info or anything else, I'd happily provide that, too.
Comment 10 Francesc Zacarias 2008-11-10 17:34:06 UTC
(In reply to comment #5)
> Created an attachment (id=171291) [edit]
> gnome-panel-2.24.1-logout.patch
> 
> please try this patch.
> 
I just tried the patch and it doesn't work. gnome-panel-2.24.1 was built successfuly, but there's no change in its behaviuor.
Comment 11 Felix Apitzsch 2008-11-10 18:02:11 UTC
I have the same error after the same upgrade. Additionally, I get the following warning after login:

--8<-------------------------------------------------------
There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Launch helper exited with unknown return code 0

GNOME will still try to restart the Settings Daemon next time you log in.
--8<-------------------------------------------------------

No gnome themes etc. are loaded. I suspect this is caused by the same issue. Is it? Should I post a separate bug report?
Comment 12 Andrew Kirilenko 2008-11-10 18:04:55 UTC
Hello!

It's at least related. gnome-settings starts properly one time of three. To fix it do:

killall gnome-settings-daemon && /usr/libexec/gnome-settings-daemon
Comment 13 Pacho Ramos gentoo-dev 2008-11-10 18:32:43 UTC
(In reply to comment #12)
> Hello!
> 
> It's at least related. gnome-settings starts properly one time of three. To fix
> it do:
> 
> killall gnome-settings-daemon && /usr/libexec/gnome-settings-daemon
> 

Maybe you are suffering bug 239293
Comment 14 Francesc Zacarias 2008-11-10 19:05:54 UTC
(In reply to comment #11)
> I have the same error after the same upgrade. Additionally, I get the following
> warning after login:
> 
> --8<-------------------------------------------------------
> There was an error starting the GNOME Settings Daemon.
> 
> Some things, such as themes, sounds, or background settings may not work
> correctly.
> 
> The last error message was:
> 
> Launch helper exited with unknown return code 0
> 
> GNOME will still try to restart the Settings Daemon next time you log in.
> --8<-------------------------------------------------------
> 
> No gnome themes etc. are loaded. I suspect this is caused by the same issue. Is
> it? Should I post a separate bug report?
> 

I have both problems too: gnome-settings-daemon fails most of the time when I login and also can't logout or shutdown from the gnome menus.
Both problems started after upgrading the last gnome packages to 2.24: desktop, panel, nautilus, etc.
Comment 15 Felix Apitzsch 2008-11-10 22:17:06 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > Hello!
> > 
> > It's at least related. gnome-settings starts properly one time of three. To fix
> > it do:
> > 
> > killall gnome-settings-daemon && /usr/libexec/gnome-settings-daemon
> > 
> 
> Maybe you are suffering bug 239293
> 

I agree, Bug #239293 and Bug #246170 are very similar and could be duplicate.

On my machine gnome-settings-daemon fails every time on logon (with or without power plugged in). However, "killall gnome-settings-daemon && /usr/libexec/gnome-settings-daemon" works as expected every time without any error message or warning.
Comment 16 Marcin Deranek 2008-11-11 00:12:29 UTC
Seems like someone already came across the very same problem:

http://patch-tracking.debian.net/patch/series/view/gnome-session/2.22.3-2/02_gsd-spawn.patch

Quickly tried it and looks like it does the job.
Comment 17 Andrew Kirilenko 2008-11-11 01:10:59 UTC
Created attachment 171388 [details]
ebuild for debain's patch

Here is updated ebuild for provided patch. Looks like this one fixes gnome-settings-daemon problem completly.
Comment 18 Andrew Kirilenko 2008-11-11 01:27:52 UTC
Created attachment 171390 [details]
ebuild w/ logout support

This one works as well. If somebody applied this patch and wasn't able to get logout working - you most likely forgot about autoreconf.
Comment 19 Derk W te Bokkel 2008-11-11 02:55:13 UTC
One minor note: the exact download for the patch is: 

http://patch-tracking.debian.net/patch/series/dl/gnome-session/2.22.3-2/02_gsd-spawn.patch

I had trouble until I looked at the source and realized I had html/xml in what I assumed was the real patch but was just the html description page that the link in comment #16 points too.

It also needs to be renamed to gnome-session-2.22.3-gsd-spawn.patch

But the up shot is that it works!
Comment 20 Gilles Dartiguelongue gentoo-dev 2008-11-11 10:20:26 UTC
guys please stop using this bug for gnome-settings-daemon stuff, that is to be handled in bug #239293.

Please also avoid the "me too" style of comments (unless asked) if someone already said something that you are experiencing, just adding yourself to CC is enough, thanks in advance.

For those for which the build failed, please try the gnome-panel ebuild provided by Andrew.

@roO, you are using the overlay it seems, so it's normal if things work for you. Please do not interfere with feedback from users only using the tree, thanks for understanding.
Comment 21 Mart Raudsepp gentoo-dev 2008-11-11 17:27:46 UTC
Retitling summary as this has nothing whatsoever to do with gnome-settings-daemon.
Comment 22 Ian Abbott 2008-11-13 18:48:12 UTC
Gilles' gnome-panel-2.24.1-logout.patch and Andrew's gnome-panel-2.24.1.ebuild work for me.  Thanks guys!
Comment 23 Gilles Dartiguelongue gentoo-dev 2008-11-16 21:01:47 UTC
in 2.24.1-r1, please reopen if it doesn't fix the problem for you. Thanks for reporting.
Comment 24 Hans de Graaff gentoo-dev 2008-11-17 19:58:02 UTC
The patch breaks FEATURES="test" since it adds a new file with translateable text:

>>> Test phase [check]: gnome-base/gnome-panel-2.24.1-r1
Making check in po
make[1]: Entering directory `/var/tmp/portage/gnome-base/gnome-panel-2.24.1-r1/work/gnome-panel-2.24.1/po'
INTLTOOL_EXTRACT=/usr/bin/intltool-extract srcdir=. /usr/bin/intltool-update --gettext-package gnome-panel-2.0 --pot
rm -f missing notexist
srcdir=. /usr/bin/intltool-update -m
The following files contain translations and are currently not in use. Please
consider adding these to the POTFILES.in file, located in the po/ directory.

gnome-panel/panel-logout.c

If some of these files are left out on purpose then please add them to
POTFILES.skip instead of POTFILES.in. A file 'missing' containing this list
of left out files has been written in the current directory.
if [ -r missing -o -r notexist ]; then \
	  exit 1; \
	fi
make[1]: *** [check] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gnome-panel-2.24.1-r1/work/gnome-panel-2.24.1/po'
make: *** [check-recursive] Error 1


Unrelated from this: I'm using an 'en' locale, but I'm not sure how this may affect users with other locales, I'm guessing these strings will not be translated for them?
Comment 25 Gilles Dartiguelongue gentoo-dev 2008-11-17 22:42:38 UTC
(In reply to comment #24)
> The patch breaks FEATURES="test" since it adds a new file with translateable
> text:
> 
> Unrelated from this: I'm using an 'en' locale, but I'm not sure how this may
> affect users with other locales, I'm guessing these strings will not be
> translated for them?
> 

oops, that's right I forgot to fix that and yes it won't be translated if the strings where punted from the po file otherwise, it might still work because of gettext magic :p