Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245896 - media-libs/xine-lib-1.1.15-r1 fails to build with media-libs/libcaca-0.99_beta16
Summary: media-libs/xine-lib-1.1.15-r1 fails to build with media-libs/libcaca-0.99_beta16
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2008-11-06 22:40 UTC by Andrei Slavoiu
Modified: 2009-08-04 16:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Slavoiu 2008-11-06 22:40:08 UTC
When emerging xine-lib with the libcaca use flag on I get the following error:

(cd .libs && rm -f && ln -s ../
(cd .libs && rm -f && ln -s ../
(cd .libs && rm -f && ln -s ../
/bin/sed: can't read /usr/lib64/ No such file or directory
libtool: link: `/usr/lib64/' is not a valid libtool archive
make[3]: *** [] Error 1
make[3]: *** Waiting for unfinished jobs....
x86_64-pc-linux-gnu-gcc -shared  .libs/xineplug_vo_out_none_la-video_out_none.o  -Wl,--rpath -Wl,/var/tmp/portage/media-libs/xine-lib-1.1.15-r1/work/xine-lib-1.1.15/src/xine-engine/.libs ../../src/xine-engine/.libs/  -march=native -Wl,-z -Wl,defs -Wl,-O1 -Wl,--enable-new-dtags -Wl,--sort-common -Wl,-z -Wl,combreloc -Wl,--as-needed -pthread -Wl,-soname -Wl, -o .libs/
(cd .libs && rm -f && ln -s ../
(cd .libs && rm -f && ln -s ../
make[3]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.15-r1/work/xine-lib-1.1.15/src/video_out'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.15-r1/work/xine-lib-1.1.15/src/video_out'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.15-r1/work/xine-lib-1.1.15/src'
make: *** [all-recursive] Error 1

Reproducible: Always

Steps to Reproduce:
Comment 1 Andrei Slavoiu 2008-11-06 22:40:51 UTC
Portage 2.2_rc13 (default-linux/amd64/2007.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2 x86_64)
System uname: Linux-2.6.27-gentoo-r2-x86_64-AMD_Phenom-tm-_9350e_Quad-Core_Processor-with-glibc2.2.5             
Timestamp of tree: Thu, 06 Nov 2008 19:36:01 +0000                                                               
ccache version 2.4 [enabled]                                                                                     
app-shells/bash:     3.2_p39                                                                                     
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-march=native -ggdb -O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -ggdb -O2 -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="buildpkg ccache collision-protect distlocks fixpackages parallel-fetch preserve-libs preserved-rebuild protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
LINGUAS="ro en eo"
MAKEOPTS="-j6 -l8"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
USE="3dnow 3dnowext 3ds 7zip X a52 aac aalib accessibility acl acpi aiglx akode alsa amd64 amr amrnb amrwb apache2 asf aspell audiofile bash-completion berkdb branding bzip2 caps captury cddb cdinstall cdparanoia cdr cisco clamav cracklib crypt css cups curl dba dbus dga djvu dmi doc dpms dri dts dv dvd dvdr dvdread eds emboss encode erandom evo examples exif expat fam fbcon ffmpeg firefox flac fontconfig fortran ftp gcj gd gdbm geoip gif glib glut gmp gnokii gnutls gpm graphviz gsm hal hddtemp hou htmlhandbook iconv id3tag idn imagemagick imlib inotify ipv6 isdnlog jadetex java javascript jingle jpeg jpeg2k justify kde kdeenablefinal kdehiddenvisibility kerberos kig-scripting kipi kqemu lame lcms ldap libcacalibclamav libgcrypt libsamplerate libssh2 libwww live lm_sensors lua lzo mad maildir matroska mbrola metric midi mikmod mjpeg mmap mmx mmxext mng mp3 mp4 mplayer mppe-mppc mudflapmusepack musicbrainz mythtv ncurses network nls nodrm nowin nptl nptlonly offensive ofx ogg openal openexr opengl openmp pam pch pcre pdf perl php physfs plugins png posix povray ppds pppd pth python qt qt3 qt3support qt4 quicktime rdesktop readline reflection reiserfs rtc ruby samba sasl schroedinger sdl session slang sms sockets sou sound sox speex spell spl sqlite sqlite3 sse sse2 ssl subversion svg symlink syslog sysvipc tcpd theora threads tidy tiff truetype tunepimp unicode usb vhook videos visualization vnc voice vorbis wifi wmf x264 xattr xcb xcomposite xine xml xml2 xmlrpc xmp xorg xpm xsl xv xvid xvmc yahoo zeroconf zip zlib zvbi" ALSA_CARDS="bt87x via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmixdshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflatedir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ro en eo" LIRC_DEVICES="kworld" USERLAND="GNU" VIDEO_CARDS="radeon radeonhd vesa"
Comment 2 Andrei Slavoiu 2008-11-06 22:55:31 UTC
Note: doing a `ln -s /usr/lib64/ /usr/lib64/` solves the problem. So the libcaca ebuild should probably create this symlink during installation. And probably do the same for
Comment 3 Dan Coats 2008-11-07 13:47:04 UTC
yep, symlink works here..
Comment 4 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-07 17:00:15 UTC
Please run revdep-rebuild and reopen this bug report if the problem persists.
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2008-11-07 17:00:54 UTC
(In reply to comment #3)
> yep, symlink works here..

It's also a good way to hose your system over time. :)
Comment 6 Andrei Slavoiu 2008-11-08 00:25:23 UTC
(In reply to comment #4)
> Please run revdep-rebuild and reopen this bug report if the problem persists.

You were right, a revdep-rebuild did help.
Comment 7 Cyp 2009-08-04 16:52:50 UTC
revdep-rebuild didn't work for me, but 'emerge -v1 libsdl' did work.
(Don't ask me what libsdl has to do with xine-lib...)

Actually, when trying revdep-rebuild, most things it tried to rebuild failed with the same error as xine-lib.

So if you are a random person having trouble getting to get xine-lib to build, and stumble upon this bug, try:

emerge -v1 libsdl