Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245775 - x11-misc/lavaps-2.7-r2 - Can't open lavaps.pod for reading: No such file or directory
Summary: x11-misc/lavaps-2.7-r2 - Can't open lavaps.pod for reading: No such file or d...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-06 02:04 UTC by Dan Wallis
Modified: 2010-02-16 01:03 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Wallis 2008-11-06 02:04:12 UTC
Hello

I get this error when trying to install x11-misc/lavaps-2.7-r2:

make  all-recursive
make[1]: Entering directory `/var/tmp/portage/x11-misc/lavaps-2.7-r2/work/lavaps-2.7'
Making all in doc
make[2]: Entering directory `/var/tmp/portage/x11-misc/lavaps-2.7-r2/work/lavaps-2.7/doc'
/usr/local/bin/perl podprune LAVAPS "WHAT'S NEW" REQUIREMENTS "INSTALLATION DETAILS" AVAILABILITY "RELEASE HISTORY" ISPELL <master.pod >lavaps.pod
/usr/local/bin/perl podprune LAVAPS "WHAT'S NEW" REQUIREMENTS "INSTALLATION DETAILS" AVAILABILITY "RELEASE HISTORY" ISPELL  <master.pod >lavaps.pod
make[3]: Entering directory `/var/tmp/portage/x11-misc/lavaps-2.7-r2/work/lavaps-2.7/doc'
/usr/local/bin/perl podprune LAVAPS "WHAT'S NEW" REQUIREMENTS "INSTALLATION DETAILS" AVAILABILITY "RELEASE HISTORY" ISPELL <master.pod >lavaps.pod
/usr/bin/pod2man --section=1 --release="lavaps-2.7" --center="Lavaps Documentation" lavaps.pod >lavaps.1
/usr/bin/pod2man --section=1 --release="lavaps-2.7" --center="Lavaps Documentation" lavaps.pod >lavaps.1
/usr/bin/pod2html --title "lavaps-2.7 manual page" lavaps.pod >lavaps_man.html
/usr/bin/pod2html: lavaps.pod: cannot resolve L<X(1)> in paragraph 45.
/usr/bin/pod2html: lavaps.pod: cannot resolve L<ps(1)> in paragraph 97.
rm -f lavaps.pod
Can't open lavaps.pod for reading: No such file or directory
 at /usr/bin/pod2man line 60
Can't open lavaps.pod for reading: No such file or directory
 at /usr/bin/pod2man line 60
make[2]: *** [lavaps.1] Error 9
make[2]: *** Waiting for unfinished jobs....
make[3]: *** [lavaps.1] Error 9
make[3]: Leaving directory `/var/tmp/portage/x11-misc/lavaps-2.7-r2/work/lavaps-2.7/doc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-misc/lavaps-2.7-r2/work/lavaps-2.7/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-misc/lavaps-2.7-r2/work/lavaps-2.7'
make: *** [all] Error 2


Reproducible: Always

Steps to Reproduce:
1. ACCEPT_KEYWORDS="~amd64" emerge =x11-misc/lavaps-2.7-r2
Actual Results:  
Build fails:
/usr/bin/pod2html: lavaps.pod: cannot resolve L<X(1)> in paragraph 45.
/usr/bin/pod2html: lavaps.pod: cannot resolve L<ps(1)> in paragraph 97.

Expected Results:  
Build completes successfully.
Comment 1 Jeroen Roovers gentoo-dev 2008-11-07 03:54:04 UTC
Please post your `emerge --info' too.
Comment 2 Dan Wallis 2008-11-07 04:34:55 UTC
Sorry.

dan@tui ~ $ emerge --info 
Portage 2.1.4.5 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 x86_64)
=================================================================
System uname: 2.6.25-gentoo-r7 x86_64 Intel(R) Core(TM)2 Duo CPU T7500 @ 2.20GHz
Timestamp of tree: Fri, 07 Nov 2008 02:45:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks metadata-transfer parallel-fetch sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://gentoo.blueyonder.co.uk "
LANG="C"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="7zip X a52 aac aalib acl acpi alsa amd64 amr ao apache2 apm applet ares artworkextra avahi bash-completion berkdb bluetooth bonjour bugzilla bzip2 cairo caps cdda cddb cdio cdparanoia cdr cgi cli cracklib crypt cups curl cvs cxx daap dbus dell dia divx doc domainkeys dri dvd dvdr dvdread eds encode epiphany esd evo exif exiscan-acl ffmpeg filepicker firefox flac fortran ftp fuse galago gd gdbm gedit geoip gif gimp git glade glitz gmail gnome gnome-keyring gnome-print gnuplot gnutls gpg gphoto2 gpm grammar graphviz gstreamer gtk gtkhtml gtkspell guile hal iconv imagemagick imap imlib inherit-graph inkjar ipv6 irmc isdnlog jabber java javascript jpeg jpeg2k lame laptop ldap libcaca libgda libnotify libsamplerate libwww live logrotate lua lzma lzo mad math mbox midi mmx mng modplug mono motif mozbranding mozdevelop mozilla mp2 mp3 mpeg mplayer mudflap musepack mysql nano-syntax nautilus ncurses networkmanager nfs njb nls nntp nptl nptlonly nsplugin nvidia ogg opengl openmp ots pam pcre pda pdf perl php pidgin plotutils pmu png pop portaudio posix postgres postscript pppd prediction python pyx quicktime rar raw rdesktop readline realmedia reflection rss rtc rubytests samba session sftp shout skey slang smartcard smtp sndfile snmp sound sourceview speex spell spf spl sqlite sse sse2 ssl ssse3 startup-notification stream subversion svg syslog tcl tcpd theora thesaurus threads thunderbird tiff timidity tk truetype twolame unicode usb v4l v4l2 valgrind vcd vim-syntax vorbis wavpack wifi wmf wmp wordperfect xface xine xinerama xml xorg xulrunner xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB" USERLAND="GNU" VIDEO_CARDS="nvidia vesa v4l vga vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

dan@tui ~ $ 
Comment 3 Dan Wallis 2010-02-16 01:03:43 UTC
Looks like darkside removed x11-misc/lavaps back in 2009.