Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245763 - app-admin/eselect - 'eselect profile' - /bin/sed: can't read //profiles/profiles.desc: No such file or directory
Summary: app-admin/eselect - 'eselect profile' - /bin/sed: can't read //profiles/profi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo eselect Team
URL:
Whiteboard:
Keywords:
: 247627 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-11-05 22:13 UTC by Pavel Volkov
Modified: 2010-04-16 11:43 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Volkov 2008-11-05 22:13:26 UTC
Cannot manage profiles via "eselect profile".
Portage is synced recently.
make.profile symlink is valid:
lrwxrwxrwx 1 root root 48 Ноя  4 21:32 /etc/make.profile -> /usr/portage/profiles/default/linux/amd64/2008.0

Reproducible: Always

Steps to Reproduce:
eselect profile list
Actual Results:  
/bin/sed: can't read //profiles/profiles.desc: No such file or directory
!!! Error: Failed to get a list of valid profiles
zsh: killed     eselect profile list


Expected Results:  
See profile list.

Portage 2.2_rc13 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r2melf x86_64)
=================================================================                                            
System uname: Linux-2.6.27-gentoo-r2melf-x86_64-AMD_Athlon-tm-_64_Processor_3000+-with-glibc2.2.5            
Timestamp of tree: Tue, 04 Nov 2008 15:30:01 +0000                                                           
app-shells/bash:     3.2_p39                                                                                 
dev-java/java-config: 1.3.7, 2.1.6-r1                                                                        
dev-lang/python:     2.5.2-r8                                                                                
dev-python/pycrypto: 2.0.1-r6                                                                                
dev-util/cmake:      2.6.2                                                                                   
sys-apps/baselayout: 2.0.0                                                                                   
sys-apps/openrc:     0.3.0-r1                                                                                
sys-apps/sandbox:    1.2.18.1-r3                                                                             
sys-devel/autoconf:  2.13, 2.63                                                                              
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1                                    
sys-devel/binutils:  2.19                                                                                    
sys-devel/gcc-config: 1.4.0-r4                                                                               
sys-devel/libtool:   2.2.6a                                                                                  
virtual/os-headers:  2.6.27-r2                                                                               
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                               
CBUILD="x86_64-pc-linux-gnu"                                                                                 
CFLAGS="-O2 -pipe -march=native -mtune=native"                                                               
CHOST="x86_64-pc-linux-gnu"                                                                                  
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config"                                                                                     
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"                                                              
CXXFLAGS="-O2 -pipe -march=native -mtune=native"                                                                               
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/"
LANG="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_GB ru ja"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/java-overlay /usr/local/myover/combined"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa amd64 bash-completion berkdb bitmap-fonts bluetooth bzip2 cdr chasen cjk cli cracklib crypt csscups directfb djvu dri dts dvd dvdr encode exif fbcon ffmpeg flac fortran ftp gdbm geoip gif glitz gpm gtk hal iconv idn imap immqt-bc isdnlog jabber java jpeg kde kdeprefix lame libcaca matroska midi mmx mp3 mpeg mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png pppd python qt4 raw readline reflection session spell spl sse sse2ssl svg sysfs tcpd truetype truetype-fonts type1-fonts unicode usb vorbis wavpack x264 xcomposite xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB ru ja" USERLAND="GNU" VIDEO_CARDS="vesa vga nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jeroen Roovers gentoo-dev 2008-11-07 03:51:25 UTC
Which version of app-admin/eselect is installed on your system?
Comment 2 Pavel Volkov 2008-11-07 06:53:48 UTC
It's eselect 1.0.11-r1
Comment 3 Wormo (RETIRED) gentoo-dev 2008-11-09 06:20:12 UTC
It sounds like somehow PORTDIR got unset on your system... what is your output for "portageq portdir" ?
Comment 4 Wormo (RETIRED) gentoo-dev 2008-11-09 06:30:56 UTC
Sorry, I just remembered to check your --info output for PORTDIR, and it looks fine. It is puzzling then that on your system the module /usr/share/eselect/modules/profile.eselect thinks ${portdir} is empty ... I get the correct value of ${portdir}=/usr/portage using the same version of eselect??
Comment 5 Jeroen Roovers gentoo-dev 2008-11-10 04:29:34 UTC
(In reply to comment #4)
> Sorry, I just remembered to check your --info output for PORTDIR, and it looks
> fine. It is puzzling then that on your system the module
> /usr/share/eselect/modules/profile.eselect thinks ${portdir} is empty ... I get
> the correct value of ${portdir}=/usr/portage using the same version of
> eselect??

It's puzzling unless perhaps PORTDIR was set to / in the shell that eselect was run in, while it wasn't set in the environment when `emerge --info' was run...
Comment 6 Pavel Volkov 2008-11-10 06:58:56 UTC
I get the same output with bash as login shell and with setting PORTDIR manually:

$ PORTDIR="/usr/portage" eselect profile list
/bin/sed: can't read //profiles/profiles.desc: No such file or directory
!!! Error: Failed to get a list of valid profiles
zsh: killed     PORTDIR="/usr/portage" eselect profile list


Comment 7 Jeroen Roovers gentoo-dev 2008-11-20 22:08:56 UTC
*** Bug 247627 has been marked as a duplicate of this bug. ***
Comment 8 Pavel Volkov 2008-12-22 23:21:11 UTC
I no longer have this error message. Don't know the reason, though.
Comment 9 Drew Tomlinson 2008-12-25 16:37:22 UTC
(In reply to comment #8)
> I no longer have this error message. Don't know the reason, though.
> 

I had the same issue but found that re-emerging eselect resolved this issue.
Comment 10 Jacob Braun 2008-12-27 22:21:57 UTC
Re-emerging eselect also fixed this problem for me.
Comment 11 orionbelt2 2010-04-16 11:43:42 UTC
Re-emerging eselect did not fix this problem for me.

What fixed it was un-defining the ROOT environment variable, which i was defining in my .cshrc because of some script that needs it. Alas, portage also uses ROOT (when defined) to specify the target root filesystem (e.g., read "man emerge" under "ENVIRONMENT OPTIONS") !

If running "printenv ROOT" does not return empty (or with a result that makes sense), then simply "unsetenv ROOT" (and stop defining it in your environment), and the problem should go away.

Note that this affects all portage-related commands, not just eselect. For example, equery could not find packages that were actually installed.