Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245299 - Please stabilise media-video/mpeg4ip-1.5.0.1-r5
Summary: Please stabilise media-video/mpeg4ip-1.5.0.1-r5
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Olivier Crete (RETIRED)
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-11-02 18:29 UTC by Christian Faulhammer (RETIRED)
Modified: 2008-12-12 05:07 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Faulhammer (RETIRED) gentoo-dev 2008-11-02 18:29:53 UTC
This is for GCC 4.3 stabilisation.  Please add arches as you see fit. Thanks.
Comment 1 Olivier Crete (RETIRED) gentoo-dev 2008-11-02 18:41:25 UTC
go arches, stabilize it, its only small fixes
Comment 2 Markus Meier gentoo-dev 2008-11-05 21:24:34 UTC
needs newer ffmpeg (>=media-video/ffmpeg-0.4.9_p20080326)
Comment 3 Christian Faulhammer (RETIRED) gentoo-dev 2008-11-06 18:03:05 UTC
(In reply to comment #2)
> needs newer ffmpeg (>=media-video/ffmpeg-0.4.9_p20080326)

 Can we stable such a version?  Olivier, or is backporting the GCC 4.3 fix alone possible?
Comment 4 Olivier Crete (RETIRED) gentoo-dev 2008-11-06 19:48:35 UTC
Actually, maybe we should p.mask it... upstream has stopped developping it
Comment 5 Steve Dibb (RETIRED) gentoo-dev 2008-11-06 19:51:01 UTC
(In reply to comment #4)
> Actually, maybe we should p.mask it... upstream has stopped developping it
> 

I dont really see any reason to mask it, it works fine.  I'd be okay with moving it to unstable.
Comment 6 Olivier Crete (RETIRED) gentoo-dev 2008-11-06 19:56:12 UTC
Or disable the ffmpeg dep (we keep on having to update it every few months..
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-11-08 01:50:14 UTC
So, what do you want us to do then?
Comment 8 Thomas Anderson (tanderson) (RETIRED) gentoo-dev 2008-11-22 14:23:21 UTC
Fails with patching:

>>> Emerging (1 of 1) media-video/mpeg4ip-1.5.0.1-r5 to /
^[ * mpeg4ip-1.5.0.1.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                                        [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                           [ ok ]
 * checking mpeg4ip-1.5.0.1.tar.gz ;-) .                                                                                                                                       [ ok ]
>>> Unpacking source...
>>> Unpacking mpeg4ip-1.5.0.1.tar.gz to /var/tmp/portage/media-video/mpeg4ip-1.5.0.1-r5/work
 * Applying mpeg4ip-1.4.1-disable-faac-test.patch ...                                                                                                                            [ ok ]
 * Applying mpeg4ip-1.5.0.1-x264.patch ...

 * Failed Patch: mpeg4ip-1.5.0.1-x264.patch !
 *  ( /usr/portage/media-video/mpeg4ip/files/mpeg4ip-1.5.0.1-x264.patch )
 * 
 * Include in your bugreport the contents of:
 * 
 *   /var/tmp/portage/media-video/mpeg4ip-1.5.0.1-r5/temp/mpeg4ip-1.5.0.1-x264.patch-8488.out

 * 
 * ERROR: media-video/mpeg4ip-1.5.0.1-r5 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 2668:  Called epatch 'src_unpack'
 *             environment, line 1613:  Called die
 * The specific snippet of code:
 *                   die "Failed Patch: ${patchname}!";
 *  The die message:
 *   Failed Patch: mpeg4ip-1.5.0.1-x264.patch!


The contents of the patching output are much of this:

PATCH COMMAND:   patch -p0 -g0 -E --no-backup-if-mismatch < /usr/portage/media-video/mpeg4ip/files/mpeg4ip-1.5.0.1-x264.patch

======================================
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- mpeg4ip-1.5.0.1/server/mp4live/video_x264.cpp      2006-05-11 22:23:19.000000000 +0200
|+++ mpeg4ip/server/mp4live/video_x264.cpp      2006-09-29 21:55:42.000000000 +0200
--------------------------
No file to patch.  Skipping patch.
5 out of 5 hunks ignored
can't find file to patch at input line 57
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- a/mpeg4ip-1.5.0.1/server/mp4live/video_x264.h.old  2006-11-11 20:56:48.000000000 +0100
|+++ b/mpeg4ip-1.5.0.1/server/mp4live/video_x264.h      2006-11-11 20:57:49.000000000 +0100
--------------------------
No file to patch.  Skipping patch.
1 out of 1 hunk ignored
=====================================
Comment 9 Nikita Melnichenko 2008-11-30 19:42:12 UTC
(In reply to comment #8)
> Fails with patching:

Yeah, that's true. But it fails even with "stable" media-video/mpeg4ip-1.5.0.1-r1.
Comment 10 Samuli Suominen gentoo-dev 2008-12-12 05:07:01 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Actually, maybe we should p.mask it... upstream has stopped developping it
> > 
> 
> I dont really see any reason to mask it, it works fine.  I'd be okay with
> moving it to unstable.
> 

Moved to unstable with -r6.