Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 245285 - [TRACKER] stabilization of media-video/ffmpeg-0.4.9_p20081014
Summary: [TRACKER] stabilization of media-video/ffmpeg-0.4.9_p20081014
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: STABLEREQ, Tracker
: 230151 (view as bug list)
Depends on: 239341 242964 245291 245326 245511 245513 245515 245522 245524 245527 245532 245533 245535 245947 247653
Blocks: gcc-4.3-stable CVE-2008-4866 250723 250804 250894
  Show dependency tree
 
Reported: 2008-11-02 15:18 UTC by Peter Alfredsen (RETIRED)
Modified: 2008-12-22 14:37 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-11-02 15:18:06 UTC
Please mark as blocker the *stabilization bugs* for packages that are needed for this version.
Comment 1 Serkan Kaba (RETIRED) gentoo-dev 2008-11-02 17:21:21 UTC
Need to stabilize media-video/jubler-3.9.6 when it lives in the tree enough time with no bugs.
Comment 2 Alexis Ballier gentoo-dev 2008-11-02 21:48:30 UTC
Indeed we should hurry up on this for bug #245313

So, we need:
- vlc 0.9.5, bug #242740 should take care of it soon hopefuly.
- k3b-1.0.5-r3
- >=blender-2.48-r1
- alsa-plugins-1.0.17-r1
- vdr-softdevice-0.5.0.20080922
- sox-14.1.0
- kino-1.3.1
- motion-3.2.11
- transcode-1.0.7_rc1
- xvidcap-1.1.7
- jubler-3.9.6
- x264{,-encoder}-0.0.20081006
- avidemux-2.4.3 (because of x264)

Packages that have been broken in ~arch for more than a year (not ported to swscaler, that i don't consider should be holding us):
- mpeg4ip, bug #242094
- ffmpeg-php, bug #242050
- DirectFB-extra, bug #242036

I hope this list is exhaustive, so now one just has to file stable requests when possible or add this in a mass stabling one.
Comment 3 Samuli Suominen gentoo-dev 2008-12-10 23:29:30 UTC
*** Bug 230151 has been marked as a duplicate of this bug. ***
Comment 4 Samuli Suominen gentoo-dev 2008-12-11 11:03:26 UTC
Please do.
Comment 5 Samuli Suominen gentoo-dev 2008-12-11 11:18:20 UTC
If you find packages that won't compile against this version of ffmpeg, please open a bug and CC treecleaners. However, don't let it be a showstopper.

Broken packages will be punted.
Comment 6 Samuli Suominen gentoo-dev 2008-12-12 05:12:30 UTC
(In reply to comment #2)
> Indeed we should hurry up on this for bug #245313
> Packages that have been broken in ~arch for more than a year (not ported to
> swscaler, that i don't consider should be holding us):
> - mpeg4ip, bug #242094
> - ffmpeg-php, bug #242050
> - DirectFB-extra, bug #242036

mpeg4ip should be fixed now with -r6 and moving it back to unstable.
ffmpeg-php got fixed by gentoo users (not developers) with version 0.6.0.
and directfb-extra didn't even compile against directfb, so vapier masked it, and I removed it.
Comment 7 Samuli Suominen gentoo-dev 2008-12-12 17:52:11 UTC
A lot of arch devs have asked me how to do this bug, first ffmpeg and then all the rest of the bugs this tracker depends on *at the same time*, preferably before the mirrors sync because most of them are not backwards compatible.

So test them all, and mass commit it to stable.
Comment 8 Tobias Klausmann gentoo-dev 2008-12-12 22:25:36 UTC
All (rev)deps stable on alpha, ffmpeg too. Lots of QA warnings, though.
Comment 9 Samuli Suominen gentoo-dev 2008-12-13 04:56:45 UTC
(In reply to comment #8)
> All (rev)deps stable on alpha, ffmpeg too. Lots of QA warnings, though.
> 

Mostly from other broken arches that haven't keyworded it properly, or unquoted variables in old ebuilds, or this new warning from usage of emake -j1.. which
is valid, and Portage is giving false warnings -- I think we have a open bug about it.
Comment 10 Samuli Suominen gentoo-dev 2008-12-15 08:01:07 UTC
x86 stable
Comment 11 Jeroen Roovers gentoo-dev 2008-12-16 16:36:11 UTC
I think HPPA is all done.
Comment 12 Brent Baude (RETIRED) gentoo-dev 2008-12-16 16:50:05 UTC
also think ppc64 is done too
Comment 13 Samuli Suominen gentoo-dev 2008-12-19 10:42:31 UTC
Old ffmpeg is getting package.masked by end of this week, so you have few days left to catch up. Incompatible with tree (no swscale) and open CVEs, or you can
always request security team to drop your arch from security supported list..
Comment 14 Thomas Anderson (tanderson) (RETIRED) gentoo-dev 2008-12-20 01:05:52 UTC
I think we're(amd64) done here too.
Comment 15 Ferris McCormick (RETIRED) gentoo-dev 2008-12-20 23:36:56 UTC
I think sparc is done.  I'm adding myself to the CC in case I missed anything.
Comment 16 nixnut (RETIRED) gentoo-dev 2008-12-21 17:16:56 UTC
ppc done I think.
Comment 17 Raúl Porcel (RETIRED) gentoo-dev 2008-12-22 14:26:05 UTC
arm/ia64 stable
Comment 18 Samuli Suominen gentoo-dev 2008-12-22 14:37:00 UTC
And we are done here.