Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 244128 - gnome-base/libghttp: CC variable not respected
Summary: gnome-base/libghttp: CC variable not respected
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: PMASKED
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2008-10-24 19:43 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-06-17 23:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-24 19:43:26 UTC
I'm filing this bug (from a template, mind you) because the ebuild I'm reporting it against failed to build once I removed my /usr/bin/{gcc,cc,c++,c99} binaries. This means that the ebuild is relying on gcc or cc as compiler, while it should use "$(tc-getCC)" so that user choices are respected, and cross-compiling works as intended.

This usually comes down to one of these tasks:

- use emake CC="$(tc-getCC)" for building, to ovewrite make's CC variable (defaults to "cc", some upstream rewrites it);
- the above plus replacing explicit "gcc" (or similar) calls with $(CC) so that the variable is actually respected;
- tc-export CC in src_compile before eventual econf.

For C++, you'd have to replace CC with CXX everywhere above, of course.

If your package is a special case on this, please let me know.

Thanks,
Diego
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-10-30 21:47:20 UTC
zomg, this packages dates back from 2001, it's probably some dead piece of gnome 1 or early gnome 2.

The only dep in tree that uses this is orpheus. I think this should seriously die or migrate to libsoup or something more modern.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-11-21 23:45:40 UTC
@sound, hi guys, any input of orpheus migration to something better than libghttp ?
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-04-26 19:45:16 UTC
ok this package has gone the way of the dodo as of the gnome migration to git which is more than indicative that this package should die asap.

@sound, I'm going to remove support for libghttp in orpheus in a week or so unless you speek now so I can pmask this package.
Comment 4 Samuli Suominen gentoo-dev 2009-05-10 14:22:54 UTC
(In reply to comment #3)
> ok this package has gone the way of the dodo as of the gnome migration to git
> which is more than indicative that this package should die asap.
> 
> @sound, I'm going to remove support for libghttp in orpheus in a week or so
> unless you speek now so I can pmask this package.
> 

+  10 May 2009; Samuli Suominen <ssuominen@gentoo.org>
+  -files/1.5-gcc34.patch, -orpheus-1.5.ebuild,
+  -files/orpheus-1.5-nolibghttp.patch, -orpheus-1.6.ebuild,
+  orpheus-1.6-r1.ebuild:
+  Remove deprecated libghttp support wrt #244128

Remove at your leisure.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-05-14 22:19:35 UTC
Annoucement mail sent. removal in 30 days.
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-06-17 23:17:24 UTC
and killed. Closing.