Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243846 - app-emulation/vmware-modules-1.0.0.15-r1 fail to emerge
Summary: app-emulation/vmware-modules-1.0.0.15-r1 fail to emerge
Status: RESOLVED DUPLICATE of bug 227303
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-24 16:16 UTC by Paulo J. Matos
Modified: 2008-10-25 12:14 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo J. Matos 2008-10-24 16:16:16 UTC
app-emulation/vmware-modules-1.0.0.15-r1 , dependency of app-emulation/vmware-server-1.0.7.108231 fail to emerge: 
>>> Source unpacked.                                                                
>>> Compiling source in /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work ...                                                                              
 * Preparing vmmon module                                                           
Using 2.6.x kernel build system.                                                    
make -C /usr/src/linux/include/.. M=$PWD SRCROOT=$PWD/. modules                     
make[1]: Entering directory `/usr/src/linux-2.6.26'                                 
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.   
  CC [M]  /var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.o                                                                      
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.c:171: error: unknown field 'nopage' specified in initializer                    
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.c:172: warning: initialization from incompatible pointer type                    
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.c:175: error: unknown field 'nopage' specified in initializer                    
/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.c:176: warning: initialization from incompatible pointer type                    
make[3]: *** [/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.o] Error 1                                                         
make[2]: *** [_module_/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/work/vmmon-only] Error 2                                                                
make[1]: *** [sub-make] Error 2                                                     
make[1]: Leaving directory `/usr/src/linux-2.6.26'                                  
make: *** [vmmon.ko] Error 2                                                        
 *                                                                                  
 * ERROR: app-emulation/vmware-modules-1.0.0.15-r1 failed.                          
 * Call stack:                                                                      
 * ebuild.sh, line   49:  Called src_compile                                        
 * environment, line 3216:  Called linux-mod_src_compile                            
 * environment, line 2441:  Called die                                              
 * The specific snippet of code:                                                    
 * eval "emake HOSTCC="$(tc-getBUILD_CC)"                                          CC="$(get-KERNEL_CC)"                                            LDFLAGS="$(get_abi_LDFLAGS)"                                                ${BUILD_FIXES}             ${BUILD_PARAMS}                                          ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";                          
 * The die message:                                                                 
 * Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS=   auto-build VMWARE_VER=VME_S1B1 KERNEL_DIR=/usr/src/linux KBUILD_OUTPUT=/lib/modules/2.6.26-mactel/build                                                                 
 *                                                                                  
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                                   
 * A complete build log is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/temp/build.log'.                                                       
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/vmware-modules-1.0.0.15-r1/temp/environment'.                                              
 *                                                                                  

>>> Failed to emerge app-emulation/vmware-modules-1.0.0.15-r1

Reproducible: Always




Portage 2.2_rc12 (default-linux/x86/2007.0, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.26-mactel i686)                                                                      
=================================================================                   
System uname: Linux-2.6.26-mactel-i686-Intel-R-_Core-TM-2_CPU_T7200_@_2.00GHz-with-glibc2.0                                                                             
Timestamp of tree: Fri, 24 Oct 2008 01:45:02 +0000                                  
app-shells/bash:     3.2_p39                                                        
dev-java/java-config: 1.3.7, 2.1.6-r1                                               
dev-lang/python:     2.4.4-r9, 2.5.2-r8                                             
dev-python/pycrypto: 2.0.1-r6                                                       
dev-util/cmake:      2.6.2                                                          
sys-apps/baselayout: 2.0.0                                                          
sys-apps/openrc:     0.3.0-r1                                                       
sys-apps/sandbox:    1.2.18.1-r3                                                    
sys-devel/autoconf:  2.13, 2.63                                                     
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1                   
sys-devel/binutils:  2.18-r3                                                        
sys-devel/gcc-config: 1.4.0-r4                                                      
sys-devel/libtool:   2.2.6a                                                         
virtual/os-headers:  2.6.26                                                         
ACCEPT_KEYWORDS="x86 ~x86"                                                          
CBUILD="i686-pc-linux-gnu"                                                          
CFLAGS="-march=nocona -O2 -pipe -ggdb"                                              
CHOST="i686-pc-linux-gnu"                                                           
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"                                                
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"                                             
CXXFLAGS="-march=nocona -O2 -pipe -ggdb"                                            
DISTDIR="/usr/portage/distfiles"                                                    
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                                                 
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                                                   
LDFLAGS=""                                                                          
LINGUAS="en en_GB pt"                                                               
MAKEOPTS="-j3"                                                                      
PKGDIR="/usr/portage/packages"                                                      
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                              
PORTAGE_TMPDIR="/var/tmp"                                                           
PORTDIR="/usr/portage"                                                              
PORTDIR_OVERLAY="/usr/local/portage"                                                
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"                               
USE="R X aac accessibility acl acpi addbookmarks addressbook aften alias alsa amarok amrnb apache2 aspnet aspnet2 audiofile autoreplace big-tables bluetooth bzip2 cairo calendar caps cdaudio cddb chicken cjk cli clisp connectionstatus contactnotes context cracklib crypt ctype cups curl cxx daap dbus device-mapper dia djvu dri dts dvd dvdread emacs enblend encode examples exif expat extra extrafilters fame fat ffmpeg flac fontforge fortran gadu games gd gdbm git glitz gmp gnutls gpm graphics graphviz groupwise gstreamer gtk gtkhtml guile gzip-el hal highlight history htmlhandbook humanities iconv ieee1394 imagemagick imlib inkjar inotify ipv6 irc irda isdnlog jabber java java6 javascript jpeg kde kig-scripting kpathsea kqemu lame laptop latex ldap libextractor libffi libsamplerate lua lzo madwifi marble mbox midi mjpeg mmx mono moonlight mozsha1 mp3 mp3tunes mp4 mpeg mplayer msn mudflap music musicbrainz mysql mzscheme ncurses netmeeting network networking networkmanager nls nowlistening nptl nptlonly nsplugin ntfs ntp nuv ocaml ogg omega openal opengl openmp openvpn oscar pam paste64 pcre pdf perl php pike plasma plotutils plugins png posix postscript povray ppds pppd pptp preview-latex privacy pstricks publishers pymacs python qq qt3 qt3support qt4 quicktime readline reflection reiserfs ruby samba sametime sasl science sdl session sift slp smp sms solver speex spell spl sqlite sqlite3 sse sse2 ssl ssse3statistics subtitles subversion svg svga taglib tcl tcpd tex tex4ht texteffect theora threads tidy tiff tk toolbar toolkit-scroll-bars translator truetype unicode urlpicpreview usb v4l v4l2 vcd visualization vorbis webpresence wifi win32codecs winpopup wma wmf wmp wxwindows x264 x86 xcf xcomposite xetex xft xine xml xmlreader xmlrpc xmlwriter xorg xpm xrandr xscreensaver xulrunner xv xvid yahoo yaz zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1     emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m   maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB pt" USERLAND="GNU" VIDEO_CARDS="i810 vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL,PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mike Auty gentoo-dev 2008-10-25 12:14:25 UTC

*** This bug has been marked as a duplicate of bug 227303 ***