Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243750 - app-text/sgrep: CC variable not respected
Summary: app-text/sgrep: CC variable not respected
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo SGML herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2008-10-24 01:03 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2012-01-21 06:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch to sgrep-1.92a.ebuild to autoreconf the package, after fixing deprecated behavior that caused autotools to abort (sgrep-1.92a.ebuild.patch,1.03 KB, patch)
2009-08-29 16:04 UTC, Kevin Pyle
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-24 01:03:34 UTC
I'm filing this bug (from a template, mind you) because the ebuild I'm reporting it against failed to build once I removed my /usr/bin/{gcc,cc,c++,c99} binaries. This means that the ebuild is relying on gcc or cc as compiler, while it should use "$(tc-getCC)" so that user choices are respected, and cross-compiling works as intended.

This usually comes down to one of these tasks:

- use emake CC="$(tc-getCC)" for building, to ovewrite make's CC variable (defaults to "cc", some upstream rewrites it);
- the above plus replacing explicit "gcc" (or similar) calls with $(CC) so that the variable is actually respected;
- tc-export CC in src_compile before eventual econf.

For C++, you'd have to replace CC with CXX everywhere above, of course.

If your package is a special case on this, please let me know.

Thanks,
Diego
Comment 1 Kevin Pyle 2009-08-29 16:04:02 UTC
Created attachment 202618 [details, diff]
Patch to sgrep-1.92a.ebuild to autoreconf the package, after fixing deprecated behavior that caused autotools to abort

This package is based on autotools, but ships a configure so old that passing --host= does not cause it to use a fully qualified gcc name.  Rerunning autoconf after unpacking updates to a newer configure, which then uses a fully qualified gcc name.
Comment 2 Marcel Partap 2010-07-12 10:38:29 UTC
The package version should be bumped to 1.94a which contains a lot of fixes (thx to eager debians ;). Maybe also fix for this?
Comment 3 Tim Harder gentoo-dev 2012-01-21 06:40:05 UTC
This should be fixed in 1.94a in CVS.