Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243744 - app-text/rhyme: CC variable not respected
Summary: app-text/rhyme: CC variable not respected
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: tc-directly
  Show dependency tree
 
Reported: 2008-10-24 01:02 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2009-07-23 03:30 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Respect user set CC, and some cleanup (rhyme_fix_cc.patch,1.48 KB, patch)
2009-05-21 01:10 UTC, Espen Hustad
Details | Diff
Respect user set CC, and some cleanup (rhyme_fix_cc.patch,1.27 KB, patch)
2009-05-22 14:41 UTC, Espen Hustad
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-24 01:02:23 UTC
I'm filing this bug (from a template, mind you) because the ebuild I'm reporting it against failed to build once I removed my /usr/bin/{gcc,cc,c++,c99} binaries. This means that the ebuild is relying on gcc or cc as compiler, while it should use "$(tc-getCC)" so that user choices are respected, and cross-compiling works as intended.

This usually comes down to one of these tasks:

- use emake CC="$(tc-getCC)" for building, to ovewrite make's CC variable (defaults to "cc", some upstream rewrites it);
- the above plus replacing explicit "gcc" (or similar) calls with $(CC) so that the variable is actually respected;
- tc-export CC in src_compile before eventual econf.

For C++, you'd have to replace CC with CXX everywhere above, of course.

If your package is a special case on this, please let me know.

Thanks,
Diego
Comment 1 Espen Hustad 2009-05-21 01:10:03 UTC
Created attachment 191973 [details, diff]
Respect user set CC, and some cleanup
Comment 2 Espen Hustad 2009-05-22 14:41:09 UTC
Created attachment 192119 [details, diff]
Respect user set CC, and some cleanup
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-30 02:07:22 UTC
done, thx Espen
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-07-23 03:30:55 UTC
(In reply to comment #3)
> done, thx Espen
> 

I guess I forgot to resolve this