Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243248 - gnome-base/gnome-applets-2.22.3 fails FEATURES="sandbox"
Summary: gnome-base/gnome-applets-2.22.3 fails FEATURES="sandbox"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 246210 (view as bug list)
Depends on:
Blocks: 243288
  Show dependency tree
 
Reported: 2008-10-22 16:56 UTC by jieryn
Modified: 2008-11-10 07:58 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-base:gnome-applets-2.22.3:20081022-142551.log (gnome-base:gnome-applets-2.22.3:20081022-142551.log,280.42 KB, text/plain)
2008-10-22 16:57 UTC, jieryn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jieryn 2008-10-22 16:56:48 UTC
[ebuild  N    ] gnome-base/gnome-applets-2.22.3  USE="acpi gnome hal ipv6 -apm -debug -doc -gstreamer" 0 kB

Portage 2.2_rc12 (default/linux/amd64/2008.0/developer, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27.2 x86_64)
=================================================================
System uname: Linux-2.6.27.2-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-glibc2.2.5
Timestamp of tree: Wed, 22 Oct 2008 11:00:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r15, 2.5.2-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--verbose --keep-going --jobs 25 --load-average 25"
FEATURES="buildsyspkg cvs digest distlocks fixpackages metadata-transfer multilib-strict parallel-fetch preserve-libs protect-owned sandbox sfperms sign splitdebug strict unmerge-orphans userfetch usersandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/java-overlay /usr/local/portage/layman/nouveau /usr/local/portage/layman/mozilla /usr/local/portage /usr/local/portage/krossai /usr/local/portage/ibm-internal/gentoo-ebuilds /usr/local/portage/java-experimental"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amd64 ao apache2 avahi bash-completion berkdb bluetooth bzip2 cairo caps cddb cdr cli cracklib crypt css ctype cups curl cvs dbus dirac directfb dri dvd dvdr dvdread emboss encode enscript evo fam fbcon ffmpeg firefox flac fortran gdbm gif git gnome gnome-keyring gnutls gpm gtk gtkhtml hal iconv id3tag ieee1394 imagemagick imap imlib ipv6 isdnlog jpeg kerberos laptop libnotify lzo mad mailwrapper mbox midi mikmod mmx mng mp3 mpeg mplayer mudflap multilib musepack mysql ncurses network networkmanager nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png pop ppds pppd pulseaudio python qt3 qt3support qt4 quicktime rdesktop readline reflection rtc samba schroedinger sdl session sndfile snmp spell spl sse sse2 ssl ssse3 startup-notification subversion svg sysfs tcpd theora tiff truetype unicode usb vcd vhosts vorbis wmf x264 xinetd xml xorg xulrunner xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="peruser" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="fbdev nouveau nv nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Reproducible: Always
Comment 1 jieryn 2008-10-22 16:57:22 UTC
Created attachment 169446 [details]
gnome-base:gnome-applets-2.22.3:20081022-142551.log
Comment 2 Alexander Huemer 2008-10-22 17:28:23 UTC
same situation here.
sandbox violation.
tried to write to /root/.gconf/.testing.writeability as a writability check.
Comment 3 Sancho 2008-10-22 19:05:02 UTC
emerge -B sandbox
emerge -C sandbox
emerge gnome-applets
emerge sandbox
That's ugly but work for me ~x86 :)

gnome-applets-2.22.3 acpi gnome hal
Comment 4 jieryn 2008-10-22 19:13:20 UTC
That's really not a solution, sorry. Besides, you could just FEATURES="-sandbox" ... I have no idea why you'd unmerge sandbox just to disable it.

Next..?
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-10-22 21:18:53 UTC
another gconf 2.24 failure it seems, let's create that tracker.
Comment 6 Paulo J. Matos 2008-10-30 11:05:40 UTC
Well, FEATURES="-sandbox" emerge gnome-applets was the solution around here. :(
Comment 7 anemos 2008-11-05 20:44:10 UTC
What I did to temporarily bypass this was
# emerge -1av gnome-applets
# mkdir /var/tmp/portage/gnome-base/gnome-applets-2.22.3/image/root
# ebuild /usr/portage/gnome-base/gnome-applets/gnome-applets-2.22.3.ebuild qmerge

It's an ugly hack but at least it gets emerged the correct way (I think).
Comment 8 Gilles Dartiguelongue gentoo-dev 2008-11-09 01:23:18 UTC
fixed without a bump.
Comment 9 Mart Raudsepp gentoo-dev 2008-11-10 07:58:27 UTC
*** Bug 246210 has been marked as a duplicate of this bug. ***