Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 243160 - [gnome overlay] app-i18n/libtomoe-gtk-0.6.0: problem with gucharmap-2.24.0
Summary: [gnome overlay] app-i18n/libtomoe-gtk-0.6.0: problem with gucharmap-2.24.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: CJK Team
URL: https://sourceforge.net/tracker2/?fun...
Whiteboard:
Keywords:
: 262367 438202 (view as bug list)
Depends on: 249753
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-21 23:03 UTC by Rafał Mużyło
Modified: 2012-10-16 10:33 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
libtomoe-gtk-0.6.0-gucharmap2.patch (libtomoe-gtk-0.6.0-gucharmap2.patch,753 bytes, patch)
2008-12-03 22:20 UTC, Gilles Dartiguelongue
Details | Diff
libtomoe-gtk-0.6.0-gucharmap2.patch (libtomoe-gtk-0.6.0-gucharmap2.patch,6.14 KB, patch)
2008-12-03 23:19 UTC, Gilles Dartiguelongue
Details | Diff
patch to build scim-tomoe with gucharmap2 (scim-tomoe-0.6.0-gucharmap2.patch,711 bytes, patch)
2008-12-06 17:52 UTC, Rafał Mużyło
Details | Diff
libtomoe-gtk-0.6.0-gucharmap2.patch (libtomoe-gtk-0.6.0-gucharmap2.patch,7.23 KB, text/plain)
2008-12-21 03:49 UTC, MATSUU Takuto (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafał Mużyło 2008-10-21 23:03:38 UTC
To put it simple: API change in gucharmap,
for pkg-config gucharmap became gucharmap-2.
Can't tell yet how hard will be porting.
Comment 1 Gilles Dartiguelongue gentoo-dev 2008-12-03 22:20:19 UTC
Created attachment 174199 [details, diff]
libtomoe-gtk-0.6.0-gucharmap2.patch

this patch allows libtomoe-gtk to detect the new gucharmap but it won't build because of the API changes.
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-12-03 23:19:33 UTC
Created attachment 174201 [details, diff]
libtomoe-gtk-0.6.0-gucharmap2.patch

better patch that updates libtomoe-gtk use of the gucharmap API. It doesn't look really clean to keep compatibility with the older API so I'll wait on @cjk input to see what they want to do.

For now, it seems fedora just disable the gucharmap integration.
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-12-03 23:24:11 UTC
posted the issue upstream.
Comment 4 Rafał Mużyło 2008-12-06 17:52:48 UTC
Created attachment 174432 [details, diff]
patch to build scim-tomoe with gucharmap2

As a companion to your patch, I'm dropping mine:
it for scim-tomoe 0.6.0.
I'm not sure if it's correct, but tomoe seems to work.
Comment 5 Rafał Mużyło 2008-12-06 17:57:40 UTC
As a sidenote - regarding your patch:
you should add a block adding ACLOCAL_AMFLAGS = macros
to the top level Makefile.am, so eautoreconf just works.
Comment 6 Gilles Dartiguelongue gentoo-dev 2008-12-07 00:32:34 UTC
(In reply to comment #5)
> As a sidenote - regarding your patch:
> you should add a block adding ACLOCAL_AMFLAGS = macros
> to the top level Makefile.am, so eautoreconf just works.
> 

This is intentional, my goal is to fix gucharmap API usage, not autofoo here.
Comment 7 Gilles Dartiguelongue gentoo-dev 2008-12-07 00:33:39 UTC
@cjk, please comment on those patch, how would you like to see them in portage and whatnot, I don't really want to step on someone's toes.
Comment 8 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-20 03:25:20 UTC
sorry for delay.
I think it should be handled by #if pragma for both gucharmap and gucharmap2 api. I'll contact to upstream soon.
Comment 9 MATSUU Takuto (RETIRED) gentoo-dev 2008-12-21 03:49:00 UTC
Created attachment 176020 [details]
libtomoe-gtk-0.6.0-gucharmap2.patch

this patch is based on http://lists.sourceforge.jp/mailman/archives/tomoe-devel/2008-December/000197.html.
Could you test this?
Comment 10 Gilles Dartiguelongue gentoo-dev 2008-12-21 14:20:08 UTC
Hum overlooking further discussion on upstream ml, it seems this patch is not enough. It is a bit simpler than mine but I don't really like adding that much #ifdefs :). Anyway we'll stick to upstream choice if they come up with something better.
Comment 11 Gilles Dartiguelongue gentoo-dev 2009-02-18 23:14:52 UTC
this patch doesn't seem to apply on the version in tree. I'll fix it tomorrow nigth and commit if it's ok for you. With scim fixes too.
Comment 12 Gilles Dartiguelongue gentoo-dev 2009-02-22 21:20:16 UTC
Included in 0.6.0-r1 bump for libtomoe-gtk and 0.6.0-r2 for scim-tomoe. Thanks for refining the patch and working with upstream.
Comment 13 Christopher Atherton 2009-02-26 22:46:19 UTC
libtomoe-gtk-0.6.0-r1 still doesn't compile with the doc flag enabled.

gtk-doc: Compiling scanner
libtool: compile:  x86_64-pc-linux-gnu-gcc -I../../src -I../../src -I/usr/include/tomoe -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -c libtomoe-gtk-scan.c  -fPIC -DPIC -o .libs/libtomoe-gtk-scan.o
In file included from ../../src/tomoe-gtk.h:36,
                 from libtomoe-gtk-scan.c:7:
../../src/tomoe-gucharmap.h:27:33: error: gucharmap/gucharmap.h: No such file or directory
Comment 14 Gilles Dartiguelongue gentoo-dev 2009-02-26 23:04:32 UTC
that would be with USE="-gucharmap" I believe. Well that's another bug then. Please fill a new one with a reference to an upstream bug. Thanks.
Comment 15 Christopher Atherton 2009-02-27 01:46:15 UTC
(In reply to comment #14)
> that would be with USE="-gucharmap" I believe. Well that's another bug then.
> Please fill a new one with a reference to an upstream bug. Thanks.
> 

Nope.  gucharmap is on, and gucharmap and doc mutually exclude each other.  Either gucharmap or doc build, but not both.  Notice it's looking for gucharmap.h, but '-I/usr/include/gucharmap-2' is missing, which leads to failure.
Comment 16 Gilles Dartiguelongue gentoo-dev 2009-03-04 00:04:07 UTC
reopening before I forget to fix that.
Comment 17 Gilles Dartiguelongue gentoo-dev 2009-03-09 23:02:57 UTC
fixed without a bump as this affects only users have USE="doc".
Comment 18 Rafał Mużyło 2009-03-13 21:58:23 UTC
*** Bug 262367 has been marked as a duplicate of this bug. ***
Comment 19 Pablo Yanez Trujillo 2009-12-16 02:12:00 UTC
what was exactly the fix? I've just made a eix-sync and I'm trying to compile scim-tomoe and libtomoe-gtk cannot be configured because of "gucharmap >= 1.4.0". I also tried enabling and disabling the 'doc' flag but it didn't worked. It seems not fixed for me :(
Comment 20 Rafał Mużyło 2009-12-21 17:53:12 UTC
It's fixed by keywording libtomoe-gtk-0.6.0-r1
(which should have a stable request by now, BTW)
Comment 21 Naohiro Aota gentoo-dev 2012-10-16 10:33:24 UTC
*** Bug 438202 has been marked as a duplicate of this bug. ***