Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242842 - gnome-base/eel-2.22.2 fails to compile against gnome-base/gnome-desktop-2.24.0 (gnome_bg_set_uri undefined)
Summary: gnome-base/eel-2.22.2 fails to compile against gnome-base/gnome-desktop-2.24....
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 242866 243080 243302 244016 245407 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-10-20 02:09 UTC by James Erickson
Modified: 2008-11-22 10:21 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Erickson 2008-10-20 02:09:57 UTC
did "emerge --update --deep world" and it tells me the following:

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: gnome-base/gnome-desktop-2.24.0
 *  - /usr/lib64/libgnome-desktop-2.so.2
 *  - /usr/lib64/libgnome-desktop-2.so.2.4.8
 *      used by /usr/bin/awn-applet-activation (gnome-extra/avant-window-navigator-0.2.6-r1)
 *      used by /usr/bin/bug-buddy (gnome-extra/bug-buddy-2.22.0)
 *      used by /usr/bin/epiphany (www-client/epiphany-2.24.0.1)
 *      used by 66 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

so i run "emerge @preserved-rebuild" which fails with:

GMENU_I_KNOW_THIS_IS_UNSTABLE     -march=nocona -O2 -pipe -MT check-program.o -MD -MP -MF .deps/check-program.Tpo -c -o check-program.o check-program.c
mv -f .deps/check-program.Tpo .deps/check-program.Po
/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -march=nocona -O2 -pipe libeel-2.la -lm -Wl,-O1 -o check-program check-program.o -pthread -lgailutil -lglade-2.0 -lgnome-desktop-2 -lgnomeui-2 -lSM -lICE -lbonoboui-2 -lgnomevfs-2 -lgnomecanvas-2 -lgnome-2 -lpopt -lbonobo-2 -lbonobo-activation -lORBit-2 -lart_lgpl_2 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lz -lfontconfig -lgconf-2 -lgthread-2.0 -lrt -lgmodule-2.0 -lgobject-2.0 -lglib-2.0 -lxml2 -lstartup-notification-1   
x86_64-pc-linux-gnu-gcc -march=nocona -O2 -pipe -Wl,-O1 -o .libs/check-program check-program.o -pthread  ./.libs/libeel-2.so -lm /usr/lib64/libgailutil.so /usr/lib64/libglade-2.0.so /usr/lib64/libgnome-desktop-2.so /usr/lib64/libgnomeui-2.so /usr/lib64/libSM.so /usr/lib64/libICE.so /usr/lib64/libbonoboui-2.so /usr/lib64/libgnomevfs-2.so /usr/lib64/libgnomecanvas-2.so /usr/lib64/libgnome-2.so /usr/lib64/libpopt.so /usr/lib64/libbonobo-2.so /usr/lib64/libbonobo-activation.so /usr/lib64/libORBit-2.so /usr/lib64/libart_lgpl_2.so /usr/lib64/libgtk-x11-2.0.so /usr/lib64/libgdk-x11-2.0.so /usr/lib64/libatk-1.0.so /usr/lib64/libgio-2.0.so /usr/lib64/libpangoft2-1.0.so /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libcairo.so /usr/lib64/libpango-1.0.so /usr/lib64/libfreetype.so -lz /usr/lib64/libfontconfig.so /usr/lib64/libgconf-2.so /usr/lib64/libgthread-2.0.so -lrt /usr/lib64/libgmodule-2.0.so /usr/lib64/libgobject-2.0.so /usr/lib64/libglib-2.0.so /usr/lib64/libxml2.so /usr/lib64/libstartup-notification-1.so 
./.libs/libeel-2.so: undefined reference to `gnome_bg_set_uri'
collect2: ld returned 1 exit status
make[2]: *** [check-program] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/eel-2.22.2/work/eel-2.22.2/eel'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/eel-2.22.2/work/eel-2.22.2'
make: *** [all] Error 2
 * 
 * ERROR: gnome-base/eel-2.22.2 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line  702:  Called gnome2_src_compile
 * environment, line  633:  Called die
 * The specific snippet of code:
 * emake || die "compile failure"
 * The die message:
 * compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-base/eel-2.22.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/eel-2.22.2/temp/environment'.
 * 

>>> Failed to emerge gnome-base/eel-2.22.2, Log file:

>>>  '/var/tmp/portage/gnome-base/eel-2.22.2/temp/build.log'

 * Messages for package gnome-base/eel-2.22.2:

 * 
 * ERROR: gnome-base/eel-2.22.2 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line  702:  Called gnome2_src_compile
 * environment, line  633:  Called die
 * The specific snippet of code:
 * emake || die "compile failure"
 * The die message:
 * compile failure
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/gnome-base/eel-2.22.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/gnome-base/eel-2.22.2/temp/environment'.
 * 


Reproducible: Always




uname -a
Linux odysseus 2.6.27-gentoo #5 SMP Tue Oct 14 19:33:26 CDT 2008 x86_64 Intel(R) Xeon(R) CPU E5405 @ 2.00GHz GenuineIntel GNU/Linux

emerge --info
Portage 2.2_rc12 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5405_@_2.00GHz-with-glibc2.2.5
Timestamp of tree: Sun, 19 Oct 2008 23:01:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.cites.uiuc.edu/pub/gentoo/ "
LDFLAGS="-Wl,-O1"
MAKEOPTS=""
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 acl alsa amd64 apache2 avahi berkdb bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr emacs encode esd ffmpeg flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal iconv imap ipv6 isdnlog jpeg jpeg2k kqemu ldap mad mdnsresponder-compat midi mmx mp3 mpeg mpeg2 mplayer mudflap multilib ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl png pppd python qt3 readline reflection sdl session smtp spl sse ssl svg sysfs tcpd theora tiff unicode usb v4l v4l2 virtuoso vorbis xcb xorg xulrunner xv zlib" ALSA_CARDS="virtuoso" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Mishael Sibiryakov 2008-10-20 07:22:28 UTC
Have the same problem on the same platform.

Symbol gnome_bg_set_uri defined in the:
/usr/lib/libgnome-desktop-2.so.2 -> libgnome-desktop-2.so.2.4.8 

But libeel2 is linking with the /usr/lib64/libgnome-desktop-2.so and got unresolved symbol.
Comment 2 Mike Auty gentoo-dev 2008-10-20 09:24:39 UTC
CCing the portage crew, since this may only happen when the old libgnome-desktop is hanging around...
Comment 3 Mike Auty gentoo-dev 2008-10-20 09:25:51 UTC
*** Bug 242866 has been marked as a duplicate of this bug. ***
Comment 4 Mike Auty gentoo-dev 2008-10-20 09:30:27 UTC
Yoel, I've marked your bug as a duplicate, but it pointed out that you're getting gnome-desktop-2.24.0 and trying to compile 2.22 packages against it.  This probably won't work, and hopefully the latest eel will come along soon and get it all going smoothly again.  This isn't really a portage bug, so I've removed their CC again (sorry for the spam guys).

Since you're running ~amd64, unfortunately you'll have to expect small breakages like this from time to time.  Sorry about that.  5:(

In the interim, you should probably downgrade and wait a couple of days for the new eel, or if you're really impatient, go get the gnome overlay to tide you over for the few days whilst they move everything into the main tree...
Comment 5 Mishael Sibiryakov 2008-10-20 09:37:13 UTC
eel from the gnome overlay is working great :)

>>> Installing gnome-base/eel-2.24.0

2.24 in overlay instead of 2.22 in the main tree.
Comment 6 Robert Piasek (RETIRED) gentoo-dev 2008-10-20 13:19:46 UTC
yep, eel 2.22 doesn't want to work against gnome-desktop 2.24

Some other packages break too (which depends on eel) - like:
nautilus, gnome-settings-daemon.

piasekr@rob ~ $ ldd -r -v $(which nautilus) | grep eel
	libeel-2.so.2 => /usr/lib/libeel-2.so.2 (0x00007fe50d2ee000)
undefined symbol: gnome_bg_changes_with_size	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_set_placement	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_set_uri	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_set_pixmap_as_root	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_is_dark	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_set_color	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_new	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_bg_create_pixmap	(/usr/lib/libeel-2.so.2)
undefined symbol: gnome_desktop_item_new_from_uri	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_get_string	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_get_entry_type	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_get_localestring	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_copy	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_ref	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_set_location	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_new_from_string	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_set_string	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_unref	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_set_localestring	(/usr/bin/nautilus)
undefined symbol: gnome_desktop_item_save	(/usr/bin/nautilus)
	/usr/lib/libeel-2.so.2:
Comment 7 Mishael Sibiryakov 2008-10-20 14:11:49 UTC
Strange, i have no problems at all.

$ ldd -r -v $(which nautilus) | grep eel
        libeel-2.so.2 => /usr/lib/libeel-2.so.2 (0x00007fd6838f9000)
        /usr/lib/libeel-2.so.2:

$ epm -q nautilus
nautilus-2.24.0
Comment 8 Rémi Cardona gentoo-dev 2008-10-20 22:49:42 UTC
gnome-desktop-2.24 has been masked earlier today. Resyncing should take care of the problem, at least for now.

Thanks
Comment 9 Rémi Cardona gentoo-dev 2008-10-21 18:24:08 UTC
*** Bug 243080 has been marked as a duplicate of this bug. ***
Comment 10 Mike Auty gentoo-dev 2008-10-23 10:45:44 UTC
*** Bug 243302 has been marked as a duplicate of this bug. ***
Comment 11 Gilles Dartiguelongue gentoo-dev 2008-10-27 00:02:28 UTC
*** Bug 244016 has been marked as a duplicate of this bug. ***
Comment 12 Rémi Cardona gentoo-dev 2008-11-03 16:27:56 UTC
*** Bug 245407 has been marked as a duplicate of this bug. ***
Comment 13 Mart Raudsepp gentoo-dev 2008-11-03 19:04:48 UTC
*** Bug 245407 has been marked as a duplicate of this bug. ***
Comment 14 Gilles Dartiguelongue gentoo-dev 2008-11-08 23:41:19 UTC
proper version of eel is in the tree.
Comment 15 Gilles Dartiguelongue gentoo-dev 2008-11-09 01:35:23 UTC
2.24 is in tree and now unmasked so when you upgrade you just have to use emerge @preserved-rebuild or revdep-rebuild.
Comment 16 Robert Bradbury 2008-11-09 23:22:20 UTC
Yes, 2.24 is gradually leaking into the source tree as a complete package (see other bugs I have recently filed relating to the incomplete release problems).

But *have* you updated the documentation so that people can research what is involved in @preserved-rebuild?  Precisely where are the source files kept that generate this list of what is to be rebuilt and whether or not (or where) there is an archived list of such packages?

Having spent several hours trying to track this down, I would suggest that proposing solutions which depend upon undocumented features is almost as bad as creating the features (without documenting them) in the first place.
Comment 17 Mart Raudsepp gentoo-dev 2008-11-09 23:53:39 UTC
There was an OR in there. @preserved-rebuild OR revdep-rebuild. If you don't know the former, maybe it's a good idea to fall back to the latter?
@preserved-rebuild is a special set in portage-2.2 that dynamically includes packages that need a rebuild to stop using a library version that is not owned by anything really anymore, but was preserved as a portage-2.2 feature to not break things too badly (remember expat for example), but yet complain loudly after most emerge operations that you need to do the rebuilds to get a clean working system.
It is documented in portage-2.2 related documentation, which hasn't entered the handbooks yet, because remember -- you are using ~arch here.
Comment 18 Gilles Dartiguelongue gentoo-dev 2008-11-22 10:21:02 UTC
*** Bug 248125 has been marked as a duplicate of this bug. ***