Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242768 - media-sound/sox-14.0.1 fails to build against media-video/ffmpeg-0.4.9_p20081014
Summary: media-sound/sox-14.0.1 fails to build against media-video/ffmpeg-0.4.9_p20081014
Status: VERIFIED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 242956 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-10-19 13:56 UTC by Ed Tomlinson
Modified: 2008-10-21 04:15 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Tomlinson 2008-10-19 13:56:14 UTC
sox ebuild fails




Reproducible: Always

Steps to Reproduce:
emerge sox

Actual Results:  
/bin/sh ../libtool --silent --tag=CC  --silent --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I.  -DLADSPA_PATH="\"/usr/lib64/ladspa\"" -DPKGLIBDIR="\"/usr/lib64/sox\""   -march=k8 -O -pipe -fsigned-char -Wall -W -Wmissing-prototypes -Wstrict-prototypes -pedantic -MT vorbis.lo -MD -MP -MF .deps/vorbis.Tpo -c -o vorbis.lo vorbis.c
ffmpeg.c: In function âstream_component_openâ:
ffmpeg.c:94: error: âAVCodecContextâ has no member named âerror_resilienceâ
ffmpeg.c: In function âstopwriteâ:
ffmpeg.c:470: warning: passing argument 1 of âurl_fcloseâ from incompatible pointer type
make[2]: *** [ffmpeg.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
mv -f .deps/nulfile.Tpo .deps/nulfile.Plo
In file included from mp3.c:82:
mp3-duration.h: In function âmp3_duration_msâ:
mp3-duration.h:108: warning: format â%uâ expects type âunsigned intâ, but argument 3 has type âsize_tâ
mv -f .deps/mp3.Tpo .deps/mp3.Plo
mv -f .deps/vorbis.Tpo .deps/vorbis.Plo
make[2]: Leaving directory `/var/tmp/portage/media-sound/sox-14.0.1/work/sox-14.0.1/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/var/tmp/portage/media-sound/sox-14.0.1/work/sox-14.0.1/src'
make: *** [all-recursive] Error 1
 *
 * ERROR: media-sound/sox-14.0.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2907:  Called die
 * The specific snippet of code:

 *       emake || die "emake failed."
 *  The die message:
 *   emake failed.

Expected Results:  
no error

# eix sox
[I] media-sound/sox
     Available versions:  ~13.0.0 14.0.1 ~14.1.0 {alsa amrnb amrwb ao debug encode ffmpeg flac id3tag ladspa libsamplerate mad ogg oss png sndfile wavpack}
     Installed versions:  14.0.1(05:07:51 PM 28/06/08)(alsa encode ffmpeg mad ogg oss -amrnb -amrwb -ao -debug -flac -id3tag -ladspa -libsamplerate -sndfile)
     Homepage:            http://sox.sourceforge.net
     Description:         The swiss army knife of sound processing programs
eix ffmpeg
[D] media-video/ffmpeg
     Available versions:  0.4.9_p20070616 (~)0.4.9_p20070616-r1 (~)0.4.9_p20070616-r2 0.4.9_p20070616-r3 (~)0.4.9_p20070616-r20 [M](~)0.4.9_p20080206 (~)0.4.9_p20080326 {X a52 aac altivec amr bindist debug doc encode hardcoded-tables ieee1394 imlib ipv6 mmx mp3 network ogg oss sdl test theora threads truetype v4l vorbis x264 xvid zlib}
     Installed versions:  0.4.9_p20081014(09:00:32 AM 19/10/08)(X aac ipv6 mmx mmxext sdl theora threads vorbis xvid zlib -altivec -amr -bindist -debug -dirac -doc -encode -gsm -hardcoded-tables -ieee1394 -mp3 -network -schroedinger -ssse3 -test -v4l -v4l2 -vhook -x264)
     Homepage:            http://ffmpeg.org/
     Description:         Complete solution to record, convert and stream audio and video. Includes libavcodec. svn revision 11878
Comment 1 Marcel Hasler 2008-10-19 16:46:27 UTC
sox-14.1.0 builds fine with latest ffmpeg.
Comment 2 GS 2008-10-20 09:57:41 UTC
this same error message has stopped a revdep-rebuild
ie  with media-sound/sox-14.0.1 
and media-video/ffmpeg  0.4.9_p20081014 
isn't 0.4.9_p20081014 the latest version for media-video/ffmpeg?
Comment 3 Mike Auty gentoo-dev 2008-10-20 13:46:47 UTC
Hi Ed,

You appear to be mixing stable versions of sox with unstable versions of ffmpeg.  Could you please try either dropping back to the latest stable version of ffmpeg, or updating sox to 14.1.0?

If you're using ~arch packages, then unfortunately you'll have to expect breakages from time-to-time, moreso if you're mixing stable and testing packages.  Sorry...  5:(

Either way, can you report back here as to whether it's broken with ~arch versions of sox/ffmpeg and then we can either close the bug or investigate further.  Thanks...
Comment 4 Till Korten 2008-10-20 21:52:31 UTC
had the exact same problem (also falied during revdep-rebuild)
echo "media-sound/sox ~amd64">> /etc/portage/package.keywords
and then reemerging sox to version 14.1.0 helped.
Thanks Marcel and Mike!
Comment 5 Mike Auty gentoo-dev 2008-10-20 22:28:19 UTC
Ed, it sounds like there are two reports of sox-14.1.0 working with the latest ffmpeg.  As such I'm going to close this bug as WONTFIX, since we can't ensure every version of every package works with every other version.  If you take issue with this, feel free to reopen this.
Comment 6 Ed Tomlinson 2008-10-20 23:43:19 UTC
It does work with sox 14.1.0 - Thanks.
Comment 7 Mike Auty gentoo-dev 2008-10-21 01:26:03 UTC
*** Bug 242956 has been marked as a duplicate of this bug. ***
Comment 8 Rafael 2008-10-21 03:35:50 UTC
I thought that the point of having unstable versions of packages were to find issues like this before they became stable. Fixing this dependence now, wich was what I was asking for in Bug 242956, would make sure you don't forget to stabilize both sox-1.4.1.0 and ffmpeg-0.4.9_p20081014, or newer versions, at the same time.

Sorry if I'm wrong.
Comment 9 GS 2008-10-21 04:15:41 UTC
adding media-sound/sox ~amd64 made all the difference
thanks for such a rapid solution