Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242476 - nvidia-drivers-96.43.07 fails to build against kernel 2.6.27
Summary: nvidia-drivers-96.43.07 fails to build against kernel 2.6.27
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Ricardo Mendoza (RETIRED)
URL:
Whiteboard:
Keywords:
: 247461 (view as bug list)
Depends on: 247461
Blocks: 242708
  Show dependency tree
 
Reported: 2008-10-17 15:24 UTC by Roy Bamford
Modified: 2008-12-18 22:33 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Fixes nvida-drivers-96.43.07 for kernel-2.6.27 (nvida.96.43.07-kernel2.6.27.patch,3.42 KB, patch)
2008-10-17 15:28 UTC, Roy Bamford
Details | Diff
Ebuild for 96.43.09 (nvidia-drivers-96.43.09.ebuild,14.03 KB, text/plain)
2008-11-02 16:32 UTC, Nuno
Details
nvidia-drivers-96.43.09.ebuild (nvidia-drivers-96.43.09.ebuild,13.94 KB, text/plain)
2008-11-10 19:53 UTC, Jiri Tyr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roy Bamford gentoo-dev 2008-10-17 15:24:29 UTC
In file included from /var/tmp/portage/x11-drivers/nvidia-drivers-96.43.07/work/NVIDIA-Linux-x86-96.43.07-pkg0/usr/src/nv/nv.c:14:
/var/tmp/portage/x11-drivers/nvidia-drivers-96.43.07/work/NVIDIA-Linux-x86-96.43.07-pkg0/usr/src/nv/nv-linux.h:106:27: error: asm/semaphore.h: No such file or directory


Reproducible: Always

Steps to Reproduce:
1. Point /usr/src/linux to your built 2.6.27 kernel
2. emerge nvidia-drivers
3.

Actual Results:  
nvidia-drivers fails to build

Expected Results:  
As asm/semaphore.h has been (re)moved/deleted the build failure could have be predicted.

Patch for later nvidia-drivers works but probably won't apply as the line numbers are very different.

Tested against 2.6.26-r1 to show it does no harm and 2.6.27 to show it solves the problem. Patch attached
Comment 1 Roy Bamford gentoo-dev 2008-10-17 15:28:03 UTC
Created attachment 168800 [details, diff]
Fixes nvida-drivers-96.43.07 for kernel-2.6.27
Comment 2 Roy Bamford gentoo-dev 2008-10-17 15:31:52 UTC
Traceablity to original patch. http://kanotix.com/files/173.14.12/NVIDIA_173.14.12_2.6.27.patch
Comment 3 ZeroHour 2008-10-25 00:30:20 UTC
Works with driver version 173.14.12 and 2.6.27 
Comment 4 Piotr Szymaniak 2008-10-29 22:53:39 UTC
Works fine for me, thanks.
Comment 5 .:deadhead:. 2008-11-02 12:19:46 UTC
(In reply to comment #1)
> Created an attachment (id=168800) [edit]
> Fixes nvida-drivers-96.43.07 for kernel-2.6.27

Thank you: it works great!
Please commit asap ;)

Comment 6 Nuno 2008-11-02 16:31:38 UTC
NVidia just release the version 96.43.09 of the driver. I two had the problem and I hacked a build file for it. Just keep in mind that I'm new to this and what I did was to basically copy the ebuild from 96.43.07. All attach the file to the bug.
Comment 7 Nuno 2008-11-02 16:32:40 UTC
Created attachment 170560 [details]
Ebuild for 96.43.09

Hacked ebuild file.
Comment 8 Jiri Tyr 2008-11-10 19:53:54 UTC
Created attachment 171343 [details]
nvidia-drivers-96.43.09.ebuild

Fully working ebuild for beta nvidia-drivers-96.43.09. Tested with vanilla-sources-2.6.27.5.
Comment 9 Martin Meyer 2008-11-14 13:29:40 UTC
I've tested attachment 171343 [details] against gentoo-sources-2.6.27-r2 and it compiles and works fine.

This version brings compat with xorg-server-1.5.*, so when it's committed it'd be nice to fix the dependency in xorg-server-1.5.2.ebuild (or whichever version is current at the time). Right now it depends exclusively on the 177-whatever driver.

I've modified my local xorg-server-1.5.2 ebuild to remove the version dependency on nvidia-drivers, and it works fine with the 96.43.09 driver release. I've been running for several days without issue.
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2008-12-09 21:14:36 UTC
Reminder to maintainers: 2.6.27 is planned to go stable on December 15th, it would be great if you could work on this before then
Comment 11 Richard Hendrikse 2008-12-16 15:02:15 UTC
proposed ebuilds fail to compile against gentoo-sources-2.6.27-r4
I had to put the proposed patch in the ebuild, whereafter it *did* work.
trying out building xorg-server-1.5.2...

emerge --info:
Portage 2.1.6_rc2 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r4 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r4-i686-AMD_Athlon-TM-_XP_2200+-with-glibc2.0
Timestamp of tree: Thu, 27 Nov 2008 14:45:01 +0000
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7, 2.1.2-r1
dev-lang/python:     2.4.4-r4, 2.5.2-r8
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.8
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://192.168.0.3/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
INSTALL_MASK="TODO.bz2 HACKING.bz2"
LDFLAGS="-Wl,-O1"
LINGUAS="nl en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=150"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/portage/local"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gpm gstreamer gtk hal iconv isdnlog jpeg kde libnotify mad midi mikmod mmx mmxext mp3 mpeg mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="snd-via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ricoh sx330z" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 12 Doug Goldstein gentoo-dev 2008-12-18 20:59:51 UTC
*** Bug 247461 has been marked as a duplicate of this bug. ***
Comment 13 Doug Goldstein gentoo-dev 2008-12-18 22:33:06 UTC
Please use the newly added 96.43.09 driver.