Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 242270 - please mark =sys-auth/consolekit-0.2.10 stable
Summary: please mark =sys-auth/consolekit-0.2.10 stable
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords: STABLEREQ
: 258251 (view as bug list)
Depends on:
Blocks: glibc-2.8-stable
  Show dependency tree
 
Reported: 2008-10-15 21:22 UTC by Peter Alfredsen (RETIRED)
Modified: 2009-05-17 01:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-10-15 21:22:58 UTC
bug 238468 seems to be some openrc issue, but I can't reproduce it. Not a regression anyway.
This version fixes issues with glibc-2.8, see bug 225405
If you agree, arches are:
alpha@gentoo.org,amd64@gentoo.org,arm@gentoo.org,hppa@gentoo.org,ia64@gentoo.org,m68k@gentoo.org,ppc64@gentoo.org,ppc@gentoo.org,s390@gentoo.org,sh@gentoo.org,sparc@gentoo.org,x86@gentoo.org
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2008-12-23 01:52:45 UTC
i need this stable for glibc-2.8 stabilization, which is a req for gcc-4.3.
Comment 2 Pacho Ramos gentoo-dev 2009-01-24 10:18:14 UTC
This works for me since was added to the tree, what is preventing stabilization? 

Portage 2.1.6.4 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.28-tuxonice-r1 i686)
=================================================================
System uname: Linux-2.6.28-tuxonice-r1-i686-Genuine_Intel-R-_CPU_T2300_@_1.66GHz-with-glibc2.0
Timestamp of tree: Fri, 23 Jan 2009 20:00:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo-euetib.upc.es/mirror/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="es es_ES en_US"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aim alsa amr ape asf audiofile avahi avi bash-completion bcmath beagle bonobo bzip2 bzlib cairo caps cdb cdda cddb cdparanoia cdr cdrparanoia cli consolekit cpdflib cracklib cross crypt css cups curl curlwrappers daap dbus dirac divx4linux djvu dts dv dvb dvd dvdr dvdread dvi eds emerald encode epiphany escreen evo exif fam fbcon fbsplash ffmpeg flac foomaticdb fortran ftp fuse galago gb gcj gd gif gimp gimpprint git glitz glut glx gmp gnome gnome-keyring gphoto2 gpm gsm gstreamer gtk gtk2 gtkhtml guile hal iconv id3tag imagemagick imlib ipv6 isdnlog jabber jack java java6 jikes jpeg kdeenablefinal kdehiddenvisibility kpathsea ladspa laptop latex lcms lesstif libnotify lm_sensors logrotate lzma mac mad mbox midi mikmod mime ming mmap mmx mmxext mng modplug mono moonlight motif mp3 mpeg mpi mplayer mudflap musepack musicbrainz nas nautilus ncurses nethack network networkmanager nls nocd nptl nptlonly nsplugin ntfs nvidia ogg oggvorbis openal opengl openmp opnegl pam pch pcmcia pcre pdf pdflib perl png pnp posix ppds pppd python qt qt3 qt4 quicktime raw readline reflection reiserfs rpm rtc ruby scanner schroedinger scrobbler sdl session slang slp smp sndfile sockets socks5 sourceview speex spell spl sse sse2 sse3 ssl startup-notification subversion svg sysfs syslog t1lib tcltk tcpd tga theora threads tiff timidity tk truetype trusted unicode usb userlocales v4l2 vcd vhook videos vim vorbis wifi win32codecs wma wmf wxwindows x86 xattr xcb xcomposite xft xine xml xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS=" " ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es es_ES en_US" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-01-29 05:14:42 UTC
I'm not sure how relevant bug 238468 is. I'll have to let other freedesktop people decide. If anyone with more exp with this package in the freedesktop herd could chime in, that would be great. We need this stable with gcc-4.3/glibc-2.8.
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2009-02-02 14:26:24 UTC
If stabilizing consolekit-0.2.10 is not an option at this time, could the build fix from bug 225405 be integrated in consolekit-0.2.3, or a consolekit-0.2.3-r1 ebuild be created with just the patch added?
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-08 23:58:25 UTC
Bug 238468 is not a blocker since it happens in current stable. We need this stable for bug 247553. Adding arches.
Comment 6 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-09 01:16:12 UTC
*** Bug 258251 has been marked as a duplicate of this bug. ***
Comment 7 Tobias Klausmann gentoo-dev 2009-02-09 17:56:05 UTC
Stable on alpha.
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-12 03:11:01 UTC
amd64 stable
Comment 9 Brent Baude (RETIRED) gentoo-dev 2009-02-12 21:16:15 UTC
ppc64 stable
Comment 10 Markus Meier gentoo-dev 2009-02-15 14:57:45 UTC
x86 stable
Comment 11 Raúl Porcel (RETIRED) gentoo-dev 2009-02-17 15:54:42 UTC
arm/ia64/s390/sh/sparc stable
Comment 12 Joe Jezak (RETIRED) gentoo-dev 2009-02-25 14:19:13 UTC
Marked ppc stable.
Comment 13 Jeroen Roovers gentoo-dev 2009-03-06 02:16:55 UTC
Stable for HPPA.
Comment 14 Gilles Dartiguelongue gentoo-dev 2009-05-16 10:06:40 UTC
@m68k, ping ?
Comment 15 SpanKY gentoo-dev 2009-05-17 01:02:27 UTC
you dont generally have to wait on m68k