Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 241380 - texlive-2008 dev-tex/mh fails to build
Summary: texlive-2008 dev-tex/mh fails to build
Status: RESOLVED DUPLICATE of bug 237202
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-11 14:38 UTC by Giampier
Modified: 2008-10-12 09:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
The build.log (build.log,1.03 KB, text/plain)
2008-10-11 14:39 UTC, Giampier
Details
The build environment (environment,83.43 KB, text/plain)
2008-10-11 14:42 UTC, Giampier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giampier 2008-10-11 14:38:28 UTC
emerge -av texlive tries to upgrate texlive-2007 to texlive-2008 but
one of the new dependencies fails to built. In particular it is:

dev-tex/mh-20080903

---

Portage 2.2_rc12 (default/linux/x86/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r1 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r1-i686-Intel-R-_Pentium-R-_M_processor_1.73GHz-with-glibc2.0
Timestamp of tree: Sat, 11 Oct 2008 07:45:02 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.3-r1, 2.5.1-r3
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ ftp://mirror.switch.ch/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl bash-completion bzip2 cli cracklib crypt cups fortran gdbm gpm iconv isdnlog midi mmx mudflap ncurses nls nptl nptlonly openmp pam pcre perl pppd python readline reflection session spl sse sse2 ssl sysfs tcpd unicode x86 xorg zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY



Reproducible: Always
Comment 1 Giampier 2008-10-11 14:39:36 UTC
Created attachment 168038 [details]
The build.log
Comment 2 Giampier 2008-10-11 14:42:14 UTC
Created attachment 168040 [details]
The build environment
Comment 3 Giampier 2008-10-12 09:34:11 UTC
Finally, I found the bug #237202 (Comments 4, 5) in the archive.
Following the instructions at:
 
  http://www.gentoo.org/proj/en/tex/texlive-migration-guide.xml#doc_chap4

I run:

  # rm -rf /var/lib/texmf/web2c
  # texmf-update

This fixed the problem in my case.
Note however that I was not upgrading from tetex but from texlive-2007.
In any case, I am not sure that this procedure should be left to the user.
Comment 4 Giampier 2008-10-12 09:41:31 UTC

*** This bug has been marked as a duplicate of bug 237202 ***