Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240608 - please mark =dev-libs/STLport-5.1.5 stable
Summary: please mark =dev-libs/STLport-5.1.5 stable
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard:
Keywords: STABLEREQ
: 245194 (view as bug list)
Depends on:
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-10-08 22:42 UTC by Peter Alfredsen (RETIRED)
Modified: 2009-03-02 20:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ppc64 build failure (build.log,125.99 KB, text/plain)
2009-01-07 20:38 UTC, Brent Baude (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Alfredsen (RETIRED) gentoo-dev 2008-10-08 22:42:22 UTC
It's been in the tree for almost half a year. We should get this stabled. Please add arches if you agree:
amd64@gentoo.org,ppc64@gentoo.org,ppc@gentoo.org,sparc@gentoo.org,x86@gentoo.org
Comment 1 Alex Cannon 2008-10-13 03:39:28 UTC
Should STLport-5.1.2 be masked on ppc because it doesn't build, at least on my system as I reported in bug 240604?
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2008-10-13 16:15:52 UTC
(In reply to comment #1)
> Should STLport-5.1.2 be masked on ppc because it doesn't build, at least on my
> system as I reported in bug 240604?
> 

Nope. That bug was due to you using gcc-4.3.1 which is still ~arch(unstable) on all arches with STLport-5.1.2 which is arch(stable). But it is the reason I'm asking for 5.1.5 to be stabled, so we don't have this problem when gcc-4.3.x goes stable.
Comment 3 Peter Alfredsen (RETIRED) gentoo-dev 2008-11-01 21:24:12 UTC
*** Bug 245194 has been marked as a duplicate of this bug. ***
Comment 4 Peter Alfredsen (RETIRED) gentoo-dev 2008-11-01 21:28:00 UTC
No response from cpp team.
Arches, please mark stable on my say-so.
Comment 5 Markus Meier gentoo-dev 2008-11-02 12:17:48 UTC
amd64/x86 stable
Comment 6 nixnut (RETIRED) gentoo-dev 2008-11-08 11:38:45 UTC
ppc stable
Comment 7 Raúl Porcel (RETIRED) gentoo-dev 2008-11-30 19:08:19 UTC
sparc stable
Comment 8 Brent Baude (RETIRED) gentoo-dev 2009-01-07 20:38:45 UTC
Created attachment 177711 [details]
ppc64 build failure
Comment 9 Brent Baude (RETIRED) gentoo-dev 2009-01-07 20:39:08 UTC
Anyone else seeing test failures?
Comment 10 Peter Alfredsen (RETIRED) gentoo-dev 2009-01-07 22:24:32 UTC
WFM
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-02-06 21:26:42 UTC
What is the status here. fails on only ppc64? What should be done?
Comment 12 Brent Baude (RETIRED) gentoo-dev 2009-02-06 22:08:22 UTC
still fails here on ppc64 in exact same way
Comment 13 Peter Alfredsen (RETIRED) gentoo-dev 2009-02-12 05:54:31 UTC
(In reply to comment #12)
> still fails here on ppc64 in exact same way

Does 5.1.2 fail in the same way? If yes, mark stable and file a bug. If no, we'll have to think of something.
Comment 14 Brent Baude (RETIRED) gentoo-dev 2009-03-02 20:07:45 UTC
Marking STLport-5.1.5 ppc64 for bug 240608; fails same tests as current stable
Comment 15 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-02 20:11:26 UTC
No arches left. Fixed.