Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 24027 - Emerge of HostAP created Unresolved Symbols in hostap.o and Hostap_crypt.o
Summary: Emerge of HostAP created Unresolved Symbols in hostap.o and Hostap_crypt.o
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Peter Johanson (RETIRED)
Depends on:
Reported: 2003-07-06 21:13 UTC by Tom Barcellona
Modified: 2004-12-29 06:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Tom Barcellona 2003-07-06 21:13:58 UTC
Emerging the latest three versions of HostAP (0.0.3-r1, 0.0.3, and 0.0.2-r1)
create unresolved symbol errors in hostap.o and hostap_crypt.o. (the second one
had something to do with "crypt", but I am not exactly sure what the name is.)
Compiling from source from the hostap website itself (independant of portage)
compiles cleanly.
Comment 1 Peter Johanson (RETIRED) gentoo-dev 2003-07-17 07:18:45 UTC
Can you please send me your more info including "emerge --info" and the output with the unresolved symbols?
Comment 2 Tom Barcellona 2003-07-17 09:13:02 UTC
root@gentoo hostap-0.0.3 # ACCEPT_KEYWORDS="~x86" emerge --info hostap
Portage 2.0.48-r1 (default-x86-1.4, gcc-3.2.2, glibc-2.3.1-r4)
System uname: 2.4.20-gentoo-r5 i686 mobile AMD Athlon(tm) 4 Processor
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/config /usr/kde/3/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 encode foomaticdb libg++ mad mikmod nls xml2 gtkhtml gdbm berkdb slang readline tetex bonobo tcltk guile
sdl libwww imlib 3dfx 3dnow aalib acl acpi -apm alsa arts avi cdr crypt cups dga directfb doc dvd esd ethereal evo
fbcon gif gnome gphoto2 gpm gps gtk gtk2 ipv6 java jpeg kde mmx motif mozilla mpeg nas ncurses oggvorbis opengl oss
pam pcmcia pdflib perl png pnp python qt quicktime samba scanner snmp spell sse ssl svga tcpd truetype trusted usb X
xinerama xmms xv zlib"
CFLAGS="-march=athlon -Os -pipe -fomit-frame-pointer"
CXXFLAGS="-march=athlon -Os -pipe -fomit-frame-pointer"
FEATURES="sandbox distcc ccache"


This pops up at the end of the emerge:

depmod: *** Unresolved symbols in /lib/modules/2.4.20-gentoo-r5/net/hostap.o
depmod: *** Unresolved symbols in /lib/modules/2.4.20-gentoo-r5/net/hostap_crypt_wep.o

and is the same output from "depmod-a."


"modprobe hostap_cs"

/lib/modules/2.4.20-gentoo-r5/net/hostap.o: unresolved symbol hostap_get_crypto_ops_Re5a7eae9
/lib/modules/2.4.20-gentoo-r5/net/hostap.o: insmod /lib/modules/2.4.20-gentoo-r5/net/hostap.o failed
/lib/modules/2.4.20-gentoo-r5/net/hostap.o: insmod hostap_cs failed


The only output from dmesg after a failed modprobe:

hostap_crypt: unregistered algorithm 'WEP'
hostap_crypt: unregistered algorithm 'NULL' (deinit)

Same message when I put the card in. (pcmcia is already set up for this card.)


I had to compile by hand from the original source and just inject it into portage. It works fine that way.
Comment 3 Tom Barcellona 2003-07-30 10:46:01 UTC
Just upgraded my kernel to 2.4.22-pre7-aa1 and tried to emerge the latest hostap drivers in portage. (0.0.4) Still same problems, unresolved symbols. No output from dmesg and nothing in the system logs. Did the same thing as before, built hostap from raw source (0.0.4) and just injected it into portage.
Comment 4 Peter Johanson (RETIRED) gentoo-dev 2003-08-19 17:42:16 UTC
the hostap tarball itself compiles everything with only CFLAGS="-O2", Can you try removing your CFLAGS, or changing the -Os to -O2 to test for me?
Comment 5 Tom Barcellona 2003-09-19 11:36:45 UTC
Just reinstalled entire system on a new laptop (old one that had this problem was fried) with cflags march=pentium4 -O2 -pipe -fomit-frame-pointer. Hostap seems to have compiled with no errors, and works just fine. Problem is that I was never able to test on the old system, so I don't know if this bug should be closed or not.
Comment 6 Jerome 2003-10-19 03:59:31 UTC
I got the problem on my box

neerd linux # emerge --info
Portage 2.0.49-r13 (default-x86-1.4, gcc-3.2.3, glibc-2.3.2-r1, 2.4.20-gentoo-r7)
System uname: 2.4.20-gentoo-r7 i586 AMD-K6(tm) 3D processor
Gentoo Base System version
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
FEATURES="sandbox ccache autoaddcvs"
USE="x86 apm arts avi crypt cups encode foomaticdb gif gpm imlib jpeg libg++
libwww mad mikmod motif mpeg ncurses nls oggvorbis opengl pdflib png quicktime
sdl spell svga truetype xml2 xmms xv zlib gdbm berkdb slang readline mysql
tcpd pam ssl perl python -X -gnome -gtk -gtk2 -kde -qt -java -alsa -oss"

When i emerge hostap, I get the "unresoved symbol" messages at the depmod
If I try to modprobe hostap, i get :
neerd linux # modprobe hostap
/lib/modules/2.4.20-gentoo-r7/net/hostap.o: unresolved symbol wireless_send_event_R5d334258
/lib/modules/2.4.20-gentoo-r7/net/hostap.o: insmod /lib/modules/2.4.20-gentoo-r7/net/hostap.o
/lib/modules/2.4.20-gentoo-r7/net/hostap.o: insmod hostap failed

dmesg do not give me anything interesting:
hostap_crypt: registered algorithm 'NULL'
hostap_crypt: unregistered algorithm 'NULL' (deinit)

I'm a bit stuck :(
Comment 7 Nicolas ANTONIAZZI 2003-10-19 06:06:18 UTC
I've got exactly the same problem.
But I really don't understand where it comes from. I've got two computers,
a desktop and a little server. On the desktop I compiled the gentoo-kernel-2.4.20-r7
and hostap and it works fine, without any problem. On the server, with the
quite same kernel config, I've got unresolved symbol when I emerge Hostap.
I've also tried with vanilla sources (2.4.22) on the server and same errors.
On a second partition of the server I've got a small mandrake distrib installed
with the hostap module. And this one works, so it is not a hardware problem.
Comment 8 Jerome 2003-10-21 05:53:39 UTC
it works for me now,
i just made a 'make mrproper' and a new kernel then emerge hostap and it

The problem may come from a dirty kernel , washed by Mr Proper :)
Comment 9 Peter Johanson (RETIRED) gentoo-dev 2003-12-09 12:38:15 UTC
Okay, everybody but Nicolas seems to have their problems resolved... Nicolas, you still having issues? have you tried trimming your CFLAGS to only -O2 possibly?
Comment 10 Henrik Brix Andersen 2004-09-14 09:29:13 UTC
Does this problem still exist with the latest hostap-driver-0.2.4?
Comment 11 Henrik Brix Andersen 2004-11-01 04:43:25 UTC
Adding mobile@ to CC:, changing to NEEDINFO.
Comment 12 Henrik Brix Andersen 2004-12-29 06:14:08 UTC
Closing due to lack of feedback.