Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240267 - [patch] x11-drivers/xf86-video-ati-6.8.0-r1 (xrandr, rotate, xaa, dri disabled)
Summary: [patch] x11-drivers/xf86-video-ati-6.8.0-r1 (xrandr, rotate, xaa, dri disabled)
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-10-06 13:27 UTC by Dyweni
Modified: 2009-09-19 23:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for xf86-video-ati-6.8.0-r1 (9000-xrand_rotate_xaa_no_dri.patch,398 bytes, patch)
2008-10-06 13:28 UTC, Dyweni
Details | Diff
updated ebuild for 6.8.0-r1 (xf86-video-ati-6.8.0-r1.ebuild,1.60 KB, text/plain)
2008-10-06 13:29 UTC, Dyweni
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dyweni 2008-10-06 13:27:13 UTC
The following patch fixes an uninitialized variable that will crash X.org when rotating the screen using the radeon_drv driver with XAA acceleration and DRI disabled.

This applies to ebuilds 6.8.0, 6.8.0-r1, and 6.9.0.

Confirmed fix in ati git master.


Reproducible: Always

Steps to Reproduce:
Comment 1 Dyweni 2008-10-06 13:28:49 UTC
Created attachment 167451 [details, diff]
patch for xf86-video-ati-6.8.0-r1

this patch applies to the 6.8.0, 6.8.0-r1, 6.9.0
Comment 2 Dyweni 2008-10-06 13:29:41 UTC
Created attachment 167453 [details]
updated ebuild for 6.8.0-r1
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2009-05-14 17:31:10 UTC
Hi, i am not a big fan of fixing stuff in XAA, you have any issues with using EXA? (since it is also upstream recomended backend...)
Btw did you sent your patch to upstream too? :]

Cheers
Comment 4 Rémi Cardona gentoo-dev 2009-09-19 23:01:42 UTC
Please get back to us.

Thanks