Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 240018 - liblrmi bundled with app-laptop/lphdisk failed to build against glibc 2.8
Summary: liblrmi bundled with app-laptop/lphdisk failed to build against glibc 2.8
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-2.8
  Show dependency tree
 
Reported: 2008-10-05 17:38 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2008-12-10 15:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (app-laptop:lphdisk-0.9.1-r1:20081005-173718.log,8.39 KB, text/plain)
2008-10-05 17:39 UTC, Diego Elio Pettenò (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-05 17:38:35 UTC
See attached build log
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-10-05 17:39:03 UTC
Created attachment 167344 [details]
Build log
Comment 2 Mark Loeser (RETIRED) gentoo-dev 2008-11-23 22:14:17 UTC
@treecleaner: This is dead upstream and doesn't seem worth fixing.
Comment 3 Sam Iam 2008-11-23 22:59:28 UTC
I think this is caused by _syscall5() not being available anymore
(http://osdir.com/ml/linux.ltp/2006-10/msg00014.html). In case there is interest, I can give it a try to incorporate this fix. Recording this for posterity :)

Sam
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-02 05:20:36 UTC
ACK.

I vote for removal however, I don't see the harm in leaving it masked until glibc-2.8 goes stable. I will side with other treecleaner votes and take action if no response in ~week.
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2008-12-08 10:33:06 UTC
+*lphdisk-0.9.1-r2 (08 Dec 2008)
+
+  08 Dec 2008; <ssuominen@gentoo.org> +files/lphdisk-0.9.1-gentoo.patch,
+  +lphdisk-0.9.1-r2.ebuild:
+  Use system lrmi library to fix building with GLIBC 2.8, incorporated with
+  GCC 3.x and linux-headers patchset. Untested version. Closes bug #240018.