Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 239395 - x11-drivers/ati-drivers-8.532 crash on hp pavillion tx2550eg with radeon hd 3200
Summary: x11-drivers/ati-drivers-8.532 crash on hp pavillion tx2550eg with radeon hd 3200
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Luca Barbato
Depends on:
Reported: 2008-10-03 05:35 UTC by Thomas Raschbacher
Modified: 2008-10-16 07:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Raschbacher gentoo-dev 2008-10-03 05:35:18 UTC
just tried out catalyst 8.9 (8.532) on my laptop, but it keeps crashing my X .. 8.522 (catalyst 8.8) works ok apart from textures on wine games ;)

please let me know if/where i should report this to ati if it is not gentoo related..

here a backtrace:
0: X(xf86SigHandler+0x6a) [0x4a36ca]
1: /lib/ [0x7fb7327c02c0]
2: /usr/lib64/xorg/modules/drivers// [0x7fb73059ee86]
3: /usr/lib64/xorg/modules// [0x7fb72d454503]
4: /usr/lib64/xorg/modules// [0x7fb72f3c94a3]
5: /usr/lib64/xorg/modules// [0x7fb72f3e6677]
6: X [0x52e432]
7: X(miGlyphs+0x617) [0x515837]
8: /usr/lib64/xorg/modules// [0x7fb72f3c7fd2]
9: /usr/lib64/xorg/modules// [0x7fb72f3e6859]
10: X [0x52e749]
11: X [0x51fdf4]
12: X(Dispatch+0x342) [0x44e032]
13: X(main+0x4a5) [0x435405]
14: /lib/ [0x7fb7327ac486]
15: X(FontFileCompleteXLFD+0x291) [0x4346c9]

Fatal server error:
Caught signal 11.  Server aborting

emerge info output:
Portage 2.2_rc9 (default/linux/amd64/2008.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.27-rc7ATH64 x86_64)
System uname: Linux-2.6.27-rc7ATH64-x86_64-AMD_Turion-tm-_X2_Ultra_Dual-Core_Mobile_ZM-82-with-glibc2.2.5
Timestamp of tree: Tue, 30 Sep 2008 15:00:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en de ja"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/mnt/space/Portage/overlays/layman/sunrise /mnt/space/Portage/overlays/layman/enlightenment /mnt/space/Portage/overlays/layman/wschlich-testing /mnt/space/Portage/overlays/layman/voip"
USE="3dnow 3dnowext X aac aalib accessibility acl acpi alsa amd64 amrnb amrwb apache2 applet aspnet beagle berkdb blender-game bluetooth branding bzip2 cairo cdda cddb cdio cdparanoia cdr cjk cli cracklib crypt cups curl cvs cxx dbus deskbar devhelp dga directfb disk-partition diskio djvu doc dri dts dvb dvd dvdr dvdread dvi edb editor eds elf emacs emboss encode esd evo exif expat extensible fam fat fbcon ffmpeg firefox flac fontconfig fortran freetds fuse galago gcdmaster gcj gd gdbm gedit ggi gif git glade glibc-compat20 gmp gnome gnome-keyring gnomecd gphoto2 gpm gs gsf gstreamer gtk gtkhtml guile hal hddtemp httpd iconv id3tag idle imagemagick imap imlib iproute2 iptc ipv6 irda isdnlog jack jadetex java java6 jpeg kde kerberos ladspa lame laptop lcms ldap libcaca libnotify lirc live lm_sensors log4j loop-aes lzo mad matroska mfd-rewrites midi mikmod mmx mmxext mng module mono mouse mp2 mp3 mpeg mssql mudflap multilib musepack mxdatetime nautilus ncurses netjack network networking nls nptl nptlonly ntfs ntp objc odbc offensive ogg openal openexr opengl openmp pam pcre pdf perl php physfs player png pnm posix postgres ppds pppd python qt3 qt3support qt4 quicktime radio rar raw readline reflection reiserfs remoteosd rtc rtsp samba scanner schroedinger sdl sdl-image sensord server session shout skins smp sndfile snmp soap sockets speex spell spl sql sqlite sqlite3 sse sse2 ssl startup-notification stream subversion svg swat sysfs syslog t1lib taglib tcpd tga theora threads tiff timidity tokenizer tools tracker trayicon truetype unicode usb v4l v4l2 vcd vcdx verse vim vorbis wavpack wddx wireshark wmf x264 xattr xcomposite xhtml xine xml xmlreader xmlrpc xmlwriter xorg xosd xpm xrandr xsl xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="atiixp atiixp-modem hda-intel intel8x0 intel8x0m usb-audio ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias auth_digest authn_dbd imagemap proxy proxy_http " ELIBC="glibc" INPUT_DEVICES="evdev keyboard joystick mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de ja" USERLAND="GNU" VIDEO_CARDS="fbdev radeon radeonhd vesa v4l vga fglrx"
Comment 1 nicolo 2008-10-04 04:35:56 UTC
Same here on Asus notebook with HD2600 and xorg-server version 1.4.2.
I think it should be a driver bug..
Comment 2 Jeffrey Gardner (RETIRED) gentoo-dev 2008-10-04 16:18:55 UTC
Yes, please report it to ATI because there's nothing we can do.

Comment 3 Thomas Raschbacher gentoo-dev 2008-10-07 08:34:45 UTC
Done that. reported to ati drivers linux driver crew
Comment 4 Lukasz Goralczyk 2008-10-16 07:17:08 UTC
This may help temporarly (it worked for me as well some other person): . The solution is to add one option to xorg.conf.