Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 239170 - gnome-extra/gnome-power-manager-2.24.0 requires a policykit policy to be usable
Summary: gnome-extra/gnome-power-manager-2.24.0 requires a policykit policy to be usable
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 249733 (view as bug list)
Depends on:
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-09-30 17:40 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2008-12-04 23:07 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
org.freedesktop.hal.power-management.policy (org.freedesktop.hal.power-management.policy,850 bytes, text/plain)
2008-09-30 17:46 UTC, Alexandre Rostovtsev (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-09-30 17:40:29 UTC
gnome-power-manager-2.24.0 with USE="policykit" does not install any kind of policy file. As a result, policykit prevents all users from suspending or hibernating the machine from any Gnome mechanism (it even prevents the GUI buttons/spinbox choices for suspend or hibernate from being shown).

The solution is to install a policy file. Gnome-power-manager uses non-Gnome policykit action IDs (e.g. "org.freedesktop.hal.power-management.suspend"), so I am not sure if the file should be installed by gnome-power-manager itself or from some sort of additional package (in case the same actions will be used by other desktops' power managers).

In any case, if USE="policykit", either gnome-power-manager or some pre/post dependency must install the appropriate policy file.
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-09-30 17:46:51 UTC
Created attachment 166852 [details]
org.freedesktop.hal.power-management.policy

Power management policy file. Copy this into /usr/share/PolicyKit/policy

This policy file allows the user with the active session to suspend/hibernate the machine (i.e. the expected behavior).
Comment 2 Gilles Dartiguelongue gentoo-dev 2008-09-30 22:54:57 UTC
before you report more of these, basically, nobody tested policykit seriously enough to get gnome 2.24 with it into the tree. There is a big mess in upstream pushing (gnome) it and causing _major_ regressions along these changes (like breaking shutdown capability) and we are more prone to fix these errors first than "solving" them by using something that is highly untested by ourselves.

@herd, what do you want to say about moving packages with pk use flag to the tree ?
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-10-01 14:53:41 UTC
(In reply to comment #2)
Policykit seems to work quite well here, as long as the correct policy files are actually installed (and as long as PolicyKit directories have the correct permissions, see bug 239231).
Comment 4 Maciej Piechotka 2008-12-03 21:01:23 UTC
*** Bug 249733 has been marked as a duplicate of this bug. ***
Comment 5 Gilles Dartiguelongue gentoo-dev 2008-12-04 23:07:35 UTC
fixed in overlay without a bump.