Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 239003 - gnome-extra/gnome-power-manager-2.24.0 fails to build
Summary: gnome-extra/gnome-power-manager-2.24.0 fails to build
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on: 238235
Blocks: gnome2.24
  Show dependency tree
 
Reported: 2008-09-29 07:02 UTC by Maciej Piechotka
Modified: 2008-10-07 13:41 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gnome-power-manager-2.24.0-build-log (gnome-power-manager-2.24.0-build-log,216.83 KB, text/plain)
2008-09-29 07:55 UTC, Alexandre Rostovtsev (RETIRED)
Details
0001-Fixed-gnome-power-manager-2.24.0-docbook2man-issues.patch (0001-Fixed-gnome-power-manager-2.24.0-docbook2man-issues.patch,2.56 KB, patch)
2008-10-01 23:55 UTC, Maciej Piechotka
Details | Diff
0001-Fixed-gnome-power-manager-2.24.0-docbook2man-issues.patch (0001-Fixed-gnome-power-manager-2.24.0-docbook2man-issues.patch,1.40 KB, patch)
2008-10-02 08:30 UTC, Maciej Piechotka
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2008-09-29 07:02:39 UTC
gnome-extra/gnome-power-manager-2.24.0 fails to build

Reproducible: Always




Portage 2.2_rc11 (default/linux/x86/2008.0/developer, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.27-rc5-zen2 i686)
=================================================================
System uname: Linux-2.6.27-rc5-zen2-i686-Intel-R-_Celeron-R-_M_processor_1.50GHz-with-glibc2.0
Timestamp of tree: Mon, 29 Sep 2008 02:01:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-Os -march=pentium-m -mfpmath=sse -pipe -momit-leaf-frame-pointer -ggdb -w -ftree-vectorize -ftree-loop-optimize -freorder-blocks-and-partition -fgcse-sm -fgcse-las -fgcse-after-reload -ftracer -maccumulate-outgoing-args -fvisibility-inlines-hidden"
DISTDIR="/var/tmp/distfiles"
FEATURES="ccache collision-protect cvs digest distlocks multilib-strict parallel-fetch prelink preserve-libs protect-owned sandbox sfperms sign splitdebug stricter unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--add-needed -Wl,--as-needed -Wl,--hash-style=both -Wl,--sort-common"
LINGUAS="en_GB en_US pl"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/java-overlay /usr/portage/local/layman/vala-overlay /usr/portage/local/layman/gnome /usr/portage/local/layman/banshee-overlay /usr/portage/local/layman/x11 /usr/portage/local/layman/zen-overlay /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa applet attr avahi avalon bash-completion berkdb bittorrent boo browseplugin bzip2 c++ cairo calendar caps cddb cdparanoia cdr cli clisp context cracklib crypt cups curl curlwrappers cxx d daap dbus deskbar devhelp disk-partition djvu docbook dri dvd dvdnav dvdr dvdread eclipse eds emacs emboss encode eog epiphany esd evo evolution exif expat extra fam ffmpeg flac flash fortran fuse galago gconf gd gdbm gdl gedit gif gimp git glib glut gmail gmp gnome gnome-keyring gnutls gpm gsf gstreamer gtk guile hal iconv idle imap inherit-graph inotify ipod iproute2 ipv6 isdnlog jabber java java5 java6 jingle jpeg jpeg2k jython kerberos keyring kqemu laptop latex libburn libffi libgda libnotify libsexy logrotate lucene mad maildir mailwrapper mhash midi mikmod mmap mmx mono moonlight mozilla mp3 mpeg mudflap mule musicbrainz nautilus ncurses network networkmanager nls nntp no-old-linux nptl nptlonly nsplugin ntpl ogg oggvorbis openal opengl openmp pam pango pbm pccts pch pcre pda pdf perl png policykit pop postgres ppds pppd pulseaudio python qt3support quicktime raw readline reflection regex reiserfs resolvconf rhino ruby samba scanner science sdl session snmp soap soup sourceview spell spl sqlite sqlite3 sse sse2 ssh ssl startup-notification subversion svg symlink sysfs syslog tcpd tetex theora threads threadsafe tiff timidity totem tracker trayicon truetype unicode usb valgrind vim vorbis vte wifi win32codecs wxwindows x86 xattr xcb xforms xhtml xml xml2 xorg xsl xslt xulrunner xv zeroconf zlib" ALSA_CARDS="atiixp" ALSA_PCM_PLUGINS="null empty dmix dshare ioplug" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="panasonic" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en_US pl" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-09-29 07:54:14 UTC
I can confirm the build failure.

# USE="X doc policykit" emerge gnome-power-manager
[...]
Making all in man
make[2]: Entering directory `/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man'
docbook2man gnome-power-manager.sgml > gnome-power-manager.1
docbook2man gnome-power-statistics.sgml > gnome-power-statistics.1
docbook2man gnome-power-preferences.sgml > gnome-power-preferences.1
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-statistics.sgml:1:59:W: cannot generate system identifier for public text "-//OASIS//DTD DocBook V4.1//EN"
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-statistics.sgml:34:0:E: reference to entity "REFENTRY" for which no system identifier could be generated
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-statistics.sgml:1:0: entity was defined here
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-statistics.sgml:34:0:E: DTD did not contain element declaration for document type name
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-statistics.sgml:36:9:E: element "REFENTRY" undefined
[...]
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-preferences.sgml:114:9:E: element "PARA" undefined
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-preferences.sgml:114:63:E: element "EMAIL" undefined
nsgmls:/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man/gnome-power-preferences.sgml:115:22:E: element "PRODUCTNAME" undefined
make[2]: *** [gnome-power-manager.1] Error 8
make[2]: *** Waiting for unfinished jobs....
make[2]: *** [gnome-power-statistics.1] Error 8
make[2]: *** [gnome-power-preferences.1] Error 8
make[2]: Leaving directory `/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0/man'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-extra/gnome-power-manager-2.24.0/work/gnome-power-manager-2.24.0'
make: *** [all] Error 2
 * 
 * ERROR: gnome-extra/gnome-power-manager-2.24.0 failed.

Note that the same error occurs even when USE=-doc
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-09-29 07:55:40 UTC
Created attachment 166740 [details]
gnome-power-manager-2.24.0-build-log

The complete build log
Comment 3 Gilles Dartiguelongue gentoo-dev 2008-09-29 08:43:27 UTC
please report upstream and paste the url in the URL field, thanks.
Comment 4 Pacho Ramos gentoo-dev 2008-09-29 08:59:40 UTC
Maybe I am wrong but, I dubt it's safe use as much CFLAGS as you seem to be using, Have you tried with less CFLAGS? Something like "-Os -march=pentium-m -pipe"
Comment 5 Rémi Cardona gentoo-dev 2008-09-29 09:28:59 UTC
(In reply to comment #4)
> Maybe I am wrong but, I dubt it's safe use as much CFLAGS as you seem to be
> using, Have you tried with less CFLAGS? Something like "-Os -march=pentium-m
> -pipe"

Pacho, before you start spreading wrong information, -Os *breaks* applications and some libraries (including gtk+ itself), you should *not* be using it.

Thanks
Comment 6 Pacho Ramos gentoo-dev 2008-09-29 09:48:04 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Maybe I am wrong but, I dubt it's safe use as much CFLAGS as you seem to be
> > using, Have you tried with less CFLAGS? Something like "-Os -march=pentium-m
> > -pipe"
> 
> Pacho, before you start spreading wrong information, -Os *breaks* applications
> and some libraries (including gtk+ itself), you should *not* be using it.
> 
> Thanks
> 

I posted -Os simply because reporter was using it (maybe because it prefers it for any reason). But, thanks for the recommendation :-)

Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2008-09-29 13:50:30 UTC
Please mark this as "depends on bug 238235". 

CFLAGS has nothing to do with this; this is a docbook script failure.

After peppering the scripts that comprise the bizarre docbook build system with echo's, I've figured out a cause: line 16 in /usr/share/sgml/docbook/utils-0.6.14/frontends/docbook : "grep -i '<!DOCTYPE' "

Now, you may ask, what could possibly be wrong with that line? Well, it turns out, the developers of grep-2.5.3 in their infinite wisdom *broke the -i switch*. WTF?

Downgrading to grep-2.5.1a-r1 makes gnome-power-manager-2.24.0 compile once again.
Comment 8 Mart Raudsepp gentoo-dev 2008-09-30 08:19:12 UTC
That grep should be bloody masked or fixed I think. Some other things broke too, ask omp :P
base-system@, what say you?

Note to others about gnome-power-manager - I'd like to forward port CPU freq UI before putting it to portage, because otherwise people are loosing their gconf saved settings on frequency due to schemas loosing the entries, and we should want the freq UI to be back because ondemand sucks in too many cases still
Comment 9 Maciej Piechotka 2008-10-01 23:55:32 UTC
Created attachment 166946 [details, diff]
0001-Fixed-gnome-power-manager-2.24.0-docbook2man-issues.patch

The patch for overlay fixing this issue - at least for me.

It is also in: git://github.com/uzytkownik/gnome-overlay.git - however as multiply commits.
Comment 10 Rémi Cardona gentoo-dev 2008-10-02 07:22:10 UTC
It looks like the old sed line is failing because it was working on Makefile.am and not Makefile.in.

Could you try with that instead? If it works, it'd save an eautoreconf call :)

Thanks
Comment 11 Maciej Piechotka 2008-10-02 08:30:30 UTC
Created attachment 166967 [details, diff]
0001-Fixed-gnome-power-manager-2.24.0-docbook2man-issues.patch

The second patch
Comment 12 Rémi Cardona gentoo-dev 2008-10-07 13:41:45 UTC
Fixed in overlay, I've also removed some lines which seemed like left-overs from older versions.

Thanks