Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 237953 - app-admin/fam fails to build NULL not declared in this scope
Summary: app-admin/fam fails to build NULL not declared in this scope
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL: http://oss.sgi.com/projects/fam/
Whiteboard:
Keywords:
: 148772 246738 (view as bug list)
Depends on:
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2008-09-17 18:53 UTC by robs
Modified: 2008-12-05 00:35 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
removes all NULLs (fam-2.7.0-gcc43-null.patch,1.95 KB, text/plain)
2008-09-17 18:55 UTC, robs
Details
fam-2.7.0-sucks-but-we-love-it.patch (fam-2.7.0-sucks-but-we-love-it.patch,686 bytes, patch)
2008-12-04 23:53 UTC, Ryan Hill (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description robs 2008-09-17 18:53:48 UTC
fam fails with a error:
Interest.h:84: error: 'NULL' was not declared in this scope

one can either include the proper headers or remove all NULLs.
Comment 1 robs 2008-09-17 18:55:28 UTC
Created attachment 165667 [details]
removes all NULLs
Comment 2 Jeroen Roovers gentoo-dev 2008-09-17 19:00:17 UTC
Which version are you speaking of?
Comment 3 Jeroen Roovers gentoo-dev 2008-09-17 19:00:37 UTC
# ChangeLog for app-admin/fam
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/ChangeLog,v 1.50 2008/05/09 01:41:10 halcy0n Exp $

  09 May 2008; Mark Loeser <halcy0n@gentoo.org>
  +files/fam-2.7.0-gcc43.patch, fam-2.7.0-r4.ebuild:
  Patch to fix building with gcc-4.3 by Martin Väth <vaeth AT
  mathematik.uni-wuerzburg DOT de>; bug #215475
Comment 4 robs 2008-09-17 19:08:53 UTC
i'm speaking of fam-2.7.0-r4

i saw there is a patch for gcc 4.3
but in my case there are still files with undefined NULLs.
Comment 5 robs 2008-09-17 19:13:40 UTC
well i guess including the proper headers would be better. why are there so many C headers? :)
Comment 6 Nils Larsson 2008-09-17 19:53:01 UTC
Last release of app-admin/fam was November 11, 2003. why isn't this phased out?

Isn't app-admin/gamin enough?
Comment 7 Harald Höglinger 2008-09-29 11:50:46 UTC
I have the same bug using gcc-4.3.1

I need fam instead of gamin because auf maya2008.
Comment 8 Luca Lesinigo 2008-11-16 22:41:26 UTC
Gentoo 2008.0 on HPPA with glibc-2.7-r2:

app-admin/fam-2.7.0-r4 emerges and runs ok on my gentoo 2008.0 on HPPA:
 * glibc-2.7-r2
 * both gcc-4.2.4 and gcc-4.3.2 tested
 * CFLAGS=CXXFLAGS="-O2 -pipe -march=2.0"
 * MAKEOPTS="-j3"
 * FEATURES="test userpriv -usersandbox"

hope this helps.
Comment 9 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-27 16:18:56 UTC
*** Bug 246738 has been marked as a duplicate of this bug. ***
Comment 10 Diego Elio Pettenò (RETIRED) gentoo-dev 2008-11-27 16:20:46 UTC
The replacement should at least be 0L rather than just 0, but I would ask for Treecleaners to consider killing this off.

While fam probably supports some non-Linux non-FreeBSD systems better than gamin, it cannot be worse, and gamin is actually being developed, thus..
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-02 05:55:57 UTC
We already went through all this on bug 197757.

If someone wants to pursue phasing out fam, then they need to check out everything that depends on virtual/fam, etc.

Until then, this bug is pretty stalled. Especially with comment #4 and comment #8 contradicting eachother. I don't have a preference either way, really so...up for vote (again).

(In reply to comment #7)
> I have the same bug using gcc-4.3.1
> 
> I need fam instead of gamin because auf maya2008.
> 

Since at least one person needs fam, I vote for fix over removal.
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-12-04 22:57:51 UTC
*** Bug 148772 has been marked as a duplicate of this bug. ***
Comment 13 Ryan Hill (RETIRED) gentoo-dev 2008-12-04 23:53:56 UTC
Created attachment 174287 [details, diff]
fam-2.7.0-sucks-but-we-love-it.patch
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2008-12-04 23:58:18 UTC
Fixinated.