Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 237852 - enlightenment.eclass CVS -> SVN switch
Summary: enlightenment.eclass CVS -> SVN switch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: SpanKY
URL:
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks:
 
Reported: 2008-09-16 17:26 UTC by Thomas Kuther
Modified: 2008-09-20 20:35 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
enlightenment.eclass.patch (enlightenment.eclass.patch,3.75 KB, patch)
2008-09-16 17:30 UTC, Thomas Kuther
Details | Diff
enlightenment.eclass.patch (enlightenment.eclass.patch,3.80 KB, patch)
2008-09-16 20:17 UTC, Thomas Kuther
Details | Diff
enlightenment.eclass with both SVN and CVS support diff. (enlightenment.eclass.diff,5.05 KB, patch)
2008-09-19 19:28 UTC, Andrian Nord
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Kuther 2008-09-16 17:26:30 UTC
The Enlightenment project switched from CVS to SVN.
Therefor the enlightenment.eclass in portage needs to be updated to use SVN.

Reproducible: Always

Steps to Reproduce:
1. layman -a enlightenment
2. emerge e (-9999 versions)


Actual Results:  
Tries to pull from non-existant CVS repo

Expected Results:  
Should pull from new SVN
Comment 1 Thomas Kuther 2008-09-16 17:30:37 UTC
Created attachment 165570 [details, diff]
enlightenment.eclass.patch

Proposed patch.

Works for me, if any ECVS_MODULE definitions are removed from the e_modules-* ebuilds in the overlay.

Lot of of things got moved around in SVN though, so the ebuilds in the overlay need more fixing. Snapshots and the ebuilds in portage should be fine though.
Comment 2 Thomas Kuther 2008-09-16 20:17:02 UTC
Created attachment 165585 [details, diff]
enlightenment.eclass.patch

I broke the E17_ESVN_REPO_URI override (ex E17_ECVS_SERVER). Fixed patch.
Not sure if this is still needed/makes sense at all.
Comment 3 Dustin Howett 2008-09-18 08:23:04 UTC
I modified the ebuilds and eclass some time ago and sent an e-mail with the diffs to he who I thought was the maintainer... never got a reply.
Comment 4 Vadim Efimov 2008-09-18 15:17:17 UTC
(In reply to comment #3)
> I modified the ebuilds and eclass some time ago and sent an e-mail with the
> diffs to he who I thought was the maintainer... never got a reply.
> 

http://overlays.gentoo.org/dev/vapier/wiki/enlightenment

Helping Out

Since this is an overlay, you need not be a Gentoo developer to help out. You just need to not suck. If you think you do not suck and you'd like to help, please drop me a line Mike Frysinger with your overlay username.

Comment 5 Andrian Nord 2008-09-18 16:09:36 UTC
I checked all ebuilds to make them match new source tree structure, and also made a few modifications in eclass to make it svn-compatible. Only problem, which makes it non-ready for end-user - is broken CVS-compatibility, which brokes a few CVS-hosted external projects, which was served with enlightenment.eclass before. You can browse and checkout my overlay (svn) freely:

https://ufo.evadim.ru/enlightenment

(thanks to Vadim Efimof for domain name, I don't have any yet)
Comment 6 Andrian Nord 2008-09-18 18:08:58 UTC
Now both CVS and SVN repositories supported. Ebuild changes still needed.
Comment 7 Mikhail Nagorny 2008-09-19 04:58:14 UTC
(In reply to comment #6)
> Now both CVS and SVN repositories supported. Ebuild changes still needed.
> 

Great job guys!
I renewed recently. There were no any issues during compiling.
8 month's bug has been corrected - battery module.
Since it's not vapier overlay, we could put where any missed modules and applications. 
Comment 8 Andrian Nord 2008-09-19 13:42:11 UTC
This is not a really good idea - to clone repository, if you mean this. This is only a temporary workplace, when it will be good enough, we plan to contact vapier (aka SpanKY) for syncing it with main overlay. Of course, if you have any ebuilds (or just any info) for missing packages - any help are welcome.

While all packages are _fetching_ successfully, we not test their's compilation. All tree must be reviewed and some stuff, like evidence, which e17 support are completelly broken, must be removed,
Comment 9 Thomas Kuther 2008-09-19 15:42:06 UTC
If you guys have a better/more mature/smarter eclass than the one above, you should attach the patch to the original here.

Linking to external repos is somehwhat disliked IIRC.
Comment 10 Andrian Nord 2008-09-19 17:20:07 UTC
I wish I could, but this is useless. Our eclass need changes in all ebuilds. I could produce a patch for all overlay, but it will be quite big
Comment 11 Thomas Kuther 2008-09-19 18:16:50 UTC
(In reply to comment #10)
> I wish I could, but this is useless. Our eclass need changes in all ebuilds. I
> could produce a patch for all overlay, but it will be quite big
> 

Sounds complicated. Mine only needs changes for e_modules-* (just remove ECVS_MODULE statements) and things that got moved in SVN, like for example epeg:

MY_PN="OLD/${PN}
inherit enlightenment

That's it.

No idea what's the point to support both, CVS and SVN, as stuff that is not part of the enlightenment project and its SVN repo, doesn't really need to use enlightenment.eclass - see itask-ng/winlist-ng ebuilds in the overlay.. 

Just use standard cvs.eclass there.. *shrug*
Comment 12 Andrian Nord 2008-09-19 18:53:56 UTC
Yeah. That's right. But you need to do this changes in every ebuild.
Also - eclass with CVS support is better that eclass without it (If this support do not require too much code complification, of course), some things still use CVS and some may be added in future.
Comment 13 Andrian Nord 2008-09-19 19:28:31 UTC
Created attachment 165867 [details, diff]
enlightenment.eclass with both SVN and CVS support diff.

Requested diff
Comment 14 Thomas Kuther 2008-09-20 05:30:44 UTC
Thanks!

Could you give an example of an ebuild that still uses (enlightenment) CVS, as I fail to find one.
Comment 15 Andrian Nord 2008-09-20 12:14:37 UTC
For now - only app-misc/evidence =). But, even it will be deleted (due to completelly broken e17 support), there is chance that some other CVS modules will be included later (or already included in some other overlays). We was acting in way of providing full backward-compatibility, to make sure, that any changes in eclass will not break anything (exept overlays packets). Later, maybe, CVS support will be deleted.
Comment 16 SpanKY gentoo-dev 2008-09-20 20:35:27 UTC
should be fixed in cvs now

http://sources.gentoo.org/eclass/enlightenment.eclass?r1=1.72&r2=1.73