Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 237202 - TeXLive 2008 keywording
Summary: TeXLive 2008 keywording
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: TeX project
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 241380 (view as bug list)
Depends on: 171441 229217 229249 239472
Blocks:
  Show dependency tree
 
Reported: 2008-09-09 17:00 UTC by Alexis Ballier
Modified: 2009-01-03 01:33 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexis Ballier gentoo-dev 2008-09-09 17:00:55 UTC
Hi all, 
TeX Live 2008 will need some keywording love; new release, new programs, some cleanup. Only amd64 and fbsd are good wrt keywording as I took care of them.

Mandatory:

alpha: 

dev-tex/luatex dev-texlive/texlive-documentation-slovenian
'>=dev-tex/europecv-20060424-r1', '>=dev-tex/currvita-0.9i-r1', '>=dev-tex/envlab-1.2-r1', '>=dev-tex/leaflet-20041222', 'dev-tex/glossaries', '>=app-text/vlna-1.3', 'dev-tex/dvi2tty', '>=dev-tex/mh-20080903', '>=dev-tex/svninfo-0.7.3-r1', 'app-text/passivetex'

hppa: 
dev-tex/luatex dev-texlive/texlive-documentation-slovenian
'>=dev-tex/europecv-20060424-r1', '>=app-text/vlna-1.3', '>=dev-tex/currvita-0.9i-r1', '>=dev-tex/envlab-1.2-r1', '>=dev-tex/leaflet-20041222', '>=dev-tex/svninfo-0.7.3-r1', 'app-text/xindy', 'dev-tex/glossaries', '>=dev-tex/xmltex-1.9-r2', 'dev-tex/dvi2tty', '>=dev-tex/mh-20080903', '>=dev-tex/g-brief-4.0.2', 'app-text/passivetex'

ia64: 
dev-tex/luatex dev-texlive/texlive-documentation-slovenian
'>=dev-tex/europecv-20060424-r1', '>=app-text/vlna-1.3', '>=dev-tex/currvita-0.9i-r1', '>=dev-tex/envlab-1.2-r1', '>=dev-tex/leaflet-20041222', '>=dev-tex/svninfo-0.7.3-r1', 'dev-tex/glossaries', '>=dev-tex/xmltex-1.9-r2', 'dev-tex/dvi2tty', '>=dev-tex/mh-20080903', '>=dev-tex/g-brief-4.0.2', 'app-text/passivetex'


ppc: 
dev-tex/luatex dev-texlive/texlive-documentation-slovenian
'>=dev-tex/envlab-1.2-r1', '>=dev-tex/leaflet-20041222', 'app-text/xindy', 'dev-tex/glossaries', 'dev-tex/translator', '>=app-text/vlna-1.3', '>=dev-tex/mh-20080903', '>=dev-tex/svninfo-0.7.3-r1', 'app-text/passivetex'

ppc64: 
dev-tex/luatex dev-texlive/texlive-documentation-slovenian
'>=dev-tex/europecv-20060424-r1', '>=app-text/vlna-1.3', '>=dev-tex/currvita-0.9i-r1', '>=dev-tex/envlab-1.2-r1', '>=dev-tex/leaflet-20041222', '>=dev-tex/svninfo-0.7.3-r1', 'app-text/xindy', 'dev-tex/glossaries', '>=dev-tex/xmltex-1.9-r2', 'dev-tex/dvi2tty', '>=dev-tex/mh-20080903', '>=dev-tex/g-brief-4.0.2', 'app-text/passivetex'

sparc: 
dev-tex/luatex dev-texlive/texlive-documentation-slovenian
'>=dev-tex/europecv-20060424-r1', '>=dev-tex/currvita-0.9i-r1', 'app-text/xindy', 'dev-tex/glossaries', '>=app-text/vlna-1.3', 'dev-tex/dvi2tty', '>=dev-tex/svninfo-0.7.3-r1'


x86: 
dev-tex/luatex dev-texlive/texlive-documentation-slovenian

Highly recommended:
app-admin/eselect-mpost (you'll have to keyword mplib for luatex anyway)

Recommended:
dev-tex/pdftex
app-admin/eselect-pdftex
See bug #198236

As always, it's a huge thing, I expect some bugs to show up, so don't hesitate to ask if something seems weird. If you spot collisions, please shout. Most or all of them should have proper blockers and portage will chose a sane upgrade path.


Additional notes:
I was tempted to just put in ~arch texlive-documentation-slovenian for all of you; but eventually I strictly followed policy: it only installs the slovenian version of "The Not So Short Introduction to LATEX 2ε"

I didn't want to drop your keywords for all the other dev-texlive ebuilds but it is not really possible to not update everything at once. tl2008 is currently p.masked so that some testing can happen, when it'll be time to unmask it and if some of you haven't had time yet to keyword those packages, I'll move the mask to your respective profiles.

Don't forget to update your /etc/texmf config files if you're upgrading from 2007: some memory sizes defaults have been bumped and it's required in some cases.

xindy: see bug #229217

luatex: some examples here: http://luatex.bluwiki.com/
Comment 1 Alexis Ballier gentoo-dev 2008-09-09 19:09:00 UTC
Two things I forgot to mention:
- It should be safe to use mask xindy for app-text/texlive if you can't get it (or clisp) to build.
- If ppc64 or x86 team needs some help for some testing/keywording, I can give a hand.
Comment 2 Ferris McCormick (RETIRED) gentoo-dev 2008-09-10 13:56:11 UTC
Sparc cannot do dev-tex/luatex because it depends on zziplib.  However, zziplib fails on sparc --- data alignment problems (Bus error) --- I'll investigate as time permits.  Please see Bug 171441 for history.
Comment 3 Markus Meier gentoo-dev 2008-09-11 21:05:01 UTC
x86 should be done.
Comment 4 Brent Baude (RETIRED) gentoo-dev 2008-09-20 17:13:42 UTC
What is this trying to tell me?

>>> Emerging (1 of 2) dev-tex/mh-20080903 to /
 * mh-20080903.zip RMD160 SHA1 SHA256 size ;-) ...                                                                                      [ ok ]
>>> Creating Manifest for /usr/portage/dev-tex/mh
  digest.assumed                 1
   digest-mh-20080407::mh-20080407.zip
 * checking ebuild checksums ;-) ...                                                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                  [ ok ]
 * checking mh-20080903.zip ;-) ...                                                                                                     [ ok ]
>>> Unpacking source...
>>> Unpacking mh-20080903.zip to /var/tmp/portage/dev-tex/mh-20080903/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-tex/mh-20080903/work/mh ...
This is TeX, Version 3.1415926 (Web2C 7.5.7)
---! //var/lib/texmf/web2c/tex.fmt doesn't match tex.pool
(Fatal format file error; I'm stymied)
Comment 5 Alexis Ballier gentoo-dev 2008-09-20 17:17:53 UTC
(In reply to comment #4)

> ---! //var/lib/texmf/web2c/tex.fmt doesn't match tex.pool

http://www.gentoo.org/proj/en/tex/texlive-migration-guide.xml#doc_chap4 ?

$ locate '/tex.fmt'
/var/lib/texmf/web2c/tex/tex.fmt


I don't have /var/lib/texmf/web2c/tex.fmt here, its probably remaining from an old (tetex?) install.
Comment 6 Brent Baude (RETIRED) gentoo-dev 2008-09-21 13:22:18 UTC
ppc64 done I think,. re-add if I missed something
Comment 7 Alexis Ballier gentoo-dev 2008-09-22 09:15:20 UTC
(In reply to comment #6)
> ppc64 done I think,. re-add if I missed something

seems you missed xindy; when I tried it on ppc64 I couldn't build clisp, maybe it would make sense to use.mask it.
Comment 8 Ferris McCormick (RETIRED) gentoo-dev 2008-09-22 16:54:31 UTC
I've taken care of the optional packages for sparc as best I can.  But texlive-core-2008 will never install until the luatex problem is resolved.  As I mentioned above, upstream has a problem regarding zziplib (they are using unaligned data in zip.c, I believe), and until that is resolved, or unless luatex can learn to live without zziplib, we are not going to be able to build texlive-core-2008 for sparc.

I'm looking at the zziplib problem and a couple other options, but this is really zziplib's problem to fix.
Comment 9 Raúl Porcel (RETIRED) gentoo-dev 2008-09-24 18:47:59 UTC
~alpha/~ia64 done
Comment 10 Alexis Ballier gentoo-dev 2008-10-03 17:25:34 UTC
So it's probably time to move the mask to the profiles now; here is what i'm gonna do:

Move the entire mask to hppa/ppc profiles (still no answer from them); and also to sparc profiles (sadly luatex is critical in this release and will probably be even more in the future, if zziplib is really not an option, we could have a look at making it optional (not sure at all it is even possible) and it's already so painful to build luatex correctly, killing a bunch of bundled libs). That way you'll just have to remove the mask when everything will be fine.

Mask xindy useflag on ppc64/bsd profiles.
Comment 11 Brent Baude (RETIRED) gentoo-dev 2008-10-03 18:27:03 UTC
I'll commit the ppc64 xindy mask today and will get the ppc keywords rolling...gimmie until EOD US time ok?
Comment 12 Ferris McCormick (RETIRED) gentoo-dev 2008-10-03 18:30:14 UTC
(In reply to comment #10)
> So it's probably time to move the mask to the profiles now; here is what i'm
> gonna do:
> 
> Move the entire mask to hppa/ppc profiles (still no answer from them); and also
> to sparc profiles (sadly luatex is critical in this release and will probably
> be even more in the future, if zziplib is really not an option, we could have a
> look at making it optional (not sure at all it is even possible) and it's
> already so painful to build luatex correctly, killing a bunch of bundled libs).
> That way you'll just have to remove the mask when everything will be fine.
> 
> Mask xindy useflag on ppc64/bsd profiles.
> 

There is a chance that luatex will work with zziplib as it is.  I think the failure is coming in the main program itself and not from the library.  I just haven't verified it yet.
Comment 13 Brent Baude (RETIRED) gentoo-dev 2008-10-04 01:55:48 UTC
@alexis - mind checking my work for ppc and ppc64?  I think I have gotten everything now and I also should have gotten xindy for ppc64 64UL masked.
Comment 14 Alexis Ballier gentoo-dev 2008-10-04 08:19:04 UTC
(In reply to comment #13)
> @alexis - mind checking my work for ppc and ppc64?  I think I have gotten
> everything now and I also should have gotten xindy for ppc64 64UL masked.

seems good as far as I can tell; thanks. Everything is referenced from app-text/texlive meta ebuild and repoman --without-mask is happy for ppc* :)

Just a small remark: xindy is a local useflag for app-text/texlive, so maybe it's better to p.use.mask it instead of the global use.mask.
Comment 15 Jeroen Roovers gentoo-dev 2008-10-04 13:29:34 UTC
HPPA should be OK without the mask. If not, mr_bones will come round to visit shortly.
Comment 16 Alexis Ballier gentoo-dev 2008-10-04 14:03:03 UTC
(In reply to comment #15)
> HPPA should be OK without the mask. If not, mr_bones will come round to visit
> shortly.

unless i'm missing something, it's definitely not ok:

app-text/texlive/texlive-2008.ebuild: ~hppa(default/linux/hppa/2008.0) ['>=dev-tex/europecv-20060424-r1', '>=app-text/vlna-1.3', '>=dev-tex/currvita-0.9i-r1', '>=dev-tex/envlab-1.2-r1', '>=dev-tex/leaflet-20041222', 'dev-tex/luatex', '>=dev-tex/svninfo-0.7.3-r1', '>=dev-texlive/texlive-documentation-slovenian-2008', 'dev-tex/glossaries', '>=dev-tex/xmltex-1.9-r2', 'dev-tex/dvi2tty', '>=dev-tex/mh-20080903', '>=dev-tex/g-brief-4.0.2', 'app-text/passivetex']
Comment 17 Jeroen Roovers gentoo-dev 2008-10-04 15:05:58 UTC
I'll get to work on it then. :)
Comment 18 Jeroen Roovers gentoo-dev 2008-10-06 04:47:26 UTC
  ebuild.minorsyn               1
   app-text/passivetex/passivetex-1.25.ebuild: Useless dodoc 'LICENSE' on line: 31
Comment 19 Jeroen Roovers gentoo-dev 2008-10-06 04:52:00 UTC
Maybe now...
Comment 20 Alexis Ballier gentoo-dev 2008-10-06 08:16:41 UTC
Good; thanks everyone, so now it's unmasked

I've move the mask to sparc profiles, files touched are:
profiles/default-linux/sparc/package.mask
profiles/arch/sparc/package.mask


Removing ppc/ppc64 from cc as they should be fine now (apart the nitpick about use.mask and p.use.mask)
Comment 21 Giampier 2008-10-12 09:41:31 UTC
*** Bug 241380 has been marked as a duplicate of this bug. ***
Comment 22 Ferris McCormick (RETIRED) gentoo-dev 2008-11-18 15:33:32 UTC
luatex-0.30.2 now keyworded for ~sparc, thanks to Friedrich Oslage (bluebird)'s help with zziplib.
Comment 23 Ferris McCormick (RETIRED) gentoo-dev 2008-11-18 17:35:18 UTC
As best as I can determine so far, sparc can be unmasked now.  Would you like to do it?
Comment 24 Alexis Ballier gentoo-dev 2008-11-18 17:39:21 UTC
(In reply to comment #23)
> As best as I can determine so far, sparc can be unmasked now.  Would you like
> to do it?


please do it; i'm at the univ atm and when i left home i had network issues where i have all the gentoo-x86 access stuff
Comment 25 Ferris McCormick (RETIRED) gentoo-dev 2008-11-18 19:34:33 UTC
I have unmasked texlive-2008 for sparc.  I am not closing the bug and I am leaving sparc in the CC list in case something unexpected comes up that requires remasking.  I don't anticipate anything.  (Unless I unmasked too much or too little.)
Comment 26 Ferris McCormick (RETIRED) gentoo-dev 2008-11-19 00:50:45 UTC
Sparc is done:
===============
polylepis texlive # genlop texlive
 * app-text/texlive

     Wed Oct 31 22:54:28 2007 >>> app-text/texlive-2007
     Tue Nov  6 23:40:12 2007 >>> app-text/texlive-2007-r1
     Sat Nov 10 13:50:41 2007 >>> app-text/texlive-2007-r2
     Sun Nov 11 15:13:58 2007 >>> app-text/texlive-2007-r3
     Wed Nov 19 00:13:43 2008 >>> app-text/texlive-2008
================

And a quick check shows that latex & xelatex both work as expected.  I'll leave it to Alexis to close or leave open as a tracker.
Comment 27 Alexis Ballier gentoo-dev 2008-11-20 10:10:13 UTC
(In reply to comment #26)
> Sparc is done:
> ===============
> polylepis texlive # genlop texlive
>  * app-text/texlive
> 
>      Wed Oct 31 22:54:28 2007 >>> app-text/texlive-2007
>      Tue Nov  6 23:40:12 2007 >>> app-text/texlive-2007-r1
>      Sat Nov 10 13:50:41 2007 >>> app-text/texlive-2007-r2
>      Sun Nov 11 15:13:58 2007 >>> app-text/texlive-2007-r3
>      Wed Nov 19 00:13:43 2008 >>> app-text/texlive-2008
> ================
> 
> And a quick check shows that latex & xelatex both work as expected.  I'll leave
> it to Alexis to close or leave open as a tracker.

thanks, i think we can close it now then

just a small note: imho you can remove all the mask entries from your profiles in order to keep them small instead of keeping them as comments
Comment 28 Ferris McCormick (RETIRED) gentoo-dev 2008-11-20 14:18:48 UTC
(In reply to comment #27)
> (In reply to comment #26)
> > Sparc is done:
> > ===============
> > polylepis texlive # genlop texlive
> >  * app-text/texlive
> > 
> >      Wed Oct 31 22:54:28 2007 >>> app-text/texlive-2007
> >      Tue Nov  6 23:40:12 2007 >>> app-text/texlive-2007-r1
> >      Sat Nov 10 13:50:41 2007 >>> app-text/texlive-2007-r2
> >      Sun Nov 11 15:13:58 2007 >>> app-text/texlive-2007-r3
> >      Wed Nov 19 00:13:43 2008 >>> app-text/texlive-2008
> > ================
> > 
> > And a quick check shows that latex & xelatex both work as expected.  I'll leave
> > it to Alexis to close or leave open as a tracker.
> 
> thanks, i think we can close it now then
> 
> just a small note: imho you can remove all the mask entries from your profiles
> in order to keep them small instead of keeping them as comments
> 

I kept the comments more as an aid to myself so that I would know what I had unmasked in case any problem turned up.  I'll remove them in a day or so.
Comment 29 Alexis Ballier gentoo-dev 2009-01-02 16:26:44 UTC
crap, it seems i haven't run repoman in there for a while:

  RDEPEND.bad                   4
   app-text/texlive/texlive-2008.ebuild: ~sparc(default/linux/sparc/2008.0) ['>=dev-tex/europecv-20060424-r1']
Comment 30 Friedrich Oslage (RETIRED) gentoo-dev 2009-01-03 01:33:16 UTC
done, RepoMan is happy again :)