Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 236147 - USE='sqlite' emerge trac fails to install pysqlite as a dependency
Summary: USE='sqlite' emerge trac fails to install pysqlite as a dependency
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-29 20:26 UTC by H C
Modified: 2009-01-29 16:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description H C 2008-08-29 20:26:20 UTC
Emerging trac with sqlite use flag set doesn't automatically install pysqlite dependency.

Reproducible: Always

Steps to Reproduce:
1. Don't have pysqlite installed.
2. USE='sqlite' emerge -v trac

Actual Results:  
It fails to emerge trac because:
 
* To use the sqlite database backend, you must either:
 * - build dev-lang/python with sqlite support, using the 'sqlite'
 *   USE flag, or
 * - emerge dev-python/pysqlite

Expected Results:  
It should automatically know to pull pysqlite in as a dependency because of the USE flag set.

If you install pysqlite it will not complain, but to me it seems like this is a bug as it should be 'smart' enough to know to emerge pysqlite if it needs it.
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-08-29 21:52:11 UTC
It should, yes. Unfortunately Portage still doesn't feature use dependencies.

*** This bug has been marked as a duplicate of bug 155723 ***
Comment 2 Zac Medico gentoo-dev 2008-08-29 22:19:00 UTC
Well, we've got USE deps (bug 2272) but they're not yet available in a stable EAPI.
Comment 3 Zac Medico gentoo-dev 2008-08-29 22:19:33 UTC

*** This bug has been marked as a duplicate of bug 2272 ***