Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235732 - [2.6.26 regression] snd-hda-intel: audio input no longer works
Summary: [2.6.26 regression] snd-hda-intel: audio input no longer works
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: http://bugzilla.kernel.org/show_bug.c...
Whiteboard: linux-2.6.26-regression
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2008-08-25 23:25 UTC by Tommaso Pasini
Modified: 2008-12-17 14:01 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Kernel configuration for 2.6.26 (.config,42.94 KB, text/plain)
2008-08-25 23:26 UTC, Tommaso Pasini
Details
Configuration used with alsa-driver-1.0.18 (.config,41.88 KB, text/plain)
2008-11-09 14:23 UTC, Tommaso Pasini
Details
Configuration used with vanilla-sources-2.6.27.4 (.config,44.75 KB, text/plain)
2008-11-09 14:23 UTC, Tommaso Pasini
Details
alsa-info.sh output ran on a 2.6.25 (working) kernel (alsa-info_working.txt,17.41 KB, text/plain)
2008-11-20 00:08 UTC, Tommaso Pasini
Details
alsa-info.sh output ran on a 2.6.26 (not working) kernel (alsa-info_notworking.txt,16.92 KB, text/plain)
2008-11-20 00:08 UTC, Tommaso Pasini
Details
alsa-info.sh output ran on a 2.6.25 (working) kernel, modules (alsa-info_working-mod.txt,17.84 KB, text/plain)
2008-11-20 00:55 UTC, Tommaso Pasini
Details
alsa-info.sh output ran on a 2.6.26 (not working) kernel, modules (alsa-info_notworking-mod.txt,17.35 KB, text/plain)
2008-11-20 00:55 UTC, Tommaso Pasini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tommaso Pasini 2008-08-25 23:25:36 UTC
With the latest kernel the audio output works as always, but I'm unable to record anything, neither talk via skype. With 2.6.25 everything works flawlessly; until the problem is fixed I'm going back to using it. I tried to update all alsa-* packages to their latest unstable version, i tried to recompile the kernel starting from the working .25 configuration: still the problem persists, even after running alsaconf.

My sound card uses the hda-intel codec
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
	Subsystem: ASUSTeK Computer Inc. Device 1213
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at febfc000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [50] Power Management version 2
	Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
	Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
	Kernel driver in use: HDA Intel
	Kernel modules: snd-hda-intel

Here is my emerge --info, if it's needed

Portage 2.1.4.4 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.26-gentoo-r1 i686)
=================================================================
System uname: 2.6.26-gentoo-r1 i686 Genuine Intel(R) CPU T2400 @ 1.83GHz
Timestamp of tree: Mon, 25 Aug 2008 13:00:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r6
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -fforce-addr -mfpmath=sse"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer -fforce-addr -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://de-mirror.org/distro/gentoo/ http://de-mirror.org/distro/gentoo/ http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LANG="it_IT.utf8"
LC_ALL="it_IT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="it"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="bzip2"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa bash-completion berkdb bluetooth branding bzip2 cairo caps cddb cdparanoia cdr cli cracklib crypt dbus dri dv dvd dvdr dvdread emboss encode evo fam ffmpeg firefox flac fortran gdbm gif gnome gnome-keyring gstreamer gtk hal iconv isdnlog java jpeg jpeg2k lcms libnotify mad matroska midi mikmod mmap mmx mng mp3 mpeg musepack nautilus ncurses networkmanager nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp pam pcre pdf perl png ppds pppd python quicktime readline real reflection samba sdl session sndfile spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora threads tiff tracker truetype unicode usb vcd vorbis win32codecs wxwindows x86 xine xml xorg xv xvid xvmc zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

I'll attach my kernel configuration; if this bug is confirmed I think it should block the bug 232070.
Comment 1 Tommaso Pasini 2008-08-25 23:26:39 UTC
Created attachment 163785 [details]
Kernel configuration for 2.6.26
Comment 2 Jeroen Roovers gentoo-dev 2008-08-26 00:08:11 UTC
Did you try the ~arch kernel with ~arch version of alsa-{lib,utils} as well?
Comment 3 Tommaso Pasini 2008-08-26 08:48:08 UTC
Of course, =media-libs/alsa-lib-1.0.17-r1, =media-plugins/alsa-plugins-1.0.17-r1, =media-sound/alsa-headers-1.0.17, =media-sound/alsa-tools-1.0.17, =media-sound/alsa-utils-1.0.17.

Now I'm back on stable kernel and stable alsa packages, and the microphone is working correctly.
Comment 4 Alejandro Diaz Caro 2008-08-29 02:05:43 UTC
I have the same problem with kernel 2.6.25-gentoo-r7 compiled with genkernel and also with the compilation I'm using now done by me (I put snd-hda-intel inside the kernel).
====================================
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
        Subsystem: Hewlett-Packard Company Device 30d6
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0 (500ns min, 1250ns max)
        Interrupt: pin A routed to IRQ 21
        Region 0: Memory at fc480000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [44] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [50] Message Signalled Interrupts: Mask+ 64bit+ Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
                Masking: 00000000  Pending: 00000000
        Capabilities: [6c] HyperTransport: MSI Mapping Enable+ Fixed+
        Kernel driver in use: HDA Intel
====================================
ernestina ~ # emerge --info
Portage 2.1.4.4 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7-janus x86_64)
=================================================================
System uname: 2.6.25-gentoo-r7-janus x86_64 AMD Turion(tm) 64 X2 TL-60
Timestamp of tree: Thu, 28 Aug 2008 13:33:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.localhost.net.ar ftp://mirrors.localhost.net.ar/pub/mirrors/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/ ftp://ftp.las.ic.unicamp.br/pub/gentoo/"
LANG="es_AR.utf8"
LC_ALL="es_AR.utf8"
LDFLAGS="-Wl,-O1"
LINGUAS="es_AR es_ES es"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aac acl acpi alsa amd64 arts audiofile bash-completion berkdb bittorrent bluetooth branding bzip2 cairo cddb cdparanoia cdr cli cracklib crypt css cups dbus directfb djvu dri dvd dvdr dvdread emboss encode fbcon ffmpeg firefox flac flash foomaticdb fortran gdbm gif gimp gmail gphoto2 gpm gstreamer hal hddtemp iconv icq imagemagick imlib isdnlog jabber java6 javascript jpeg jpeg2k kde kdeenablefinal kerberos lame laptop latex ldap libnotify lm_sensors lzo mad midi mikmod mmx mng mp3 mpeg mplayer msn mudflap multilib ncurses networkmanager nforce2 nls nptl nptlonly nsplugin nvidia offensive ogg opengl openmp oss pam pcre pdf perl png postscript ppds pppd python qt3 qt3support quicktime readline reflection rss sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd tetex tiff truetype unicode usb v4l v4l2 vcd vim-syntax vnc vorbis wifi xml xorg xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es_AR es_ES es" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

====================================
media-sound/alsa-utils version 1.0.16 (USE: midi nls)
media-sound/alsa-headers version 1.0.16 
Comment 5 Emmanuel Lepage Vallee 2008-08-30 22:06:42 UTC
Same here, (kernel 2.6.26). I ear sound in my speaker from mic, but I can't record (tried audacity). I alsa cant use my tvcard (line in is broken too). It is a real problem for because I have to use this kernel, I just finisshed to write a kernel patch for my card and I dont want to port it back.
Comment 6 Tommaso Pasini 2008-10-24 12:51:31 UTC
Kernel 2.6.27 (2.6.27-gentoo-r1) show this bug, too.
Comment 7 Tommaso Pasini 2008-11-09 14:21:26 UTC
Still, nothing is working.

I tried vanilla-sources-2.6.27.4 to see if the bug was about genpatches, but it didn't work; I tried gentoo-sources-2.6.27-r2 without the in-kernel drivers, and I compiled alsa-driver-1.0.18, but, again, nothing.

I attach a few more informations, hoping that they may be helpful.

cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfebfc000 irq 16

cat /proc/asound/devices
  0: [ 0]   : control
  1:        : sequencer
  4: [ 0- 0]: hardware dependent
  5: [ 0- 1]: hardware dependent
 16: [ 0- 0]: digital audio playback
 17: [ 0- 1]: digital audio playback
 22: [ 0- 6]: digital audio playback
 24: [ 0- 0]: digital audio capture
 30: [ 0- 6]: digital audio capture
 33:        : timer

amixer scontents
Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 27 [87%] [-6.00dB] [on]
  Front Right: Playback 27 [87%] [-6.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 27 [87%] [6.00dB] [on]
  Front Right: Playback 27 [87%] [6.00dB] [on]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [on]
  Front Left: Playback 27 [87%] [6.00dB] [on]
  Front Right: Playback 27 [87%] [6.00dB] [on]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 2 [67%]
  Front Right: 2 [67%]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 15
  Front Left: Capture 13 [87%] [19.50dB] [on]
  Front Right: Capture 13 [87%] [19.50dB] [on]
Simple mixer control 'Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
Simple mixer control 'Caller ID',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 99 [82%] [19.50dB]
  Front Right: Capture 99 [82%] [19.50dB]
Simple mixer control 'External Amplifier',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Off-hook',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Comment 8 Tommaso Pasini 2008-11-09 14:23:05 UTC
Created attachment 171186 [details]
Configuration used with alsa-driver-1.0.18
Comment 9 Tommaso Pasini 2008-11-09 14:23:42 UTC
Created attachment 171187 [details]
Configuration used with vanilla-sources-2.6.27.4
Comment 10 Daniel Drake (RETIRED) gentoo-dev 2008-11-09 14:44:01 UTC
If you're really keen and have time to spare, this process will help you find the exact kernel commit that introduced the regression:
http://www.reactivated.net/weblog/archives/2006/01/using-git-bisect-to-find-buggy-kernel-patches/
Comment 11 Tommaso Pasini 2008-11-09 14:49:31 UTC
I'll do my best, thank you.
Comment 12 Tommaso Pasini 2008-11-09 22:37:23 UTC
I got it! 31 kernels and maybe 40 reboots (damned alsaconf!), but here it is.

5d5d5f43f1b835c375de9bd270cce030d16e2871 is first bad commit
commit 5d5d5f43f1b835c375de9bd270cce030d16e2871
Author: Takashi Iwai <tiwai@suse.de>
Date:   Tue Feb 12 12:11:36 2008 +0100

    [ALSA] hda-codec - Implement auto-mic jack sensing on Samsung laptops
    
    Implemented the auto-mic jack sensing for Samsung laptops with AD1986A
    codec chip (model=laptop-eapd).
    
    The hardware uses pin 0x1d and 0x1f for the internal and external
    mics, respectively.
    
    Signed-off-by: Takashi Iwai <tiwai@suse.de>

:040000 040000 bdedbeceda4a6afc6c37302784be18523ca37b65 6b023b54ab4ef9cee8cefae779899ec88f16a356 M	sound

The weird thing is that my laptop is an Asus and not a Samsung... anyway, I posted also on ALSA bugtracker, https://bugtrack.alsa-project.org/alsa-bug/view.php?id=4228
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2008-11-17 23:34:04 UTC
That's great, thanks so much! I just sent a mail upstream to prod them into action (hopefully) :)
Comment 14 Daniel Drake (RETIRED) gentoo-dev 2008-11-18 23:18:51 UTC
Please run the alsa-info script on both a broken and a working kernel, and upload the 2 output files here.

You can get alsa-info.sh from here:
http://git.alsa-project.org/?p=alsa-driver.git;a=blob_plain;f=utils/alsa-info.sh

Run it with the "--no-upload" option. Thanks!
Comment 15 Tommaso Pasini 2008-11-20 00:08:13 UTC
Created attachment 172423 [details]
alsa-info.sh output ran on a 2.6.25 (working) kernel
Comment 16 Tommaso Pasini 2008-11-20 00:08:55 UTC
Created attachment 172424 [details]
alsa-info.sh output ran on a 2.6.26 (not working) kernel
Comment 17 Tommaso Pasini 2008-11-20 00:15:24 UTC
Here they are.
I ran alsa-info.sh on kernels where ALSA was compiled as built-in, so no modules are loaded; I did the git-bisect procedure with ALSA compiled as modules, instead. I don't think this should vary the results, in case tell me and I'll rebuild both kernels.

I saw in the email that Takashi Iwai asked to open a bug entry in bugzilla.kernel.org, will you do that or should I?
Comment 18 Daniel Drake (RETIRED) gentoo-dev 2008-11-20 00:37:46 UTC
Yes, please go ahead and do that (and attach the 2 files). Thanks!
Comment 19 Tommaso Pasini 2008-11-20 00:55:01 UTC
Created attachment 172431 [details]
alsa-info.sh output ran on a 2.6.25 (working) kernel, modules
Comment 20 Tommaso Pasini 2008-11-20 00:55:30 UTC
Created attachment 172432 [details]
alsa-info.sh output ran on a 2.6.26 (not working) kernel, modules

Here they are!
Comment 21 Daniel Drake (RETIRED) gentoo-dev 2008-11-20 10:41:25 UTC
Sorry, I should answer your question more clearly. No need to change builtin vs modules.

Please go ahead and file an upstream kernel bug and attach the files there (either set, don't need to do both).
Comment 22 Tommaso Pasini 2008-11-20 20:36:20 UTC
I understood the right meaning of your message just after attaching the last file, but it was already 2 am so I postponed to today. :-)

I opened the bugreport on bugzilla.kernel.org, it can be found here http://bugzilla.kernel.org/show_bug.cgi?id=12070

The file outputs of alsa-info posted here are different from the two on bugzilla.kernel, because there are instructions not to open bugs about distro-kernels or anything with binary modules loades; so, to be sure the bug doesn't get rejected just because of this, I built two vanilla kernels and re-ran the script onto them.
Comment 23 mikopp 2008-11-24 09:09:15 UTC
hi,

Does this work in  2.6.26-r3? r3 just got marked stable (http://bugs.gentoo.org/show_bug.cgi?id=245638) and is based on 2.6.26.6 but according to the upstream bug this is not fixed until 2.26.8 which would be r4.

I'm new to this but shouldn't r3 be unstable if it still has this issue?
Comment 24 Daniel Drake (RETIRED) gentoo-dev 2008-11-24 09:37:09 UTC
(In reply to comment #23)
> Does this work in  2.6.26-r3? r3 just got marked stable
> (http://bugs.gentoo.org/show_bug.cgi?id=245638) and is based on 2.6.26.6 but
> according to the upstream bug this is not fixed until 2.26.8 which would be r4.

2.6.26-r3 includes 2.6.26.8. And on the upstream bug he is saying that the fix that Takashi posted works with 2.6.26.8, not that the 2.6.26.8 includes the fix.

The next step on this bug is to locate the exact fix which Takashi made as an isolated patch, and add it to our kernel.
Comment 25 mikopp 2008-11-24 10:14:39 UTC
OK, Sorry for the mistake.

Anyway, but it means that this is still open for 2.6.26-r3. Shouldn't it be marked as unstable then?
Comment 26 Daniel Drake (RETIRED) gentoo-dev 2008-11-24 10:39:56 UTC
Unkeywording a stable version will cause more damage than good. The best way to proceed is to fix this bug as quickly as we can. If you'd like to help further, the "next steps" are outlined above, and please feel free to ask in #gentoo-kernel on IRC or the gentoo-kernel mailing list if you need help getting started. Thanks!
Comment 27 Daniel Drake (RETIRED) gentoo-dev 2008-11-25 10:09:38 UTC
Nick Loeve found identified the patch at http://tinyurl.com/5skjh2 which we have now queued for 2.6.26 and 2.6.28, thanks!
Comment 28 Tommaso Pasini 2008-11-25 19:25:08 UTC
What do you mean with "queued"?

Anyway, I tried to brutally overwrite patch_analog.c in 2.6.28-rc6 with the one you linked, but compilation fails. Still, alsa-driver snapshots don't create modules that I can load successfully.

I'm cloning tiwai's git tree to see if I can compile them as built-in, I'll post updates.
Comment 29 Daniel Drake (RETIRED) gentoo-dev 2008-11-26 10:21:11 UTC
Personally I wouldn't worry, assuming you have a working configuration. By queued I mean it will appear in the next gentoo-sources release. I'm confident that (thanks to Takishi) we have already isolated and fixed the bug with this patch.
Comment 30 Tommaso Pasini 2008-12-04 23:59:05 UTC
I hope you're right; but I just compiled 2.6.28-rc7 and it is still.
Comment 31 Tommaso Pasini 2008-12-04 23:59:59 UTC
Oops! "...it is still deaf" :)
Comment 32 Daniel Drake (RETIRED) gentoo-dev 2008-12-05 00:20:35 UTC
yeah, the patch hasn't made it into 2.6.28 yet upstream, but we'll be sure to take care of it in gentoo and submit for linux-stable where appropriate
Comment 33 Daniel Drake (RETIRED) gentoo-dev 2008-12-06 10:29:20 UTC
Fixed in gentoo-sources-2.6.27-r5 and gentoo-sources-2.6.26-r4, thanks for your help solving this
Comment 34 Tommaso Pasini 2008-12-06 13:10:44 UTC
It's working, I love you guys.