Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 235640 - GUI Install on Thinkpad X60S failed: Error listing the kernels in boot
Summary: GUI Install on Thinkpad X60S failed: Error listing the kernels in boot
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Installer
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-25 00:52 UTC by choo
Modified: 2009-05-03 17:21 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description choo 2008-08-25 00:52:06 UTC
When installing to a Thinkpad X60S with a livecd-i686-installer-2008.0-r1.iso by USB with the method shown at http://www.gentoo.org/doc/en/liveusb.xml, and using the GUI installer, the install fails following the network setup section with: 

GLIException: BootloaderError :FATAL: _configure_grub: Error listing the kernels in /boot

Partition Setup:
/dev/sda4 ext3 27.00 GB /
/dev/sda5 linux-swap 1.95GB (shared with other distros)
/dev/sda6 ext2 31.34 MB /boot (extended partition in /dev/sda2 exclusively for booting Gentoo)

Reproducible: Always

Steps to Reproduce:
1. Get livecd-i686-installer-2008.0-r1.iso and copy to USB by http://www.gentoo.org/doc/en/liveusb.xml
2. Partition disks as shown in Description section
3. Boot by USB, with doscsi flag, and install with GUI installer in X
4. Install fails by "GLIException: BootloaderError :FATAL: _configure_grub: Error listing the kernels in /boot" following the network interface setup section.

Actual Results:  
Install fails

Expected Results:  
Install completes

Target hardware:

    *  One of the following low voltage processors, supporting Intel Virtualization Technology (available since bios version 2.06):
          o Intel Core Duo (Yonah) CPU L2500 @ 1.83 GHz
    * Intel Graphics Media Accelerator 950
          o 12.1" TFT display with 1024x768 resolution (UL, 180 nits) 
    * 1024 MB PC2-5300 memory standard
    * 80 GB 5400 rpm SATA 2.5" HDD
    * IBM Active Protection System
    * AD1981HD HD Audio 1.0 controller
    * Intel Gigabit Ethernet Controller
    * MiniPCI Express slot with one of the following:
          o Intel PRO/Wireless 3945ABG Mini-PCI Express Adapter
    * IBM Embedded Security Subsystem 2.0
    * Integrated Fingerprint Reader on some models
    * SD Card slot with IO support
    * CardBus slot (Type 2)
    * Firewire (IEEE1394) 


USB Media used:

* Kingston DataTraveler 2GB


Partitions:

/dev/sda1 ext3 45GB (Ubuntu)
/dev/sda4 ext3 27GB (Gentoo /) <-- installing here
/dev/sda3 ext3 5GB (Backtrack 3)
/dev/sda2 extended 
    /dev/sda5 linux-swap 1.95GB
    /dev/sda6 ext2 35MB (Gentoo /boot) <-- Gentoo boot partition here
    /dev/sda-1 unallocated 1.10GB
Comment 1 Dawid Węgliński (RETIRED) gentoo-dev 2008-08-25 00:56:46 UTC

*** This bug has been marked as a duplicate of bug 230998 ***
Comment 2 choo 2008-08-25 02:29:36 UTC
I've seen that bug already. It was resolved with the release of livecd-i686-installer-2008.0-r1.iso. I'm installing with r1, now, and it's still failing.
Comment 3 Preston Cody (RETIRED) gentoo-dev 2008-08-27 00:50:06 UTC
I have to admit, I've never done a USB install with the installer, not even during all my years of testing it.  Therefore I'm not sure how much support I'll be able to give you.
Can you list what kernels are in /boot?  Does it look like the kernel was created/copied correctly?
Comment 4 choo 2008-08-28 03:42:51 UTC
/boot/System.map-genkernel-x86-2.6.24-gentoo-r5
Comment 5 choo 2008-08-28 03:44:09 UTC
And how can I tell if it's been created/copied properly?
Comment 6 Andrew Gaffney (RETIRED) gentoo-dev 2009-05-03 17:21:35 UTC
The installer is deprecated.