Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235619 - More sys-libs/ss sys-libs/com_err stuff; ffmpeg this time
Summary: More sys-libs/ss sys-libs/com_err stuff; ffmpeg this time
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Robert Piasek (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-24 16:06 UTC by Michael Evans
Modified: 2012-10-07 08:02 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Evans 2008-08-24 16:06:45 UTC
paludis -pi ffmpeg

* sys-libs/ss::installed [! blocking]
    Reasons: sys-libs/e2fsprogs-libs-1.41.0:0::installed
* sys-libs/com_err::installed [! blocking]
    Reasons: sys-libs/e2fsprogs-libs-1.41.0:0::installed
* media-video/ffmpeg [U 0.4.9_p20070616-r20 -> 0.4.9_p20080326] <target>
    X a52 aac (-altivec) -amr -bindist+ -debug -doc encode -hardcoded-tables+ ieee1394 -imlib ipv6 mmx mp3+ -network -sdl -test theora -threads truetype vorbis x264 xvid zlib
    2.39 MBytes to download

Reproducible: Always

Steps to Reproduce:
use paludis
update
paludis -i ffmpeg


Expected Results:  
installation of ffmpeg

I can't actually see where in ffmpeg it's being pulled in, and I don't know paludis well enough to know how to interrogate it to find out.

sys-libs/e2fsprogs-libs-1.41.0:0 is installed, and is supposed to provide both of the things that are blockers.  I was able to install other applications without issue, but this is blocking pretty much any media playback due to various things depending on ffmpeg being rebuilt to relink against other basic libraries.
Comment 1 Jeroen Roovers gentoo-dev 2008-08-25 01:29:32 UTC
I have no idea either - relaying to paludis package maintainers.
Comment 2 Michael Evans 2008-08-25 05:16:15 UTC
Adding spb@gentoo.org as CC, because they seem to be the one most associated with filed bugs that match a search for paludis; and I have no idea how to find the package maintainer either.  Hopefully they're either who we're looking for, or have the knowledge of how to find them.
Comment 3 Michael Evans 2008-08-26 04:29:06 UTC
It still shows the same dependencies, but I thought of trying the same thing I did to get the other library to install and it worked to allow me to force ffmpeg to build.

paludis -i --dl-blocks discard ffmpeg

This is a workaround, not a resolution; there's still something wrong that should be resolved.
Comment 4 Thomas Anderson (tanderson) (RETIRED) gentoo-dev 2008-08-26 18:41:52 UTC
vfi

*** This bug has been marked as a duplicate of bug 234907 ***
Comment 5 Michael Evans 2008-08-28 01:47:55 UTC
 ------- Comment  #4 From Thomas Anderson  2008-08-26 18:41:52 0000   -------

vfi

*** This bug has been marked as a duplicate of bug 234907 ***


This is an extension/separate issue:  The problem still exists for paludis users.

Additionally: as of right now...


/usr/bin/paludis --debug-build split --continue-on-failure if-satisfied --dl-reinstall if-use-changed --dl-suggested install --dl-reinstall-scm weekly --dl-downgrade error -ip ffmpeg
Building target list...
Building dependency list...

These packages will be installed:

* sys-libs/ss::installed [! blocking]
    Reasons: sys-libs/e2fsprogs-libs-1.41.0:0::installed
* sys-libs/com_err::installed [! blocking]
    Reasons: sys-libs/e2fsprogs-libs-1.41.0:0::installed
* media-video/ffmpeg [R 0.4.9_p20080326] <target>


AND


/usr/bin/paludis --debug-build split --continue-on-failure if-satisfied --dl-reinstall if-use-changed --dl-suggested install --dl-reinstall-scm weekly --dl-downgrade error -ip nvidia-drivers
Building target list...
Building dependency list...

These packages will be installed:

* sys-libs/ss::installed [! blocking]
    Reasons: sys-libs/e2fsprogs-libs-1.41.0:0::installed
* sys-libs/com_err::installed [! blocking]
    Reasons: sys-libs/e2fsprogs-libs-1.41.0:0::installed
* x11-drivers/nvidia-drivers [R 173.14.12] <target>
    Reasons: media-video/nvidia-settings-173.14.12:0::installed, x11-base/xorg-server-1.4.2:0::installed
    acpi -custom-cflags gtk (-multilib) kernel: (linux)



I suspect this both of these are depending on something else (possibly the same, possibly not) which is where the real issue is.  Only I don't know, and can't see, any paludis instruction to provide me with a proper way of producing output that I can make sense of to see what is pulling in what...
Comment 6 Michael Evans 2008-08-28 02:35:20 UTC
This was actually more of an extension than I realized.

It seems that 'discard' is actually more like 'ignore'.


The problem is the lack of a clear (and hopefully automatic) upgrade path when packages are split-up to different names.

Probably at least a paludis news item is in order.


paludis -u sys-libs/ss sys-libs/com_err
reconcilio

 ------- Comment  #38 From Michael Evans  2008-08-21 11:50:36 0000   -------

Paludis steps that work:

Verify ONLY the two blocks mentioned above exist for this.
paludis -ip e2fsprogs-libs

(The second is optional)
paludis --dl-blocks discard -if e2fsprogs-libs
paludis --dl-blocks discard -ip e2fsprogs-libs
paludis --dl-blocks discard -i e2fsprogs-libs
Comment 7 Pacho Ramos gentoo-dev 2012-04-06 14:47:39 UTC
Is this still valid today? If not, feel free to close this bug please
Comment 8 Pacho Ramos gentoo-dev 2012-10-07 08:02:43 UTC
(In reply to comment #7)
> Is this still valid today? If not, feel free to close this bug please