Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235204 - net-misc/nxserver-freenx-0.7.2-r2: round-robin loadbalance broke
Summary: net-misc/nxserver-freenx-0.7.2-r2: round-robin loadbalance broke
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-08-19 16:55 UTC by Simon Gao
Modified: 2008-08-25 18:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info file (emerge.info,3.08 KB, text/plain)
2008-08-19 21:30 UTC, Simon Gao
Details
Upstream SVN fixes for round-robin loadbalance (nxserver-freenx-0.7.3-roundrobin.patch,4.03 KB, patch)
2008-08-25 09:37 UTC, Bernard Cafarelli
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Gao 2008-08-19 16:55:41 UTC
With FreeNX-0.7.2-r2, the loadbalance only works with "random" mode. "round-robin" mode does not work. 

Reproducible: Always

Steps to Reproduce:
1. emerge freenx-0.7.2-r2
2. configure loadbalance
3. run nxclient from a client machine to test

Actual Results:  
if set "round-robin" mode, then NX client will connect to the FreeNX server only even if the server is not specified in the pool of load balancing servers. 

Expected Results:  
When set "round-robin" mode, the FreeNX server will pass NX connections to each server in turn.

Related part in node.conf:

SERVER_LOADBALANCING="Yes"
LOAD_BALANCE_SERVERS="192.168.10.11 192.168.10.12 192.168.10.13"
LOAD_BALANCE_ALGORITHM="round-robin"
ENABLE_LOAD_BALANCE_PREFERENCE="1"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2008-08-19 21:19:11 UTC
Please post your `emerge --info' too.
Comment 2 Simon Gao 2008-08-19 21:30:43 UTC
Created attachment 163331 [details]
emerge --info file

Please see attached file for emerge --info result.
Comment 3 Bernard Cafarelli gentoo-dev 2008-08-22 13:08:23 UTC
I think I have seen e-mails on the freenx list where the setup included round-robin load balancing (working), and there is no Gentoo-specific behavior in this part... 

Can you try with 0.7.3? I've just added it to portage

Comment 4 Simon Gao 2008-08-23 00:00:09 UTC
>Can you try with 0.7.3? I've just added it to portage 

I got the same problem with 0.7.3.  

The configuration change from stock node.conf for 0.7.3 is minimal with only three lines:

ENABLE_SSH_AUTHENTICATION="1"
LOAD_BALANCE_SERVERS="192.168.x.x 192.168.x.x"
LOAD_BALANCE_ALGORITHM="round-robin" 
Comment 5 Bernard Cafarelli gentoo-dev 2008-08-25 09:37:04 UTC
Looks like upstream quickly found the problem after your mail!

There was another commit to fix "--terminate|--suspend|--force-terminate for load balancing", so I'll probably add a patch with the 2 commits. Can you test it?
Comment 6 Bernard Cafarelli gentoo-dev 2008-08-25 09:37:43 UTC
Created attachment 163749 [details, diff]
Upstream SVN fixes for round-robin loadbalance
Comment 7 Simon Gao 2008-08-25 18:10:05 UTC
The patch fixed the round-robin problem. Thanks.
Comment 8 Bernard Cafarelli gentoo-dev 2008-08-25 18:36:20 UTC
Thanks for the confirmation, patch added to portage in new 0.7.3-r1 ebuild